Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запуск общего модуля из модуля объекта

Запуск общего модуля из модуля объекта
Я
   Григорий256
 
02.06.21 - 11:26
Доброго времени суток!
Есть такое задание"Создайте константу «Граница учета», тип данных «Дата», включите ее в подсистему «Настройки».
Для всех документов, дата которых раньше этой границы, необходимо запретить отмену проведения и перепроведение.
Но данное правило не распространяется на непроведенные документы. То есть проведение новых документов и непроведенных ранее документов допустимо с любой датой.
Процедура проверки должна быть одна для всех документов и располагаться в общем модуле"

Код:
&НаСервере
Процедура ПроверкаДок(Отказ, РежимЗаписи, РежимПроведения,НовыйДокумент,Дата,Проведен) Экспорт

     КонстантаГраница = Константы.ГраницаУчета.Получить();
        Если Не НовыйДокумент  и РежимЗаписи<>РежимЗаписиДокумента.Запись Тогда
        Если Дата<КонстантаГраница И Проведен Тогда
              
   Сообщить("Данное действие не допустимо, граница проведения документа превышена"+КонстантаГраница);
   Отказ  = Истина;
   КонецЕсли;
   КонецЕсли;

КонецПроцедуры

Не понимаю как запустить в модуле объекта данный код.Подскажите пожалуйста!!!
 
 Партнерская программа EFSOL Oblako
   polosov
 
1 - 02.06.21 - 11:30
(0) Тебе нужно использовать подписку на события, если это тестовая конфигурация.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.