Вход | Регистрация
 

В обработчике печати не был сформирован табличный документ для:

В обработчике печати не был сформирован табличный документ для:
Я
   shira84
 
01.06.21 - 17:43
Сегодня вышло обновление по зарплате гос учреждения, и не могу понять почему перестало работать
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.3.1.73");
    ПараметрыРегистрации.Информация = НСтр("ru = 'Список перечислений (банк)'");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
    ПараметрыРегистрации.Версия = "1.1.1.1";
    ПараметрыРегистрации.Назначение.Добавить("Документ.ВедомостьНаВыплатуЗарплатыВБанк");
    
    Команда = ПараметрыРегистрации.Команды.Добавить();
    Команда.Представление = НСтр("ru = 'Список перечислений (банк)'");
    Команда.Идентификатор = "СписокПеречисленийВБанк";
    Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    Команда.ПоказыватьОповещение = Истина;
    Команда.Модификатор = "ПечатьMXL";
    
    Возврат ПараметрыРегистрации;
КонецФункции

Процедура Печать(МассивОбъектов,
                КоллекцияПечатныхФорм,
                ОбъектыПечати,
                ПараметрыВывода) Экспорт
    
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ПФ_MXL_СписокПеречисленийНаЛицевыеСчета1") Тогда
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ПФ_MXL_СписокПеречисленийНаЛицевыеСчета1",
            "Список перечислений в банк", ПечатьСписокПеречисленийБанк(МассивОбъектов, ОбъектыПечати),,"ПФ_MXL_СписокПеречисленийНаЛицевыеСчета1");
    КонецЕсли;
    
КонецПроцедуры

Функция ПечатьСписокПеречисленийБанк(МассивОбъектов, ОбъектыПечати)

        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("ПФ_MXL_СписокПеречисленийНаЛицевыеСчета1");
    ОбластьМакетаШапкаДокумента  = Макет.ПолучитьОбласть("ШапкаДокумента");
    ТабличныйДокумент.Вывести(ОбластьМакетаШапкаДокумента);
    Возврат ТабличныйДокумент;
    
КонецФункции
 
 Партнерская программа EFSOL Oblako
   mikecool
 
1 - 01.06.21 - 17:50
не формируется выходной макет, почему - смотри в отладке
   mikecool
 
2 - 01.06.21 - 17:51
+1 при формировании может быть исключение, либо модуля уже нет, либо функции...
   shira84
 
3 - 01.06.21 - 17:56
Так нет никаких функций в чем весь прикол то. Щас попробую кэш-мэш-перезагрузка...
   SleepyHead
 
4 - 01.06.21 - 17:57
(0) В описании - обновили версию БСП, смотри, что поменялось.
Вот сейчас сам на тестовую базу ставлю обновление, буду проверять внешние печатные формы.
   SleepyHead
 
5 - 01.06.21 - 18:18
У меня все внешние формы работают на 3.1.18.46, как и раньше.
   SleepyHead
 
6 - 01.06.21 - 18:19
(0) Ты патчи ставил? Мне пришлось все патчи удалить, потому что в 1с-Предприятии после обновления были ошибки. Убрал все патчи. обновление завершилось.
   shira84
 
7 - 01.06.21 - 19:22
(6) в общем ошибка оказалась в параметрах  УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(), убрал последний параметр "ПолныйПутьКМакету" "ПФ_MXL_СписокПеречисленийНаЛицевыеСчета1" и все заработало. Раньше этот параметр был и работало все отлично, сейчас видимо что-то поменяли

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.