Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Сохранение шаблона ворд без указания пути папки

Сохранение шаблона ворд без указания пути папки
Я
   nikolaii1902
 
28.05.21 - 14:43
Здравствуйте, реализовал сохранение шаблона ворд в формат пдф и ворд, можно ли как то исправить код, чтобы автоматически доки открывались заданных в форматах без указания пути в целом?
буду рад, если поможете

&НаСервере
Процедура Серверная()
    ТрудовойДоговор=РеквизитФормыВЗначение("Объект").ПолучитьМакет("ТрудовойДоговор");
    // Получить объект из макета.
    MSWord = ТрудовойДоговор.Получить();

    Попытка
        Документ = MSWord.Application.Documents(1);
        Документ.Activate();
        // Получить объект, который будет использоваться для поиска и замены.
        Замена = Документ.Content.Find;
        // Заменить заранее определенные ключевые конструкции на требуемый текст.
        Замена.Execute("<Ruk>", Ложь, Истина, Ложь, , , Истина, , Ложь, Директор );
        //и тд.....            
        // Вкл видимость приложения и активизируем его.      
        //MSWord.Application.Visible = Истина;
        MSWord.Activate();
        Если РольДоступна("Администратор") Тогда
        MSWord.SaveAS("D:\файл пдф\"+ Объект.Номер +".pdf",17 );
    КонецЕсли;
        Если РольДоступна("Бухгалтер") Тогда
        MSWord.SaveAs("D:\файл пдф\"+ Объект.Номер +".docx" , 16);
        КонецЕсли;    
        Исключение
        // Если произойдет ошибка, выводятся данные об ошибке, и объект закрывается.
        Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = ОписаниеОшибки();
        Сообщение.Сообщить();    
        MSWord.Application.Quit();
    КонецПопытки;     
КонецПроцедуры
 
 Партнерская программа EFSOL Oblako
   nikolaii1902
 
1 - 28.05.21 - 14:44
(0) все сохраняет, но если вдруг использовать это на другом ПК, нужно будет постоянно менять местоположение папки для сохранения.
   unknown181538
 
2 - 29.05.21 - 18:53
(0) Использовать каталог временных файлов.
ПолучитьИмяВременногоФайла()
   Garykom
 
3 - 29.05.21 - 22:46
а если база sql на сервере 1С? или опубликована через веб-сервер? и там нетути ворда?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.