Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Водяные знаки в печатной форме

v7: Водяные знаки в печатной форме
Я
   Volodja
 
28.05.21 - 12:39
Собственно есть две базы. Одна тренировочная, другая рабочая. На все отчеты которые будут выводиться из тренировочной решили наложить водяные символы, например "Тестовая база".
Создал WordArt объект в Worde задал прозрачность. Вроде знаки устраивают.
Но проблема в том, что если рисунок с водяными знаками не помещается в выгружаемую секцию, то он и не выводится. Хотелось бы иметь одну надпись на весь лист, а не подгонять под секцию. Т.е хочется наложить рисунок с фоном на уже сформированный отчет и маштабировать его.
в 8- ке вроде для этого есть ТабДок.ФоновыйРисунок()
Спасибо.
 
 Партнерская программа EFSOL Oblako
   trdm
 
1 - 28.05.21 - 12:54
ёксил?
   trdm
 
2 - 28.05.21 - 12:55
или в принцыпе посылать печатную форму на печать через 8-ку...
   Volodja
 
3 - 28.05.21 - 12:57
МенеджерТабличного Документа копаю от Trad
   Volodja
 
4 - 28.05.21 - 12:58
(2) нет там 8-ки
   trdm
 
5 - 28.05.21 - 13:33
У меня 8-ка конвертит таблицы в  pdf :)
   Злопчинский
 
6 - 28.05.21 - 13:34
Формекс. Глобальная предопределенная
Процедура ПриПечатиТаблицы(<?>,,)КонецПроцедуры
Синтаксис:
Процедура ПриПечатиТаблицы(<Таблица>,<ФлагПредпросмотра>,<Заголовок>,<ИмяПринтера>)КонецПроцедуры
Назначение:
Процедура, вызываемая при печати табличного документа.
Параметры:
<Таблица> - (Таблица) объект ''Таблица''
<ФлагПредпросмотра> - (Число) флаг предпросмотра
<Заголовок> - (Строка) заголовок таблицы
<ИмяПринтера> - имя принтера, на который отправлена печать
.
   Volodja
 
7 - 28.05.21 - 14:14
(6)  А как водяные знаки появятся?
   Volodja
 
8 - 28.05.21 - 14:16
(5) через Йоксель тоже можно.И в JPG еще
   Злопчинский
 
9 - 28.05.21 - 14:18
Поставь в систему дубль-принтер где в свойтсвах принтера настроить "водяные знаки" (вроде атк можно), перехватывать печать и перенаправлять на принтер-дубль
   Злопчинский
 
10 - 28.05.21 - 14:18
..может быть.. типа так...
   Злопчинский
 
11 - 28.05.21 - 14:19
" На все отчеты которые будут выводиться из тренировочной решили наложить водяные символы, например "Тестовая база"."
в тренировочнй базе В ОБЯЗАТЕЛЬНО выводить ВЕЗДЕ КОЛОНТИТУЛЫ с указанием ТЕСТОВАЯ БАЗА
   Cthulhu
 
12 - 28.05.21 - 14:21
(7): а в полученную (в первом параметре) таблицу - никак не добавить?
   Volodja
 
13 - 28.05.21 - 14:21
(6) Это я понял, что я здесь перехвачу событие? Ок, спасибо. Вы меня опередили.
   Volodja
 
14 - 28.05.21 - 14:23
(11) Про колонтитулы думали, но могут смошенничать и отрезать сверху и снизу
   Злопчинский
 
15 - 28.05.21 - 14:23
(14) херня какая. могут смошенничать и все что надо в экселе сделать.
   Volodja
 
16 - 28.05.21 - 14:24
Хотелось бы через весь лист, по диагонали.Здоровенными, водяными буквами
   Злопчинский
 
17 - 28.05.21 - 14:24
(14) При перехвате таблицы ее можно еще тупо логгировать обычной записью в папку на диск, в протокол куда-нить...
   Volodja
 
18 - 28.05.21 - 14:25
(15) Ну да. Я им тоже про это.
   Volodja
 
19 - 31.05.21 - 07:43
(6) А можно ли программно задать текст колонтитула или только через конфигуратор открывать каждую таблицу и записывать текст или вызов функции. Просто таблиц много, а раз можно перехватить печать, то может быть можно и добавить нужный колонтитул?
   Фомич
 
20 - 31.05.21 - 08:44
(19) в глобальный добавить желаемое, в виде функции и звать сие через [] из колонтитула...
   Фомич
 
21 - 31.05.21 - 08:45
<code>
Функция глВернутьКолонтитулВПечатныйДок(Докум) Экспорт
    
    АвторДокумента    = ?(Докум.Автор.ФизЛицо.Выбран()=1,СокрЛП(Докум.Автор.ФизЛицо.ПолнНаименование),СокрЛП(Докум.Автор));
    АвторПечати        = ?(глПользователь.ФизЛицо.Выбран()=1,СокрЛП(глПользователь.ФизЛицо.ПолнНаименование),СокрЛП(глПользователь.Наименование));
        
    стрПечатиАвтора = ?(Докум.Автор<>глПользователь,"Документ создал: "+АвторДокумента+", напечатал: "+АвторПечати,"Документ напечатал: "+АвторПечати);
    
    стрВозврата = стрПечатиАвтора+РазделительСтрок+" дата печати: #D, время печати: #T"+РазделительСтрок+" страница: #P из #Q";

    
    Возврат стрВозврата;
    
КонецФункции
<code>
   Volodja
 
22 - 31.05.21 - 08:47
(20) ну а вызов функции то прописывать в каждой таблице же нужно. Открывать таблицу и добавлять нижний или верхний колонтитул.
   Фомич
 
23 - 31.05.21 - 08:48
(20) ну там одну строку скопипастить
[глВернутьКолонтитулВПечатныйДок(Докум)]
не особо затратно...
   Фомич
 
24 - 31.05.21 - 08:50
при особо сильном желании можно в функции проверять базу на "тестовость/боевуюсть" и возвращать разное...
   Volodja
 
25 - 31.05.21 - 08:50
Я поэтому спрашиваю, можно ли без добавления в конфигураторе колонтитула, используя только контекст таблицы программно его туда добавить. Таблиц сейчас вагон с тележкой. И в каждую нужно заходить. А еще пользователям дана возможность создавать внешние шаблоны таблиц.
   Volodja
 
26 - 31.05.21 - 08:51
И не в одной таблице из вагона еще их нет. Колонтитулов.


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.