Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работа со сканером штрихкодов в мобильном приложении ERP

Работа со сканером штрихкодов в мобильном приложении ERP
Я
   cojko
 
26.05.21 - 19:00
Запустил мобильное приложение ERP на ТСД под Андроидом. При попытке зайти в заказ клиента или создать новый выдает Сообщение:
Функциональность "Камера, Микрофон, Библиотека музыки, Библиотека картинок и видео, Воспроизведение аудио и вибрация, Воспроизведение аудио и вибрация в фоновом режиме" отключена в мобильном приложении.

У приложения в андроиде есть доступ и камере и к микрофону. Хотелось просто сканировать ШК штатным сканером ТСД в приложении. Запускал мобильное приложение не на ТСД работает нормально, т.е. проблема не в самой базе.
Подскажите в какую сторону копать?
 
 Партнерская программа EFSOL Oblako
   ДедМорроз
 
2 - 26.05.21 - 20:29
Мобильное приложение штатный сканер не умеет,нужно внешнюю компоненту для перехвата события сканирования ставить.
   cojko
 
3 - 07.06.21 - 14:45
(2) Внешняя компонента даже есть. Как она подключается к мобильному приложению ERP не подскажешь?
   shiling
 
4 - 07.06.21 - 15:06
(3) ну для начала хоть модель назовите модель ТСД и что за компонента
   cojko
 
5 - 07.06.21 - 16:42
Модель Urovo i6300. Компонента RS Core в ней расширения:
1. KBEmu 1.02 Эмуляция сканера как клавиатуры;
2. IO 1.00 Операции ввода/вывода
3. 1С 8.3.6. 1.03 Поддержка 1С 8.3.6-8.3.8 через механизм GCM
4. 1С 8.3.9 1.04 Поддержка 8.3.9 через механизм ВК
   Kassern
 
6 - 07.06.21 - 17:07
(2) как это не умеет?
#Если МобильноеПриложениеКлиент  Тогда

         Если НЕ СредстваМультимедиа.ПоддерживаетсяСканированиеШтрихКодов() Тогда
            ВызватьИсключение НСтр("ru='Сканирование штрихкодов не поддерживается';en='Barcode scanning is not supported'");
            Возврат;
          КонецЕсли;
        ОбработчикСканирования = Новый ОписаниеОповещения("ОбработкаСканирования", ЭтаФорма);
          СредстваМультимедиа.ПоказатьСканированиеШтрихКодов(НСтр("ru='Наведите камеру на штрихкод';en='Aim the camera at an barcode'"), ОбработчикСканирования,, ТипШтрихКода.Все);
    #конецесли
   Kassern
 
7 - 07.06.21 - 17:09
   Kassern
 
8 - 07.06.21 - 17:09
(7) с помощью нее можно подружить сканер ТСД с 1ской
   cojko
 
9 - 07.06.21 - 17:12
(6) Вот не могу понять, что я не включил или не выключил.
Сообщение выдается: Функциональность "Камера, Микрофон, Библиотека музыки, Библиотека картинок и видео, Воспроизведение аудио и вибрация, Воспроизведение аудио и вибрация в фоновом режиме" отключена в мобильном приложении в самой 1С.

Хочу понять в типовом мобильном приложении ERP сканер подключить можно через настройки или нужно разбираться в отладке мобильных приложений, менять код и т.д.
   H A D G E H O G s
 
10 - 07.06.21 - 17:14
(5) Держите.
https://disk.yandex.ru/d/QoMBrD1Vw61_GQ

Для Urovo:
Имя поля - barocode
Имя события - urovo.rcv.message
   H A D G E H O G s
 
11 - 07.06.21 - 17:15
(9) Сканер - как отдельное устройство - через ВК, раньше можно было через внешнее приложение, которое отсылало оповещения, с версии 8.3.12 это зарезали.
Сканер - как фотокамера, которая тебе чето попытается распознать - см (6).
   cojko
 
12 - 07.06.21 - 17:16
(10) Спасибо. Вы можете на (9) прокомментировать. Хочу понять настройками вопрос решается или через конфигуратор. Хочу к мобильному приложению ERP применить.
   Kassern
 
13 - 07.06.21 - 17:17
(9) с типовым МП ERP не работал. Но писал свою нетленку для ТСД. Я просто взял эту библиотеку (7) и на ней сделал свою нетленку. В настройках указал оборудование и все. После этого при сканировании штатно отрабатывает ОбработкаОповещения, где параметром приходит ШК.
   Kassern
 
14 - 07.06.21 - 17:18
(13) если в МП ЕРП уже заложена эта библиотека, то все должно работать из коробки
   cojko
 
15 - 07.06.21 - 17:18
(11) Я правильно понимаю, что мне нужно Мобильное приложение ERP допиливать в конфигураторе? Или мобильное приложение ERP это просто тонкий клиент. И нужно допиливать обычную конфигурацию ERP?
   Kassern
 
16 - 07.06.21 - 17:21
(15) МП это отдельная конфигурация для мобилок.
   Kassern
 
17 - 07.06.21 - 17:22
(15) главное не путать мобильный клиент и мобильное приложение
   Kassern
 
18 - 07.06.21 - 17:23
(15) у вас случаем не https://its.1c.ru/db/remotework/content/4/hdoc ?
   Evgenchik
 
19 - 07.06.21 - 17:30
(7) Нужно собирать приложение в apk-файл или можно обновлением через http-сервис обойтись?
   Kassern
 
20 - 07.06.21 - 17:31
(19) а разница то какая на выходе? Как вам удобнее, так и делайте.
   Kassern
 
21 - 07.06.21 - 17:33
(19) Мне удобнее через http сервис обновлять конфу для МП. Так гораздо быстрее дорабатывать конфу МП и тестить
   Evgenchik
 
22 - 07.06.21 - 17:33
я не знаю, есть ли разница, поэтому и спрашиваю.
   Evgenchik
 
23 - 07.06.21 - 17:34
(21) конечно удобнее, просто у меня событие сканирования не срабатывает. Поэтому и пытаюсь понять, как должно быть правильно.
   Kassern
 
24 - 07.06.21 - 17:36
(22) вы должны понимать, что через apk вы создаете ту же приложуху с платформой и конфой. При обновлении конфы, вам понадобится заново собирать apk файл и передавать на мобилку. Через http сервис, вы всего лишь ставите платформу на мобилку и прописываете путь до конфы в вебе. По факту на выходе что там, что тут нужная платформа с нужной конфой.
   Kassern
 
25 - 07.06.21 - 17:37
(23) Вы можете попробовать создать новую конфу, где будет только лишь библиотека подключаемого оборудования для мобилок и посмотреть как она будет отрабатывать по шк.
   Kassern
 
26 - 07.06.21 - 17:38
(25) а потом на основе демки перенести функционал на свое детище.
   Evgenchik
 
27 - 07.06.21 - 17:41
(26) спасибо за ответы, попробую
   Kassern
 
28 - 07.06.21 - 17:42
(23) После того как ОборудованиеУстройствоВвода определите, можете при открытии сделать следующее:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ОписаниеОшибки = "";
    Если НЕ МенеджерОборудованияКлиент.ПодключитьОборудованиеПоИдентификатору(УникальныйИдентификатор, ОборудованиеУстройствоВвода, ОписаниеОшибки) Тогда
        Сообщить(ОписаниеОшибки);
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия = "Штрихкод" Или ИмяСобытия = "Barcode" Тогда
        ОбработатьШтрихкод(Параметр);

    Иначе
        Сообщить("Данные:" + Параметр);
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПередЗакрытием(Отказ, ЗавершениеРаботы, ТекстПредупреждения, СтандартнаяОбработка)
    МенеджерОборудованияКлиент.ОтключитьВсеОборудование();
КонецПроцедуры
   cojko
 
29 - 07.06.21 - 17:45
(18) У меня именно мобильный клиент. Т.е. я прям расширение сделал и оно сразу отобразилось на мобилке. Значит это сообщение по ошибке сканера можно искать в основной конфигурации.
   Kassern
 
30 - 07.06.21 - 17:48
(29) а зачем вы в заголовке пишите про МП? Про МК вам не подскажу, с ним толком не работал.
 
 
   cojko
 
31 - 07.06.21 - 18:06
(30) Потому  в магазине Android можно скачать только это приложение ERP. Чем там оно по факту является разбираюсь по ходу ))
   cojko
 
32 - 15.06.21 - 18:13
(1) Удалось сдвинуться в этом вопросе с места. В свойствах конфигурации в конфигураторе на сервере, нужно было настроить "Используемую функциональность мобильного приложения". Естественно это потребовало включения возможности изменений. Также я выгружал на ТСД свою версию Мобильного клиента, но возможно это не обязательно. Проверю напишу позже.


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.