Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Настройка обмена УТ11 - БП

Настройка обмена УТ11 - БП
Я
   AlekseiYunniPodavvan
 
26.05.21 - 10:34
Добрый день! Есть типовой обмен, после выгрузки данных в БП, в доки бухгалтер вносит изменения. Случается так, что эти изменения затираются. Как настроить регистрацию изменений в УТ, чтобы выгружались только новые доки, измененные не выгружались второй раз?
 
 Партнерская программа EFSOL Oblako
   AlekseiYunniPodavvan
 
1 - 26.05.21 - 10:34
УТ11.3/БП3
   PuhUfa
 
2 - 26.05.21 - 10:36
(0) написать свой обмен
   AlekseiYunniPodavvan
 
3 - 26.05.21 - 10:37
т.е. настройки синхронизации мне не помогут?
   Йохохо
 
4 - 26.05.21 - 10:59
подождите пока мнение начальника продаж, может они с бухом решат, что совсем друг от друга устали
   AlekseiYunniPodavvan
 
5 - 26.05.21 - 11:33
(4) спасибо, но не по теме
   Pro-tone
 
6 - 26.05.21 - 11:34
(0) есть такое как правила регистрации, шаманить надо в них
   yzimin
 
7 - 26.05.21 - 11:39
Пусть бухгалтер вносит изменения в УТ
   DrZombi
 
8 - 26.05.21 - 11:44
(0) В плане обмена, выгрузки указать, что бы обратно документ не улетали.
Или не улетала к примеру табличная часть.

К примеру в файлике "ExchangeRules.xml" отключена миграция табличной части из БП в ЗУП:

            <Правило>
                <Код>ОтражениеЗарплатыВБухучете</Код>
                <Наименование>Документ: Отражение зарплаты в бухгалтерском учете</Наименование>
                <Порядок>400</Порядок>
                <ПослеЗагрузки>Выполнить(Алгоритмы.ЗаполнитьТЧИзПараметровОбъекта);</ПослеЗагрузки>
                <СинхронизироватьПоИдентификатору>true</СинхронизироватьПоИдентификатору>
                <Источник>ДокументСсылка.ОтражениеЗарплатыВБухучете</Источник>
                <Приемник>ДокументСсылка.ОтражениеЗарплатыВБухучете</Приемник>

... далее по тексту...
                    <Группа Отключить="true">
                        <Код>10</Код>
                        <Наименование>НачисленнаяЗарплатаИВзносы --&gt; НачисленнаяЗарплатаИВзносы</Наименование>
                        <Порядок>350</Порядок>
                        <Источник Имя="НачисленнаяЗарплатаИВзносы" Вид="ТабличнаяЧасть"/>
                        <Приемник Имя="НачисленнаяЗарплатаИВзносы" Вид="ТабличнаяЧасть"/>
                        <ПередОбработкойВыгрузки>//+ отключена выгрузка табличной части

                        Если Параметры.НеВыгружатьПерсональныеДанныеФизическихЛиц Тогда
    Отказ = Истина;
КонецЕсли;</ПередОбработкойВыгрузки>
                        <Свойство>
                            <Код>23</Код>
                            <Наименование>ФизическоеЛицо --&gt; ФизическоеЛицо</Наименование>
                            <Порядок>50</Порядок>
                            <Источник Имя="ФизическоеЛицо" Вид="Реквизит" Тип="СправочникСсылка.ФизическиеЛица"/>
                            <Приемник Имя="ФизическоеЛицо" Вид="Реквизит" Тип="СправочникСсылка.ФизическиеЛица"/>
                            <КодПравилаКонвертации>ФизическиеЛица                                    </КодПравилаКонвертации>
                        </Свойство>

...далее по тексту...
                    <Группа Отключить="true">
                        <Код>30</Код>
                        <Наименование>НачисленныйНДФЛ --&gt; НачисленныйНДФЛ</Наименование>
                        <Порядок>400</Порядок>
                        <Источник Имя="НачисленныйНДФЛ" Вид="ТабличнаяЧасть"/>
                        <Приемник Имя="НачисленныйНДФЛ" Вид="ТабличнаяЧасть"/>
                        <ПередОбработкойВыгрузки>//+ отключена выгрузка табличной части

                        Если Параметры.НеВыгружатьПерсональныеДанныеФизическихЛиц Тогда
    Отказ = Истина;
КонецЕсли;</ПередОбработкойВыгрузки>
                        <Свойство>
                            <Код>37</Код>
                            <Наименование>ВидОперации --&gt; ВидОперации</Наименование>
                            <Порядок>50</Порядок>
                            <Источник Имя="ВидОперации" Вид="Реквизит" Тип="ПеречислениеСсылка.ВидыОперацийПоЗарплате"/>
                            <Приемник Имя="ВидОперации" Вид="Реквизит" Тип="ПеречислениеСсылка.ВидыОперацийПоЗарплате"/>
                            <ПередВыгрузкой>Значение = Параметры.СоответствиеВидыОперацийПоЗарплате[ОбъектКоллекции.ВидОперации];</ПередВыгрузкой>
                        </Свойство>

...далее по тексту ...
                    <Группа Отключить="true">
                        <Код>38</Код>
                        <Наименование>УдержаннаяЗарплата --&gt; УдержаннаяЗарплата</Наименование>
                        <Порядок>500</Порядок>
                        <Источник Имя="УдержаннаяЗарплата" Вид="ТабличнаяЧасть"/>
                        <Приемник Имя="УдержаннаяЗарплата" Вид="ТабличнаяЧасть"/>
                        <ПередОбработкойВыгрузки>//+ отключена выгрузка табличной части

                        Если Параметры.НеВыгружатьПерсональныеДанныеФизическихЛиц Тогда
    Отказ = Истина;
КонецЕсли;</ПередОбработкойВыгрузки>
                        <Свойство>
                            <Код>43</Код>
                            <Наименование>ВидОперации --&gt; ВидОперации</Наименование>
                            <Порядок>50</Порядок>
                            <Источник Имя="ВидОперации" Вид="Реквизит" Тип="ПеречислениеСсылка.ВидыОперацийПоЗарплате"/>
                            <Приемник Имя="ВидОперации" Вид="Реквизит" Тип="ПеречислениеСсылка.ВидыОперацийПоЗарплате"/>
                            <ПередВыгрузкой>Значение = Параметры.СоответствиеВидыОперацийПоЗарплате[ОбъектКоллекции.ВидОперации];</ПередВыгрузкой>
                        </Свойство>

и далее в каждой табличной части... :)
   DrZombi
 
9 - 26.05.21 - 11:46
+(0) в каждой табличной части прописана команда "Отключить="true""

<Группа Отключить="true">
   DrZombi
 
10 - 26.05.21 - 11:46
+ Комментарий там только для того, что бы ты потом нашел свои дописки в план обмена :)
   AlekseiYunniPodavvan
 
11 - 26.05.21 - 11:55
(10) Большое спасибо!
   AlekseiYunniPodavvan
 
12 - 26.05.21 - 12:00
Если весь документ? Перед названием документа "<Группа Отключить="true">"?

Список тем форума
 
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.