Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Бухгалтерия 3.0.Программно заполнить партии в проводках

Бухгалтерия 3.0.Программно заполнить партии в проводках
Я
   jul8851
 
25.05.21 - 19:39
Добрый день!

В счете учета включили Субконто3=Партии. Как заполнить партии в проводках, которые уже проведены ранее?

Спасибо.
   ДенисЧ
 
1 - 25.05.21 - 20:06
получить объект документа, получить набор записей регистра, установить партию, записать набор
   tgu82
 
2 - 25.05.21 - 20:10
(0) А что у вас является партией? Документ прихода?
   RomanYS
 
3 - 25.05.21 - 20:11
(0) списаний не было что ли?
   jul8851
 
4 - 25.05.21 - 20:23
(1) это я понимаю. Не понимаю как обратиться к субконто в регистре бухгалтерии.
   jul8851
 
5 - 25.05.21 - 20:23
(2) да: документ прихода и ввод начальных остатков.
   jul8851
 
6 - 25.05.21 - 20:24
Уточню. Не Бухгалтерия 3, а БГУ 2.0 (выглядит как БП 3.0), извините)
   jul8851
 
7 - 25.05.21 - 20:28
(3) были, их перепроведем. Некоторые документы поступления почему-то не хотят перепроводиться(ругается почему-то, что дебет партии не заполнен), а некоторые проводятся.
Но в вводе остатков ручные операции, поэтому все равно программно надо заполнять.
   Amra
 
8 - 25.05.21 - 20:32
(7) Ууу, как все запущено
   jul8851
 
9 - 25.05.21 - 20:38
(8) суть еще хуже, чем есть на самом деле.
Есть счет 105.31 с пилюльками, и некоторые(!) пилюльки надо списывать по той же цене, по которой они поступили. Остальные-все равно как.
Я нашла только один выход-включить по счету 105.31 субконто Партии(количественный и суммовой). Но теперь их надо как-то заполнить.
Если предложите что-то более вразумительное, буду безмерно благодарна. Бухгалтерию не знаю совсем, но начальник поставил такую задачу(
   Amra
 
10 - 25.05.21 - 20:44
(9) Я бы начал с того, что разобрался, почему часть приходов не проводится. Ибо нет гарантий, что когда начнете вводить новые документы, то они тоже не проведутся
   2S
 
11 - 25.05.21 - 20:49
(9) может все же серии и характеристики раз пилбли?
   jul8851
 
12 - 25.05.21 - 20:56
(10) согласна. Буду разбираться.
   jul8851
 
13 - 25.05.21 - 20:56
(11) для чайника можете написать, если не сложно?
   Amra
 
14 - 25.05.21 - 21:06
(11) В бухгалтерии серии и характеристики?
   comp2006
 
15 - 25.05.21 - 21:24
Как пример:

ДокОбъект = ДокСсылка.ПолучитьОбъект();
Проводки =  ДокОбъект.Движения.Хозрасчетный;
Проводки.Прочитать();
   Для каждого Проводка Из Проводки Цикл
    Если Проводка.СчетКт=Счет60_01 Тогда
       БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, 3, ДокСсылка);
    КонецЕсли;  
   КонецЦикла;
Проводки.Записать();
ДокОбъект.Записать();
   Amra
 
16 - 25.05.21 - 21:56
(15) Последнюю строчку выкинуть нафиг
   jul8851
 
17 - 25.05.21 - 22:04
(15) спасибо. Попробую. Счет60_01 это так к счету можно обращаться или это в качестве примера? Я по коду искала.
   jul8851
 
18 - 07.06.21 - 18:51
Не пойму-что передать в эту процедуру, так не получилось:
БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, 3, ДокСсылка)

Написала так:       
        Сч105_31= ПланыСчетов.ЕПСБУ.НайтиПоКоду("105.31");
    ДокОбъект = Ссылка.ПолучитьОбъект();
    Проводки =  ДокОбъект.Движения.ЖурналПроводокЕПСБУ;
    Проводки.Прочитать();
    Для каждого Проводка Из Проводки Цикл
        Если Проводка.СчетДт=Сч105_31 Тогда
            БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, 3, Ссылка);
        КонецЕсли;  
    КонецЦикла;
    Проводки.Записать();

Выдает ошибку:
"ОбщийМодуль.БухгалтерскийУчет.Модуль(703)}: Поле объекта не обнаружено (СчетРегистрБухгалтерииСубконто.ЖурналПроводокЕПСБУ)
    СвойстваСчета = БухгалтерскийУчетПовтИсп.ПолучитьСвойстваСчета(Проводка["Счет"+ДтКт]);"

Что-то не то передается в параметр ДтКт:
Процедура УстановитьСубконто(Проводка, ДтКт, ИмяСубконто, ЗначениеСубконто) Экспорт
    Если НЕ ЗначениеЗаполнено(ИмяСубконто) Тогда
        Возврат;
    КонецЕсли;
    СвойстваСчета = БухгалтерскийУчетПовтИсп.ПолучитьСвойстваСчета(Проводка["Счет"+ДтКт]);
   Amra
 
19 - 07.06.21 - 19:01
(18) "Дт" или "Кт"
   jul8851
 
20 - 07.06.21 - 19:05
мне надо при "Поступлении МЗ" заполнить СубконтоДт "Партия".

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.