Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Сделать стиль для некоторых справочников 1с

Сделать стиль для некоторых справочников 1с
Я
   bebibo
 
24.05.21 - 15:49
Всем добрый день! Как с помощью средств визуального (цветового) оформления пометить справочники (некоторые) в системе учёта в отдельном стиле и отобразить их в отдельной подсистеме?
 
 Партнерская программа EFSOL Oblako
   bebibo
 
1 - 24.05.21 - 15:55
Создаю объект "Стиль". Выбираю там нужную подсистему и окраску. Но в 1с предприятии ничего не меняется.
   RomanYS
 
2 - 24.05.21 - 15:59
(1) Ты стиль включил в подсистему. Ничего поменяться и не должно было
   bebibo
 
3 - 24.05.21 - 16:01
(2) Ну это был один из вариантов, которые были в моей голове..Тогда как вообще с помощью средств визуального (цветового) оформления пометить справочники в системе учёта в отдельном стиле?
   bebibo
 
4 - 24.05.21 - 16:05
Это вообще реально сделать?(
   RomanYS
 
5 - 24.05.21 - 16:07
(4) Не очень понятно что "это". Раскрасить подсистему в панели разделов? Может и не реально
   acht
 
6 - 24.05.21 - 16:10
Выделить подсистему кадров розовеньким... Концептуально!
   bebibo
 
7 - 24.05.21 - 16:24
(5) Справочники пометить отдельным стилем, чтобы они отличались.
   ДенисЧ
 
8 - 24.05.21 - 16:27
Зачем вообще это извращение? Система должна быть в едином стиле...
   bebibo
 
9 - 24.05.21 - 16:28
(8) Так надо, обязательно. Чтобы некоторые справочники выделялись. Это делается с помощью объекта "Элемент стиля"? Или нет?
   Kassern
 
10 - 24.05.21 - 16:29
(7) конфигурация какая?
   bebibo
 
11 - 24.05.21 - 16:31
(10) Самописная полностью..
   1Сергей
 
12 - 24.05.21 - 16:36
(8) Зачем тогда придумали стили?
   acht
 
13 - 24.05.21 - 16:37
(12) В УФ - для оформления всей системы. Целиком. Полностью. Одинаково.
   acht
 
14 - 24.05.21 - 16:38
(9) > Так надо, обязательно.
Тебя расстреляют, а ты не берись за то, чего не знаешь.
   bebibo
 
15 - 24.05.21 - 16:39
Или может программно как то можно пометить три справочника в отдельном стиле?
   acht
 
16 - 24.05.21 - 16:39
(15) Нельзя. Суши сухари.
   bebibo
 
17 - 24.05.21 - 16:44
(16) Говорят что можно)
   RomanYS
 
18 - 24.05.21 - 16:46
(17) И как? Если только вместо раздела открывать свою форму...
   bebibo
 
19 - 24.05.21 - 16:49
(18) Не знаю как. Вот само задание от преподавателя:
1.На базе реализованной конфигурации из рейтинговой работы первого семестра добавить ещё 3-4 предметно-значимых сущности, увязанных с финансовыми операциями организации. Реализовать документы для ведения данных сущностей. С помощью средств визуального (цветового) оформления пометить данные сущности в системе учёта в отдельном стиле. Отобразить их в отдельной подсистеме.
   trdm
 
20 - 24.05.21 - 16:52
(19) Что типа в общем модуле:
// trdm 2021-19-05 15-23

Функция ОбновитьНадписьНомерДокумента(псЭтотОбъект, псЭтаФорма) Экспорт 
    ЗначВозврата = "";
    вСтатус = ?(псЭтотОбъект.ЭтоНовый(),"(новый)","(сохранен)");
    Если псЭтотОбъект.Проведен  Тогда
        вСтатус = "(проведен)";
    ИначеЕсли псЭтотОбъект.ПометкаУдаления Тогда
        вСтатус = "(пом.удал.)";
    КонецЕсли; 
    вЗаголовок = псЭтотОбъект.Метаданные().Синоним+" "+вСтатус+" №";
    вНадпись = псЭтаФорма.ЭлементыФормы.НадписьНомер;
    вНадпись.Заголовок = вЗаголовок;
    вНадпись.Шрифт = Новый Шрифт(псЭтаФорма.ЭлементыФормы.НадписьДата.Шрифт,,,Истина);
    вНадпись.ЦветТекста = Новый Цвет(153,51,0);// рыжий    

    Возврат ЗначВозврата;
КонецФункции
 
А в форме:
// trdm 2021-12-05 17-22 

Процедура УправлениеДиалогом()
    ДокументыОбщее.ОбновитьНадписьНомерДокумента(ЭтотОбъект,ЭтаФорма);
КонецПроцедуры
   bebibo
 
21 - 24.05.21 - 17:03
А записи в регистре можно цветом выделить? В форме списка? Не все записи, а выборочно.
   RomanYS
 
22 - 24.05.21 - 17:06
(21) да, условным формлением
   bebibo
 
23 - 24.05.21 - 17:08
(22) Не знаю конечно что это, но попробую))
   sikuda
 
24 - 24.05.21 - 17:18
(23) Скорее всего ваши ... фантазии это - https://infostart.ru/public/1215241/
   vis_tmp
 
25 - 24.05.21 - 18:51
(19) Чему учат...


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.