Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Автоматическая подстановка значений из справочника в документ

Автоматическая подстановка значений из справочника в документ
Я
   nikolaii1902
 
22.05.21 - 12:36
Всем добрый день, есть справочник "Организации" и документ "ПриемНаРаботу". При создании документа автоматически нужно подставить реквизиты из справочника. В справочнике одна компания, в которой есть ее реквизиты. Нужно чтобы реквизиты ВидОрганизации, ПолноеНаименование и ЮридическийАдрес подставлялись в документ. Помогите пожалуйста новичку.

Пробовал и так:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Объект.ПолноеНаименование = Справочники.Организации.Объект.ПолноеНаименование;
КонецПроцедуры

И так:
&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
    ЗаполнитьДанные();
КонецПроцедуры
&НаСервере
Процедура ЗаполнитьДанные()
    Объект.ПолноеНаименование = Справочники.Организации.ПолноеНаименование;
КонецПроцедуры

Не понимаю как это реализовать, помогите пожалуйста!
 
 Партнерская программа EFSOL Oblako
   ДенисЧ
 
1 - 22.05.21 - 12:38
"Справочники.Организации.Объект.ПолноеНаименование;"
"Справочники.Организации.ПолноеНаименование;"

10 лет строгого расстрела. Без права переписки и с обязанностью наизусть выучить Митичкина, Радченко и синтакс-помощник.
   mistеr
 
2 - 22.05.21 - 12:38
(0) Чтобы получить доступ к реквизитам, нужно сначала получить ссылку на элемент справочника.
   Garykom
 
3 - 22.05.21 - 12:40
(0) на твоем уровне понимания программирования и 1С к сожалению никак
   Garykom
 
4 - 22.05.21 - 12:41
(2) можно и сам объект получить а не только ссылку ))
   Garykom
 
5 - 22.05.21 - 12:47
(1) Даже если но выучит все это не факт что поможет
Ну научится он единственную организацию из справочника получать и подставлять
Но это же не сделать настройки пользователям в которые можно записать организацию и прочее по умолчанию
   CepeLLlka
 
6 - 22.05.21 - 12:48
(0)А чё тут помогать то? Открываешь ютьюб, ищешь там "Павел Чистов Спец курс", смотришь курс, вникаешь, и всё.
   brainguard
 
7 - 22.05.21 - 13:09
(0) Если есть справочник Организации, значит организаций может быть много. Например, сто. В документ что должно попасть? Все сто организаций?
   nikolaii1902
 
8 - 22.05.21 - 13:16
(7) Так как на основании документа прием на работу я формирую файл ворд, решил в реквизиты формы документа добавить данные об организации, чтобы они подставлялись в шаблоне документа, организация только 1. Поэтому и хотелось бы чтобы подставлялось автоматически.
   nikolaii1902
 
9 - 22.05.21 - 13:17
(5) ха ха
   mistеr
 
10 - 22.05.21 - 13:33
(8) Если организация всегда только одна, можно занести ее в константу.
   Garykom
 
11 - 22.05.21 - 13:33
(9) че хаха? нехрен плохому учиться, сразу нормально делай
   Garykom
 
12 - 22.05.21 - 13:34
(10) зачем? сделать ее предопределенной
   Garykom
 
13 - 22.05.21 - 13:34
(12)+ и тогда код будет ржачно выглядеть почти как в (0)
   Garykom
 
14 - 22.05.21 - 13:35
(13)+ Объект.ПолноеНаименование = Справочники.Организации.Организация.ПолноеНаименование;
   brainguard
 
15 - 22.05.21 - 13:44
(11) Нехрен учиться чему не попадя. Учиться надо основам
   nikolaii1902
 
16 - 22.05.21 - 13:45
(11) (15) я понимаю вашу реакцию, но сказали - сделай, а никакой информации не дали, а времени не так уже много на реализацию, чтобы изучить это хорошо
   brainguard
 
17 - 22.05.21 - 13:49
(8) Если организация только одна, тогда первая задача, которую тебе следует решить - это как выбрать одну организацию из одной. С точки зрения обыденной логики это звучит дико. Но у нас тут компьютер, детка. Он не понимает, что раз организация одна, то и чего тут выбирать. Ты должен сам дать ему инструкции по выбору одной организации из одной. Вариантов сделать это много. Ты можешь использовать любой. Но пока ты не выберешь вариант, ты будешь стоять на месте. Собственно, в этом и суть работы программиста
   acht
 
18 - 22.05.21 - 13:51
(16) А почему ты пришел за информацией к нам, а не к тому, кто дал тебе задачу?
Перед ним палевно, а перед форумом - нет?
   brainguard
 
19 - 22.05.21 - 13:52
(18) Он правильно пришел
   nikolaii1902
 
20 - 22.05.21 - 13:55
(18) а зачем ты сюда написал? что за вопрос..
   acht
 
21 - 22.05.21 - 14:36
(20) Мне весьма интересно наблюдать за персонажами, которые осознаннно, без знаний, бросаются что-то делать, потом садятся на жопу и прибегают на форум, сопровождая просьбы жалобами "мало времени". Обычно подобная тупость сопровождается еще и наглостью, которая почему-то направляется именно в форум, а не к тому, кто ставит задачи.
Ты вот - типичный представитель.
   acht
 
22 - 22.05.21 - 14:37
(19) Мишенька, а возьми его на обучение?
   Garykom
 
23 - 22.05.21 - 15:38
(22) бесплатно?
   Garykom
 
24 - 22.05.21 - 15:40
(21) а вот мне не интересно
раньше с этим было проще, программист = инженер
сейчас же так как многие "без дипломов" и куча вайтишников то наступила легкая профанация профессии

было бы странно если подобная личность приперлась на авто или даже авиазавод в конструкторское бюро
и там получив задачу
полезла на форум: "как мне колесо/крыло прикрепить"


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.