Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Использование параметров ФО

Использование параметров ФО
Я
   NordMad
 
21.05.21 - 11:33
Добрый день, помогите разобраться с параметрами ФО. Для примера создал 2 ФО у каждой в составе 1 реквизит документа (разные), 1 параметр ФО, использование: измерение РС настроек. Создал РС настроек, в нем 1 измерение (оно в использовании параметра указано), 2 ресурса булевых, для каждой ФО. При при создании документа процедура. При этом при открытии формы документа параметр не срабатывает (то есть если в любом ресурсе = истина - соответсвующая ФО включается)

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если ЗначениеЗаполнено(Объект.Организация) тогда
        запрос = новый Запрос;
        запрос.Текст = "ВЫБРАТЬ
                       |    РегистрНастроек.Организация КАК Организация
                       |ИЗ
                       |    РегистрСведений.РегистрНастроек КАК РегистрНастроек
                       |ГДЕ
                       |    РегистрНастроек.Организация = &Организация";
        запрос.УстановитьПараметр("Организация",Объект.Организация);
        выборка = запрос.Выполнить().Выбрать();
        если выборка.Следующий() тогда
            УстановитьПараметрыФункциональныхОпцийФормы(Новый Структура("Организация", выборка.Организация));
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   Бизон
 
1 - 21.05.21 - 11:37
После прочитанного мне придется нажраться
   NordMad
 
2 - 21.05.21 - 11:39
(0) разобрался. Неверный ключ структуры был задан

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.