Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОтменаПроведения как правильно написать

ОтменаПроведения как правильно написать
Я
   Funnilust
 
19.05.21 - 08:35
кнопка ОтменаПроведения. Нажимаю выдает ошибку "Не удалось провести такой то документ" Подскажите какое условие написать в Процедуру ПередЗаписью(Отказ)?
Пробовал
Если НЕ РежимЗаписиДокумента.ОтменаПроведения Тогда
   Отказ = Истина;
КонецЕсли;
 
 Партнерская программа EFSOL Oblako
   Ненавижу 1С
 
1 - 19.05.21 - 08:36
(0) что вообще ты хочешь, я не понял
   DimVad
 
2 - 19.05.21 - 08:39
(0)     Если РежимЗаписи = РежимЗаписиДокумента.ОтменаПроведения Тогда
   Funnilust
 
3 - 19.05.21 - 08:41
(1) Задание дали Нужно было Сделать документ ПриемНаработу
"Нельзя принимать на работу сотрудника два раза, если
не было до этого увольнение"
Теперь когда хочу просто ОтменитьПроведение на Форме Кнопкой ОтменаПроведения То выдает ошибку типа "Неможет быть проведен"
   Почему 1С
 
4 - 19.05.21 - 08:43
Если НЕ РежимЗаписиДокумента.ОтменаПроведения Тогда
   Отказ = Истина;
КонецЕсли;

убери этот код, будет давать отменить проведение же
   Funnilust
 
5 - 19.05.21 - 08:54
(4) 1 раз пишу на форумах
 код убрал. у меня стандартные кнопки Провести и ОтменаПроведения выполняет один код
    Если СотрудникПринятНаРаботу(Сотрудник) Тогда
        Сообщить("Нельзя принят на работу сотрудника, который уже принят");
        Отказ = Истина;
    Возврат;
        
    КонецЕсли;

Проблема в том что Проведенный документ, я не могу Отменить Проведения.
Нашел в интернете что решается через РежимЗаписиДокумента.ОтменаПроведения, но не могу понять логику как и куда написать?
   Mort
 
6 - 19.05.21 - 08:56
(5) Походу не только на форумах в первый раз пишешь. Постарайся задать конкретный вопрос что не получается сделать.
   Почему 1С
 
7 - 19.05.21 - 08:57
Если СотрудникПринятНаРаботу(Сотрудник) И НЕ РежимЗаписиДокумента.ОтменаПроведения Тогда
        Сообщить("Нельзя принят на работу сотрудника, который уже принят");
        Отказ = Истина;
    Возврат;
   Mort
 
8 - 19.05.21 - 08:57
Какое поведение ожидаешь, а какое есть по факту. Вот это двумя пунктами опиши. Это как первые шаги делать - правильно описывать проблему.
   Funnilust
 
9 - 19.05.21 - 09:06
(8) Хорошо; 
Когда нажимаю Стандартную Кнопку ОтменаПроведения, чтобы зеленая птичка проведения у документа исчезла, но получается так, что оно выдает мне ошибку Типа я еще раз провожу документ; а такой документ есть в Регистре.
   ДенисЧ
 
10 - 19.05.21 - 09:08
ОбработкаОтменыПроведения в документе есть?
   Funnilust
 
11 - 19.05.21 - 09:11
(10) нету
   ДенисЧ
 
12 - 19.05.21 - 09:12
(11) Намёк понял?
   Mort
 
13 - 19.05.21 - 09:13
(9) Нашел кусок кода который это сообщение выдаёт?
   Funnilust
 
14 - 19.05.21 - 09:15
(13) Если СотрудникПринятНаРаботу(Сотрудник) Тогда
        Сообщить("Нельзя принят на работу сотрудника, который уже принят");
        Отказ = Истина;
    Возврат;
   Funnilust
 
15 - 19.05.21 - 09:15
(12) (12) Нужно создать Проц ОбработкаОтменыПроведения помимо ОбработкаПроведения?
   ДенисЧ
 
16 - 19.05.21 - 09:17
(15) Растёшь )))
   Funnilust
 
17 - 19.05.21 - 09:28
(7) Пробовал но
Преобразование значения к типу Булево не может быть выполнено
   Kesim
 
18 - 19.05.21 - 09:36
(17) кнопка отмены проведения должна выполнять код обработкиотменыпроведения
   Funnilust
 
19 - 19.05.21 - 09:41
(18) все понял спасибо. Теперь Разобраться как это написать
   youalex
 
20 - 19.05.21 - 09:43
>>И НЕ РежимЗаписиДокумента.ОтменаПроведения

РежимЗаписи <> РежимЗаписиДокумента.ОтменаПроведения
   1Сергей
 
21 - 19.05.21 - 10:03
Правильный ответ был ещё в (2)
   Funnilust
 
22 - 19.05.21 - 11:12
(21) Я только потом узнал, что передЗаписью имеет переменную <РежимЗаписи>


Список тем форума
 
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.