Вход | Регистрация
 

Добавить Итого на ВПФ

Добавить Итого на ВПФ
Я
   bozoozoo
 
14.05.21 - 11:11
Здраствуйте, столкнулся с такой проблемой: Не знаю как вывести общие итоги для количества штук и общего веса, чтоб они были в конце.

ВыборкаСсылка = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока ВыборкаСсылка.Следующий() Цикл
        ОбластьШапка.Параметры.Заполнить(ВыборкаСсылка.Ссылка);
        ТабличныйДокумент.Вывести(ОбластьШапка);
        
        ТабличныйДокумент.Вывести(ОбластьШапкаТаблицы);
        
        
        ВыборкаПрофиль = ВыборкаСсылка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
        Пока ВыборкаПрофиль.Следующий() Цикл
            
            ВыборкаМаркаСтали = ВыборкаПрофиль.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
            Пока ВыборкаМаркаСтали.Следующий() Цикл
                
                ВыборкаШирина = ВыборкаМаркаСтали.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
                Пока ВыборкаШирина.Следующий() Цикл
                    
                    ВыборкаДетальныеЗаписи = ВыборкаШирина.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
                    КоличествоСтрокВТаблице = 0;
                    НомерСтрокиНоменклатуры = 1;
                    
                    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                        
                        ОбластьСтрока.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
                        Если ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.Серия.ксм_НаименованиеПоСертификату) Тогда
                            ОбластьСтрока.Параметры.Номенклатура = ВыборкаДетальныеЗаписи.Серия.ксм_НаименованиеПоСертификату
                        КонецЕсли;
                        ОбластьСтрока.Параметры.Количество = Строка(ВыборкаДетальныеЗаписи.Количество);
                        
                        Если НЕ МожноРазместитьНаОдномЛисте(ТабличныйДокумент, ОбластьСтрока, ОбластьПодвал) Тогда
                            ТабличныйДокумент.Вывести(ОбластьПодвал);
                            ДобавитьНовуюСтраницуТД (ТабличныйДокумент, Макет, ОбластьШапка, ОбластьШапкаТаблицы, КоличествоСтрокВТаблице);
                        КонецЕсли;
                        
                        

                        ТабличныйДокумент.Вывести(ОбластьСтрока);
                        
                        НомерСтрокиНоменклатуры = НомерСтрокиНоменклатуры + 1;
                        
                    КонецЦикла;
                    
                    ОбластьИтогоВтораяСтрока.Параметры.КоличествоИтого = ВыборкаШирина.Количество;
                    ОбластьИтогоВтораяСтрока.Параметры.ксм_КоличествоШтИтого = ВыборкаШирина.ксм_КоличествоШт;
                    
            
                    
                
    //    //Итого
    ТаблицаКоличество = РезультатЗапроса.Выгрузить();
    //    
        ЭтоПерваяСтрока = Истина;
        МассивОбластейИтогов = Новый Массив;
//        МассивОбластейИтогов.Добавить(ОбластьПустаяСтрока);
        МассивОбластейИтогов.Добавить(ОбластьИтогоВтораяСтрока);
      

            
        МассивОбластейИтогов.Добавить(ОбластьИтого);
        ОбластьИтого.Параметры.КоличествоИтого = ВыборкаСсылка.Ссылка.всегомест;

        МассивОбластейИтогов.Добавить(ОбластьПодвал);
        
        
        Если НЕ ТабличныйДокумент.ПроверитьВывод(МассивОбластейИтогов) Тогда
        //    ДозаполнитьТабличныйДокументПустымиОбластями(ТабличныйДокумент, ОбластьПустаяСтрока, ОбластьПодвал);
            ДобавитьНовуюСтраницуТД (ТабличныйДокумент, Макет, ОбластьШапка, ОбластьШапкаТаблицы, КоличествоСтрокВТаблице);
            МассивОбластейИтогов.Удалить(0);
        КонецЕсли;
        
        МассивОбластейИтогов.Удалить(МассивОбластейИтогов.Количество()-1);
        
        Для Каждого Область ИЗ МассивОбластейИтогов Цикл
            ТабличныйДокумент.Вывести(Область);
        КонецЦикла;
 
 Партнерская программа EFSOL Oblako

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.