Вход | Регистрация
 

Отобразить сетку с заголовками во внешней печатной форме программно

Отобразить сетку с заголовками во внешней печатной форме программно
Я
   Энштейн 1С
 
13.05.21 - 16:06
Как отобразить сетку с заголовками во внешней печатной форме документа в 1С:ЗУП 2.5 КОРП, программно? Ручками получается отобразить, программно нет.

Что пробовал и не помогло:

ТабДокумент.ТолькоПросмотр=Ложь;
ТабДокумент.Защита=Ложь;
ТабДокумент.ОтображатьЗаголовки=Истина;
ТабДокумент.ОтображатьСетку=Истина;
Макет.Защита=Ложь;
Макет.ТолькоПросмотр=Ложь;
Макет.ОтображатьСетку=Истина;
 
 Партнерская программа EFSOL Oblako
   Энштейн 1С
 
1 - 13.05.21 - 16:07
Знаю, что просто, но в упор не вижу
   Энштейн 1С
 
2 - 13.05.21 - 16:09
Что-то в общих модулях надо прописывать?
   Энштейн 1С
 
3 - 13.05.21 - 16:09
Настройки пользователей по правам для редактирования таблиц результата тоже не дали
   Энштейн 1С
 
4 - 13.05.21 - 16:10
Ну в чем ДенисЧ может быть проблема?
   Энштейн 1С
 
5 - 13.05.21 - 16:15
Блин никто не знает, даже стыдно, товарищи сеньоры, не знать печатных форм
   BIP1
 
6 - 13.05.21 - 16:21
(5)
Навеяло темой JOB: Как стать программистом 1С за 1-3 месяца?

Уточните у вашего начальника, он такие вещи научит человека делать за 1 месяц?🙂
   Энштейн 1С
 
7 - 13.05.21 - 16:22
(6) Ты решение дай, умник
   Энштейн 1С
 
8 - 13.05.21 - 16:23
(6) Начальник бьет пяткой в грудь что все мои задачи решит за минуту, максимум за час, но когда я давал ему возможность решить проблему, так ни одну проблему самостоятельно не решил
   ДенисЧ
 
9 - 13.05.21 - 16:26
Внезапный вопрос - а что ты потом с этим табдоком делаешь?
   BIP1
 
10 - 13.05.21 - 16:29
(9) Если разговор про внешнюю, то, вероятно, в общую форму ПечатьДокументов передаёт, а не просто Показать() делает
   Энштейн 1С
 
11 - 13.05.21 - 16:30
(9) Все стандартно для внешней печатной формы:

Возвращаю из экспортной функции Печать() которую вызываю из модуля формы
Процедура КнопкаВыполнитьНажатие(Кнопка)
    ТАбДок = Новый ТабличныйДокумент;
    ТабДок = Печать();
    Табдок.Показать();
КонецПроцедуры
   Энштейн 1С
 
12 - 13.05.21 - 16:30
(10) А вот ты и не угадал))
   Энштейн 1С
 
13 - 13.05.21 - 16:36
(9) ЗУП КОРП 2.5 сильно доработанная
   Энштейн 1С
 
14 - 13.05.21 - 16:38
(9) Я бы представил весь код внешней печатной формы, но там 500 строк
   RomanYS
 
15 - 13.05.21 - 16:40
прикольный косяк
Похоже подразумевалось, что сетка должна восстановиться из ПараметрыПечатногоДокумента. Только ПараметрыПечатногоДокумента и ПечатныйДокумент это одно и то же, поэтому после изменения ПечатныйДокумент ничего уже не восстанавливается. Разработчики типовой похоже не в курсе что ТабДок передается по ссылке


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ПечатныйДокумент.ОтображатьЗаголовки    = Ложь;
    ПечатныйДокумент.ОтображатьСетку        = Ложь;
    ПечатныйДокумент.Защита                    = Защита;
    ПечатныйДокумент.ТолькоПросмотр            = Истина;
    
    Если ПараметрыПечатногоДокумента <> Неопределено Тогда
        ЗаполнитьЗначенияСвойств(ПечатныйДокумент, ПараметрыПечатногоДокумента);
    КонецЕсли;
    
    КоличествоЭкземпляров    = ПечатныйДокумент.КоличествоЭкземпляров;
    
КонецПроцедуры
   МимохожийОднако
 
16 - 13.05.21 - 16:42
(11) Перед последней строчкой этого кода и пропиши (0). ТабДок.ОтображатьСетку и т.д.
   Энштейн 1С
 
17 - 13.05.21 - 16:44
(16) Писал и перед последней строкой кода перед тем как вернуть значение из функции и в модуле форме тот же код писал, не отображается сетка и все тут
   hhhh
 
18 - 13.05.21 - 16:46
(13) наверно так
    Табдок.ОтображатьСетку        = Истина;
    Табдок.Показать();

чтобы ни одна мышь не проскочила.
   Энштейн 1С
 
19 - 13.05.21 - 16:48
(18) в оригинале вот так выглядит, но сетки все равно нет, причем редактировать можно текст:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    ТАбДок = Новый ТабличныйДокумент;
    ТабДок = Печать();
    ТабДок.ТолькоПросмотр=Ложь;
    ТабДок.Защита=Ложь;
    ТабДок.ОтображатьЗаголовки=Истина;
    ТабДок.ОтображатьСетку=Истина;
    ТабДок.ТолькоПросмотр=Ложь;
    Табдок.Показать();
КонецПроцедуры
   Энштейн 1С
 
20 - 13.05.21 - 16:49
(19) Имею ввиду, что защита от редактирования снялась, но сетка не отображается
   RomanYS
 
21 - 13.05.21 - 16:49
(19) где эта кнопка?
У тебя ВПФ интегрированная или просто обработка запускаемая из файла?
   Энштейн 1С
 
22 - 13.05.21 - 16:51
(21) ВПФ интегрирования, с авторегистрацией, ссылкой на конкретный документ
   BeerHelpsMeWin
 
23 - 13.05.21 - 16:53
(19) >КонецПроцедуры
а что в отладчике в этом месте в ТабДок.ОтображатьСетку?
   RomanYS
 
24 - 13.05.21 - 16:55
(22) тогда зачем ты (19) пишешь. По факту твоя кнопка и функции не вызываются. Только Печать()
   hhhh
 
25 - 13.05.21 - 16:55
(22) может ТабДок реквизит там? попробовать ТабДок2.
   МимохожийОднако
 
26 - 13.05.21 - 17:06
В функции Печать() сделай изменения.
   Энштейн 1С
 
27 - 13.05.21 - 17:07
(24) Я так везде напихал, лишь бы заработало
   Энштейн 1С
 
28 - 13.05.21 - 17:07
(26) Везде делаю изменения
   RomanYS
 
29 - 13.05.21 - 17:07
(26) не поможет из-за (15)
   Энштейн 1С
 
30 - 13.05.21 - 17:07
(23) В отладчике Истина в значении ТабДок.ОтображатьСетку
 
 
   BIP1
 
31 - 13.05.21 - 17:09
(30) Покажите скриншот экрана с печатной формой
   RomanYS
 
32 - 13.05.21 - 17:09
(27) Или в Печать() делай 
ТабДок.Показать();
возврат Неопределено;

или лечи (15) в общей форме печати
   Энштейн 1С
 
33 - 13.05.21 - 17:11
Други мои, открыл открытие дивное, из под отладчика печатных форм сетка показывается, а вот когда записываешь ее во внешних печатных формах самого предприятия сетки нет (Сервис-Дополнительные отчеты и обработки-Дополнительные внешние печатные формы)
   RomanYS
 
34 - 13.05.21 - 17:12
))) похоже это только для тебя открытие
   Энштейн 1С
 
35 - 13.05.21 - 17:15
(34) Как проблему то решить? Мне нужно не в отладчике, а чтобы в 1С:Предприятии работало
   Энштейн 1С
 
36 - 13.05.21 - 17:16
(31) показываю https://ibb.co/t862NnD
   azernot
 
37 - 13.05.21 - 17:16
Нигде в коде нет какого-то присвоения ТабДок.КлючПараметровПечати, КлючСохраненияПоложенияОкна, СохранятьСвойстваОтображения ?

Может принудительно выставить СохранятьСвойстваОтображения  = Ложь?
   pechkin
 
38 - 13.05.21 - 17:17
(36) это точно не табдок.показать
   azernot
 
39 - 13.05.21 - 17:17
(36) Это нихера не Табдок.Показать();
   pechkin
 
40 - 13.05.21 - 17:17
и этот человек собеседует архитекторов )))
   Энштейн 1С
 
41 - 13.05.21 - 17:18
(39) В общим модулях проблема?
   BIP1
 
42 - 13.05.21 - 17:18
(12) Всё-таки, угадал
   azernot
 
43 - 13.05.21 - 17:19
(41) Отладчиком выясняй, что в итоге выводит ту форму, который ты показываешь в скриншоте. И там копай.
   Энштейн 1С
 
44 - 13.05.21 - 17:19
(40) Ну че сказать, я печатных форм мало делал
   Энштейн 1С
 
45 - 13.05.21 - 17:20
(43) Спасибо, придется долго жать Ф11
   azernot
 
46 - 13.05.21 - 17:24
(45) Можно, если времени много, а желания думать - мало.
А можно найти эту форму в общих и отловить её открытие.
   BIP1
 
47 - 13.05.21 - 17:32
На примере УТ 11.4. Но суть та же.
Где-то в глубинах модуля общей формы ПечатьДокументов: https://ibb.co/fDTRT0V.
Всё ищется отладчиком, при желании, за считанные минуты.
   RomanYS
 
48 - 13.05.21 - 17:35
(35) Проблема в (15) раскрыта
   Chameleon1980
 
49 - 13.05.21 - 17:43
ищи форму, в которую все пф выводятся в конце
отладчик в руки и смотри, как ты можешь повлиять на вывод
сетки
подозреваю, что в процедуру печати впф нужно
добавить параметр нужный
какой? поможет отладчик
   polosov
 
50 - 13.05.21 - 17:52
(45) Вот тебе в помощь сеньор-архитектор https://ibb.co/FVdrc0r
   RomanYS
 
51 - 13.05.21 - 17:53
(50) у него ОФ
   polosov
 
52 - 13.05.21 - 17:55
(51) Тогда только на знания сеньора-архитектора уповать...
   Chameleon1980
 
53 - 13.05.21 - 17:57
замером производительности найди


Список тем форума
 
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.