Вход | Регистрация
 

Помощь с обработкой ТЧ Товары для ЭСФ

Помощь с обработкой ТЧ Товары для ЭСФ
Я
   asisdes
 
13.05.21 - 09:28
Доброго дня! Коллеги могли бы помочь с задачкой,
я не много на быдло кодил, только ногами сильно не пинать плз)))
Задача.
В документе ЭСФ в ТЧ "Товары" есть колонка Товар (Тип ОпределенныйТип в который включен Справочник Номенклатура),
так же есть Документ Поступление ТМЗ, так же есть ТЧ "Товар" и колонка Номенклатура с типом Справочник Номенклатура.

Создал обработку ТЧ для ЭСФ. которая дает мне возможность выбрать Поступление, после чего она должна
заполнить Поле товара в ЭСФ, как в документах Поступления.
Пока предполагаем что количество строк одинаковое.

В коде у мня Результат это ссылка на документ который  выбрал.
<code>

&НаКлиенте
Процедура ВыборПоступленияЗавершение(Результат, Параметры) Экспорт
    Если Не Результат = Неопределено Тогда
        СсылкаНаПТиУ = Результат;
    КонецЕсли;
    

    //КоличествоСтрок = ПолучитьКоличествоСтрок(Результат);
    //Сообщить(КоличествоСтрок);
    
    ТоварыВТЧ = Новый СписокЗначений;
    ТоварыВТЧ.ЗагрузитьЗначения(ВыгрузитьКолонкуТовары(Результат));

    Для н=0 По ВладелецФормы.Объект.Товары.Количество()-1 Цикл
        
        Если н <= КоличествоСтрок-1 Тогда
            ВладелецФормы.Объект.Товары[н].Товар = ТоварыВТЧ[н];
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры


&НаСервере
Функция ВыгрузитьКолонкуТовары(Ссылка)
    ПостОбъект = Ссылка.ПолучитьОбъект();
    КолонкиТЧ = ПостОбъект.Услуги.ВыгрузитьКолонку("Номенклатура");
    Возврат КолонкиТЧ;
КонецФункции

</code>

на форме не отрабатывает.
   PR
 
1 - 13.05.21 - 09:31
Тебе бы в школу
   tmk315
 
2 - 13.05.21 - 09:34
Отладчиком посмотри пришел массив на клиенте .
   asisdes
 
3 - 13.05.21 - 09:35
(1) Я там был, выгнали. Сказали что я не способный.
   Галахад
 
4 - 13.05.21 - 09:40
Наверное:

ТоварыВТЧ[н].Значение
   asisdes
 
5 - 13.05.21 - 09:46
(4) Вы волшебник))) Спасибо большое.
   Волшебник
 
6 - 13.05.21 - 09:59
(4) Молодец!

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.