Вход | Регистрация
 

Удаление записей справочника

Удаление записей справочника
Я
   Andreich88
 
11.05.21 - 22:31
Всем привет. Подскажите есть ли возможность удалить лишние записи справочника при ошибке "Достигнуто ограничение учебной версии"? Пробовал через обработку, не получается.
   acht
 
1 - 11.05.21 - 23:25
Возможность есть.
Точно также как в обычной версии. Если ты ответишь на вопрос - что такое "лишние записи" и  как их отличить от "не лишних".
   Andreich88
 
2 - 11.05.21 - 23:56
Записей много больше 2000, имеют наименование тип строка(2000099 пример). Пробовал через получить объект та же ошибка.
   acht
 
3 - 12.05.21 - 00:06
(2) Еще раз. Что такое "лишние" записи. Чем они отличаются от "не лишних". Что ты хочешь удалить, что оставить?

Самое простое - пометить "лишние" ссылки на удаление, а потом запустить типовую обработку по удалению помеченных объектов. В зависомости от типа клиента это будет или в меню "операции" или в меню "все функции" в разделе "стандартные".
   Andreich88
 
4 - 12.05.21 - 00:10
(3) В том то и проблема, что система не дает такой возможности ни пометить на удаление, ни удалить, ни через обработку.
Пробовал так:

&НаСервере
Процедура УдалитьНаСервере()
    
    Карта = Справочники.КартыСт.НайтиПоНаименованию("2000099");
    НайдКатрта = Карта.ПолучитьОбъект();
    НайдКатрта.Удалить();
КонецПроцедуры

&НаКлиенте
Процедура Удалить(Команда)
    УдалитьНаСервере();
КонецПроцедуры
   acht
 
5 - 12.05.21 - 00:18
(3) Ты читать умеешь? Предложенный мной способ не требует написания кода.
   Andreich88
 
6 - 12.05.21 - 00:25
(5) А ты? Система не позволяет пометить на удаление.
   acht
 
7 - 12.05.21 - 00:28
(6) Ручками не позволяет? Ну-ну.
   RomanYS
 
8 - 12.05.21 - 00:43
(7) а должно?
   hhhh
 
9 - 12.05.21 - 00:47
(6) ну возьмите чистую учебную и обработкой ВыгрузкаЗагрузкаXML перекачайте туда нужные данные.
   Andreich88
 
10 - 12.05.21 - 00:52
(9) Еще бы знаний хватило для таких действий))) Решился вопрос:
&НаСервере
Процедура Команда1НаСервере()
    
    НачатьТранзакцию();
    Выборка = Справочники.Карты.Выбрать();
    Пока Выборка.Следующий() Цикл
    Об = Выборка.ПолучитьОбъект();
    Об.Удалить();
    КонецЦикла;
    ЗафиксироватьТранзакцию();
    Сообщить("All done...")
    
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    
    Команда1НаСервере();
    
КонецПроцедуры

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.