Вход | Регистрация
 

Есть отсортированный динамический список справочника

Есть отсортированный динамический список справочника
Я
   Гений 1С
 
11.05.21 - 15:00
Как сделать, чтобы при изменении строки курсор перескакивал на следующую, а не оставался на текущей строке?
 
 Партнерская программа EFSOL Oblako
   Малыш Джон
 
1 - 11.05.21 - 15:13
(0) Спозиционировать, не?
   Kassern
 
2 - 11.05.21 - 15:15
(0)  Элементы.ДС.ТекущаяСтрока=НужнаяСтрока
   Kassern
 
3 - 11.05.21 - 15:16
(2) не знаю на счет динамического, но в обычно таблице такая тема работает
   Гений 1С
 
4 - 11.05.21 - 15:44
(2) а как определить следующую строку?
   pechkin
 
5 - 11.05.21 - 15:50
(3) в обычной таблице нужно идентификатор передавать, а не индекс
   Kassern
 
6 - 11.05.21 - 15:55
(5) я в общих чертах расписал как спозиционироваться на нужной строке, какой там тип проще в СП глянуть. Давно этим не занимался.
(4) Запомнить идентификатор текущей строки и добавить к нему +1. Скорее всего так
   pechkin
 
7 - 11.05.21 - 15:56
(6) в дин списках нет идентификаторов
   Kassern
 
8 - 11.05.21 - 16:18
(7) ну да ну да, а вы пробовали формировать динамический список произвольным запросом без указания основной таблицы? В этом случае решение будет очень простым: ТекущаяСтрока это будет число. Можно спокойно сделать +1 и присвоить текущей строке и будет вам следующая строка.
   RomanYS
 
9 - 11.05.21 - 16:23
(8) Идентификаторы не обязаны идти по порядку. Они же должны сохраняться на время жизни формы
   BIP1
 
10 - 11.05.21 - 17:17
(0) Через ПолучитьИсполняемуюСхемуКомпоновкиДанных() не вариант? Получаем ТЗ с данными текущего списка и, зная ссылку на элемент Элементы.Список.ТекущаяСтрока, получить следующую в ТЗ? Всё это &НаСервере, а не &НаКлиенте..
   mistеr
 
11 - 11.05.21 - 17:38
(0) Слушай, ты в своем ламерстве опускаешься уже ниже плинтуса. Тебе даже лень внятно сформулировать название темы и вопрос. Совсем коллег не уважаешь. Не думал, что состоявшийся программист в то же время может быть ламером, однако вот.

По теме сказать нечего, извини, т.к. не понял постановку задачи. Что значит "при изменении строки"?
   Fragster
 
12 - 11.05.21 - 17:39
(4) может поможет https://infostart.ru/1c/articles/559370/
   BeerHelpsMeWin
 
13 - 11.05.21 - 17:40
(9) У него же отсортированный список, т.е. существует какое-то поле, которое можно увеличит на условный 1. Ну или самому пронумеровать, как надо.
   BeerHelpsMeWin
 
14 - 11.05.21 - 17:54
(11) редактирование динамических списков, как в фузине!
   RomanYS
 
15 - 11.05.21 - 18:04
(13) отсортировал по другому полю, пользователь же будет ожидать что переход будет на следующую строку а не на ту которая раньше была следующей
   BeerHelpsMeWin
 
16 - 11.05.21 - 18:09
(15) Логично. Ну что же, придется запретить сортировку по другим полям. /s
   RomanYS
 
17 - 11.05.21 - 18:15
(16) )). В любом случае ДС справочника это неприменимо, там идентиифкатором является ссылка же
   Базис
 
18 - 11.05.21 - 18:41
1.  Сделай для глупых вопросов левый ник.
2. Sendkey на УФ не работает?
   RomanYS
 
19 - 11.05.21 - 18:45
(10) тяжеловато получится
(18) вроде работает
&НаКлиенте
Процедура СписокПриИзменении(Элемент)
    Shell= Новый COMОбъект("Wscript.Shell");
    Shell.SendKeys("{DOWN}");
КонецПроцедуры
   Ненавижу 1С
 
20 - 11.05.21 - 18:49
(19) а теперь я в форме элемента нажимаю "сохранить" без закрытия формы.
   Cthulhu
 
21 - 11.05.21 - 18:51
(0) см. https://forum.infostart.ru/forum9/topic73522/ комментарий 14 (martemp 11.05.16 13:08)
   RomanYS
 
22 - 11.05.21 - 18:56
(20) на тестовой перехода не было - вроде так и нужно
   RomanYS
 
23 - 11.05.21 - 18:58
+ (22) правда если записать, а потом закрыть без записи - перехода тоже нет
   BIP1
 
24 - 11.05.21 - 19:00
(22) Если на форме элемента кликать мышкой "Записать и закрыть", то переход срабатывает. Если нажать Ctrl+Enter, то курсор не переходит на следующую строку.
   BIP1
 
25 - 11.05.21 - 19:07
(24) ПодключитьОбработчикОжидания("КурсорВниз", 0.1, Истина) помогает:)
   RomanYS
 
26 - 11.05.21 - 19:08
(22) на самом деле клавиша "нажалась", но применилось не к списку. Можно сказать удачное совпадение)
   BIP1
 
27 - 11.05.21 - 19:10
(26) Событие списка ПриИзменении() же происходит, конечно
   BIP1
 
28 - 11.05.21 - 19:23
(23) Через ПодключитьОбработчикОжидания() и ВводДоступен() можно извратиться, чтобы и такая ситуация отрабатывала:)
   RomanYS
 
29 - 11.05.21 - 19:27
(28) ага, Геня в восторге должен быть от таких велосипедов))
&НаКлиенте
Процедура СписокПриИзменении(Элемент)
    ПодключитьОбработчикОжидания("Сдвинуть", 0.3, Истина);
КонецПроцедуры

&НаКлиенте
Процедура Сдвинуть()
    Если ВводДоступен() Тогда
        Shell= Новый COMОбъект("Wscript.Shell");
        Shell.SendKeys("{DOWN}");
    Иначе
        ПодключитьОбработчикОжидания("Сдвинуть", 0.3, Истина);
    КонецЕсли;
КонецПроцедуры
   BIP1
 
30 - 11.05.21 - 19:33
(29) во-во:)

&НаКлиенте
Процедура СписокПриИзменении(Элемент)
    ПодключитьОбработчикОжидания("КурсорВниз", 0.1, Истина)
КонецПроцедуры

&НаКлиенте
Процедура КурсорВниз()
    
    Если НЕ ЭтаФорма.ВводДоступен() Тогда
        ПодключитьОбработчикОжидания("КурсорВниз", 0.1, Истина);
        Возврат
    КонецЕсли;
    
    Shell= Новый COMОбъект("Wscript.Shell");
    Shell.SendKeys("{DOWN}")
    
КонецПроцедуры
 
 
   Kassern
 
31 - 12.05.21 - 11:14
(29) (30) я думал до этого не дойдет))


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.