Вход | Регистрация
    1  2  3   

Какая из самых дешевых базовых 1С-конфигураций имеет интерфейс Такси?

↓ [Волшебник, 17.05.21 - 11:01]
Какая из самых дешевых базовых 1С-конфигураций имеет интерфейс Такси?
Я
   Гений 1С
 
09.05.21 - 12:24
1С:Деньги стоит 600, имеет.
1С:Платежные документы стоит 200, имеет режим совместимости Версия 8.2
Что-нибудь за 300 есть?
 
 Партнерская программа EFSOL Oblako
   Гений 1С
 
101 - 11.05.21 - 12:04
(100) мир большой, разнообразие. ;-)
   mikecool
 
102 - 11.05.21 - 12:10
(80) ржачно
первый отзыв явно сам Геня написал
   Гений 1С
 
103 - 13.05.21 - 11:03
В общем, получил ответ от одного из крупных 1С:Франчайзи.
Сперва они долго в переписке не могли понять чего я хочу и предлагали купить то MS SQL, то сервер 1С.
В итоге решили путем созвона с тех спецом.
Они мне ответили по принципу "раз не запрещено, то разрешено", т.е. подтвердили легальность использования моей схемы.
Как-то так.
В общем, на уровне 1С:Франчайзи проверка легальности схемы пройдена.
   Kassern
 
104 - 13.05.21 - 12:09
(103) В суде будете ссылаться на слова тех спеца какого то франча?)
   Kassern
 
105 - 13.05.21 - 12:10
(104) с тем же успехом могли на мисте спросить и потом ссылаться на ветку мисты
   Paint_NET
 
106 - 13.05.21 - 12:15
Тихо рыдаю от очередной "гениальной" идеи.
   Garykom
 
107 - 13.05.21 - 12:57
(106) Никакой гениальности тут нет, только куча неудобств
Вместо этого изврата можно просто юзать МП, которое вполне на винде работает начиная с Win8.1
   Garykom
 
108 - 13.05.21 - 12:58
(107)+ Только там придется ВК написать например для клавы, ибо все мышкой неудобно бывает
   Kassern
 
109 - 13.05.21 - 12:59
(108) пфф, есть куча эмуляторов андройда на компе, можно на нем запустить МП и работать)
   Kassern
 
110 - 13.05.21 - 13:00
(109) того же блюстакс поставить и вперед)
   Гений 1С
 
111 - 13.05.21 - 15:02
(104) ну я продублирую на lic@, не вопрос.
   Гений 1С
 
112 - 14.05.21 - 10:28
получил ответ от 1С: "Ваши планы - это нелицензионное использование базовой конфигурации в качестве клиента к другой базе.
Для этого вам следует приобрести версии ПРОФ"

Но пока конкретики мало, буду продавливать на указание конкретных пунктов нарушения.
   Конструктор1С
 
113 - 16.05.21 - 06:00
(112) вся конкретика в лицензионном соглашении, которое ты никогда не читаешь
   Garykom
 
114 - 16.05.21 - 06:04
(112) Не продавишь, по спорным моментам они не дураки судиться если нет особых денежных потерь или возможной прибыли
В суд на тебя подадут в том случае если твоя поделка будет реально продажи отнимать и/или приносить тебе доход
   Гений 1С
 
115 - 16.05.21 - 12:11
(113) это такое желтенькая карточка или есть другие лС?
(114) Ну мне даже интересно, как реагирует поддержка 1С на обращения. Тупо делает морду кирпичом и игнорит или доводит до логического конца?
   Конструктор1С
 
116 - 16.05.21 - 14:04
(115) да
   Гений 1С
 
117 - 16.05.21 - 15:29
(116) в желтенькой карточке никаких запретов нет
   ДедМорроз
 
118 - 16.05.21 - 17:39
Если ты подключается к базе 1с,то все это изобретение,это мультиплексор для обхода лицензии на подключение к базе,и его нельзя использовать без клиентской лицензии вне зависимости от того,на чем он реализован.
Если база не 1с,то твое решение - это интерфейс к той программе,реализованный на 1с,и нужно ещё и у создателей целевой базы спрашивать,а можно ли так к ней подключаться.
С точки зрения самого решения - если в нем заявлена возможность использования внешних обработок,то со стороны 1с вопросов быть не должно.

Ну и ещё нужно смотреть,а не написано ли в лицензионном соглашении для чего разрешается использовать данную программу,если там сказано,например,для учёта личных финансов и т.п.то другое использование,как бы,обработчиком не одобряется.
   Гений 1С
 
119 - 16.05.21 - 17:49
(118) я подключаюсь не к базе 1С, а к другой базе. Создатель этой другой базы я сам, база на open-source движке 1С, который этого не запрещает. Тогда какого их поддержка мне врет, что так использовать нелегально? Поэтому я и хочу получить официальный ответ (на следующей неделе), чтобы понять, это придурь исполнителя или придурь 1С.
   Гений 1С
 
120 - 16.05.21 - 17:50
ой, движко другой базы My SQL, описался
   Конструктор1С
 
121 - 16.05.21 - 17:54
(117) читать пробовал?
   Гений 1С
 
122 - 16.05.21 - 18:06
(121) да, там немного текста
   Конструктор1С
 
123 - 16.05.21 - 18:18
(122) 1С Деньги 8 относятся к базовым версиям программных продуктов на базе 1С Предприятие 8. Пользователь программы 1С:Деньги 8 не может вносить изменения в конфигурацию

https://online.1c.ru/catalog/programs/program/14229054/
   Гений 1С
 
124 - 16.05.21 - 18:22
(123) я не вношу изменения в конфигурацию, протрите очи.
   Конструктор1С
 
125 - 16.05.21 - 18:22
https://v8.1c.ru/priobretenie-i-vnedrenie/otvety-na-tipovye-voprosy-po-litsenzirovaniyu-1s-predpriyatiya-8/

Полностью оригинальная конфигурация, разработанная на платформе «1С:Предприятие 8», является интеллектуальной собственностью разработчика, и он распоряжается ею по своему усмотрению, в том числе может зарегистрировать в Роспатенте, включить в «Реестр отечественного ПО». Также конфигурация может быть опубликована в открытом доступе разработчиком конфигурации без каких-либо согласований с фирмой «1С», и при этом разработчик такой конфигурации может сам задать условия использования текстов своей конфигурации. Но стоит помнить, что для запуска и использования такой конфигурации у конечного пользователя должна быть _приобретена_ _любая_ _основная_ _поставка_, включающая платформу «1С:Предприятия 8».
   Гений 1С
 
126 - 16.05.21 - 18:22
(125) и где противоречие?
   Гений 1С
 
127 - 16.05.21 - 18:23
(125) я не разрабатываю конфигурацию, я разрабатываю пакет внешних обработок для 1С:Деньги, уточню на всякий случай
   Гений 1С
 
128 - 16.05.21 - 18:24
на самом деле просто надо признать, что тут 1С допустила дыру в лицензионном соглашении и перспектив судебного преследования пользователей Базухи у нее мало.
   Krendel
 
129 - 16.05.21 - 18:27
(127) Нам пофигу, мы все равно пользоваться не будем, ибо знаем автора
   Конструктор1С
 
130 - 16.05.21 - 18:29
(127) судя по твоему опусу (37), ты собрался коннектиться из денег к СУБД. А БАЗОВАЯ версия не позволяет этого делать. Ни COM, ни ВИД в базовой не доступны. НЕ сможешь ты осуществить свои хениальные планы без ПРОФ платформы
 
 
   Гений 1С
 
131 - 16.05.21 - 18:34
(130) Новый COMОбъект в базовой разве недоступен?
   Конструктор1С
 
132 - 16.05.21 - 18:35
Если ты собрался через COM коннектиться к сторонней БД, доставать данные и распихивать по формочкам 1с, то это трэш-трэшовый. Тогда уже проще взять готовый ORM под ту же Java и запилить на ней. Худо-бедно можно было разрулить на внешних источниках данных, они и к формочкам ловко привязываются, и кучу готового 1сного поведения реализуют. Но вот незадача, ВИД нельзя добавить без изменения конфигурации
   Гений 1С
 
133 - 16.05.21 - 18:36
(132) что такое ВИД? через ADODB нормальная работа идет с другой базой
   Гений 1С
 
134 - 16.05.21 - 18:36
(132) а, внешние источники данных, они мне не нужны. Кстати, ВИД в внешних обработках нельзя заюзать?
   Конструктор1С
 
135 - 16.05.21 - 18:41
(131) ну попробуй

(133) а смысл в таком изврате? Стоимость разработки такой БД будет выше, чем стоимость разработки на C# + SQL Server или Java + Oracle
   Конструктор1С
 
136 - 16.05.21 - 18:44
(134) можно. Правда глюковато. ВИД позволяют задействовать и 1сный интерфейс, и генерировать готовые формочки, и писать запросы на встроенном языке 1с, и даже юзать динамические списки на СКД. Но ты со своими базовыми пролетаешь мимо этого удовольствия

https://v8.1c.ru/platforma/vneshniy-istochnik-dannyh/
   Гений 1С
 
137 - 16.05.21 - 18:47
(135) почему выше? Все зависит от степени формализации задачи.
(136) ну и ладно, я могу использовать сырой и гордый ADODB
   Конструктор1С
 
138 - 16.05.21 - 19:04
(137) ты с ADODB вообще работал когда-нибудь? Видимо нет. Чтобы приземлиться, предлагаю тебе написать простенькую БД, которая физически будет управляться MySQL, коннектиться к оной через QDODB, а весь интерфейс будет реализован на 1с (формы объектов, формы списков, проваливание в поле чтобы выбрать из списка и т.д.). Данные:
Справочник Контрагенты
Справочник Товары
Документ ПриходнаяНакладная (в шапке Контрагент, есть ТЧ с товарами)
Документ РасходнаяНакладная (в шапке Контрагент, есть ТЧ с товарами)

на самой 1с такая напишется за полчаса, если не торопиться. На раскоряках с ADODB хорошо если за неделю управишься
   Гений 1С
 
139 - 16.05.21 - 19:19
(138) я работал через ADODB с MYSQL, момент
   Гений 1С
 
140 - 16.05.21 - 19:21
Вот тебе пример кода:
    Для Каждого КЗ ИЗ ДанныеКатегорий Цикл
        ID = КЗ.Ключ;
        Name = КЗ.Значение["Name"];
        Parent = КЗ.Значение["Parent"];
        
        //taxonomy_term_data 

        t_keys = Новый Соответствие();
        t_keys.Вставить("vid", НомерТаксономии);  
        t_fields = Новый Соответствие();
        t_fields.Вставить("name", Name);

        
        //field_data_field_taxonomy_volusionid

        f_keys =     Новый Соответствие();
        f_keys.Вставить("field_taxonomy_volusionid_value", ID);  
        f_fields = Новый Соответствие();
        Результат = ДатьЭлементТаблицы(MySQL, "field_data_field_taxonomy_volusionid", f_keys, f_fields, ложь);
        Если НЕ Результат.ОК Тогда Сообщить("Ошибка: " + Результат.Ошибка); Возврат; КонецЕсли;
        
        Если НЕ Результат.Существует Тогда
            //Создаем связку поля volusion id и нового tid

            MySQL.НачатьТранзакциюSQL();
            
            //taxonomy_term_data update

            tid = ДатьСвободныйКлюч(MySQL, "taxonomy_term_data", "tid");  //Первичный ключ nid

            t_keys.Вставить("tid", tid);  
            f_fields.Вставить("entity_id", tid);
            f_fields.Вставить("bundle", "product");
            f_fields.Вставить("language", "ru"); 
            
            Результат = ДатьЭлементТаблицы(MySQL, "field_data_field_taxonomy_volusionid", f_keys, f_fields, истина);
            Если НЕ Результат.ОК Тогда Сообщить("Ошибка: " + Результат.Ошибка); Возврат; КонецЕсли;
            
            Результат = ДатьЭлементТаблицы(MySQL, "taxonomy_term_data", t_keys, t_fields, истина);
            Если НЕ Результат.ОК Тогда Сообщить("Ошибка: " + Результат.Ошибка); Возврат; КонецЕсли;
            
            MySQL.ПодтвердитьТранзакциюSQL();
        Иначе
            tid = Результат.Таблица[0].entity_id;
        КонецЕсли;
        
        t_keys.Вставить("tid", tid);  
        СооTID.Вставить(ID, tid);

        Результат = ДатьЭлементТаблицы(MySQL, "taxonomy_term_data", t_keys, t_fields, истина);
        Если НЕ Результат.ОК Тогда Сообщить("Ошибка: " + Результат.Ошибка); Возврат; КонецЕсли;
        
    КонецЦикла;




&НаСервере
Функция ДатьЭлементТаблицы(MySQL, ИмяТаблицы, СооКлючи, СооПоля, Изменять = ложь, Перечитывать = ложь) Экспорт
    Результат = Новый Структура("ОК, Ошибка, Таблица, Существует", ложь, "", Неопределено, ложь);
    Поля = "";
    Отбор = "";
    СооЗаполнение = Новый Соответствие();
    Для Каждого КЗ ИЗ  СооКлючи Цикл
        Поля = Поля + ?(Поля = "", "", ",") + КЗ.Ключ;
        Отбор = Отбор + ?(Отбор = "", "", " AND ") + КЗ.Ключ + " = """ + MySQL.ЭкранироватьСрокуДляSELECT(КЗ.Значение) + """";
        СооЗаполнение.Вставить(КЗ.Ключ, КЗ.Значение);
    КонецЦикла;
    Для Каждого КЗ ИЗ  СооПоля Цикл
        Поля = Поля + ?(Поля = "", "", ",") + КЗ.Ключ;
        СооЗаполнение.Вставить(КЗ.Ключ, КЗ.Значение);
    КонецЦикла;
    
    Если Поля = "" Тогда
        Результат.Существует = ложь;//Если нет полей поиска, создаем

    Иначе
        Запрос = "SELECT " + Поля + " FROM " + ИмяТаблицы + " WHERE " + Отбор;
        
        Таблица = MySQL.ПолучитьТаблицуЗначенийПоЗапросу(Запрос);    
        Если Таблица = Неопределено Тогда
            Результат.Ошибка = "Не получился запрос по отбору: " + Запрос;
            Возврат Результат;
        КонецЕсли;
        Результат.Таблица = Таблица;
        
        Результат.Существует = Таблица.Количество() <> 0;
    КонецЕсли;
    
    
    //Если нужно изменять

    Если Изменять Тогда
        Если Результат.Существует Тогда
            //Если есть строка с товарами, делаем UPDATE

            MySQL.СоздатьЗапрос("UPDATE", ИмяТаблицы, СооЗаполнение, " WHERE " + Отбор);
        Иначе
            //Строки нет, делаем Insert

            MySQL.СоздатьЗапрос("INSERT", ИмяТаблицы, СооЗаполнение);
        КонецЕсли;
        
        Если НЕ MySQL.ВыполнитьЗапрос() Тогда
            Результат.Ошибка = MySQL.ОписаниеОшибки;
            Возврат Результат;
        КонецЕсли;
        
        Если Перечитывать Тогда
            //Считыаем после изменения

            Таблица = MySQL.ПолучитьТаблицуЗначенийПоЗапросу(Запрос);    
            Если Таблица = Неопределено Тогда
                Результат.Ошибка = "Не получился запрос по отбору: " + Запрос;
                Возврат Результат;
            КонецЕсли;
            Результат.Таблица = Таблица;
        КонецЕсли;
        
    КонецЕсли;
    
    Результат.ОК = истина;
    Возврат Результат;
           
КонецФункции



   Гений 1С
 
141 - 16.05.21 - 19:22
Разумеется, все должно быть формализована, т.е. должна быть модель форма-данные для справочнико-документов. ;-)
   Конструктор1С
 
142 - 16.05.21 - 19:23
(139) только ты путаешь ситуацию, когда нужно тупо выдрать данные из сторонней БД примитивным селектом, и когда нужно реализовать полноценный CRUD с пробрасыванием в интерфейс
   Конструктор1С
 
143 - 16.05.21 - 19:29
(141) ты несёшь откровенную ахинею. Чтобы релизовать элементарную логику "данные на MySQL формы в 1с" нужно будет заплатить специалисту гораздо больше, чем стоит та же УТ ПРОФ
   Конструктор1С
 
144 - 16.05.21 - 19:30
(140) убери, убери скорее! Не хватало ещё узреть гамнокод на ночь глядя
   Гений 1С
 
145 - 16.05.21 - 19:31
(143) не, будет движок который будет сопоставлять данне и отображать их на форму.
ну например, пусть будет таблица Customers.
Нам нужна форма этого кастомера.
у него есть поля Name, INN, Phone, Addres.
Я рисую обработку в 1С с полями
и прописываю структуру:
ДобавитьОписаниеПоля("Наименование", "Name");
ДобавитьОписаниеПоля("ИНН", "INN");
ДобавитьОписаниеПоля("Телефон", "Phone");
ДобавитьОписаниеПоля("Адрес", "Addres");

Все, больше ничего кодить не надо.
   Гений 1С
 
146 - 16.05.21 - 19:32
(144) что то вы нервный какой то батенька... Валерьяночки йопните
   Конструктор1С
 
147 - 16.05.21 - 19:48
(145) ещё лучше. Написание одного такого движка обойдётся в сотку российский килорублей, если не больше. Но даже написав движок, тебе для каждой новой таблички придётся писать тонны кода, работающего с этим движком. Это абсолютно бессмысленная хрень. В "примитивной" Java EE тупо добавляются аннотации:

@Entity
public class Address {
  @Id
  protected long id
  String street;
  String city;
  String province;
}

всё, этот класс работает с БД. Тебе не нужно нырять в СУБД, чтобы создать соответствующую табличку с соответствующими полями. Не нужно рисовать select'ы, updat'ы и иже с ними. Считай что из коробки будет уметь дофига того, что тебе изобретать и изобретать в своём костыледвижке
   Конструктор1С
 
148 - 16.05.21 - 19:51
Ты с одной стороны ориентируешься на клиентов-нищебродов, для которых дорога покупка платформы за 13 тыщ. С другой стороны хочешь этим нищебродам впаривать разработку, которая по срокам и стоимости будет дороже кровавоэнтерпрайзной. Неужели не видишь противоречий?
   Гений 1С
 
149 - 16.05.21 - 19:51
(147) я тебя умоляю, ну какая сотка. ;-) хотя ради того, чтобы это потом отбилось, не вопрос.
   Гений 1С
 
150 - 16.05.21 - 19:52
(148) ну мы пока еще не доказали, что скорость разработки там будет сложнее. Это пока только ваше мнение. По мне так также, как в 1С, плюс больше возможностей для форм будет. Можно будет вложенные формы использовать и тп.
ну и конечно, не нужно будет покупать 1С-Сервер за 80.000 рублей.
Правда, нет выполнения кода на сервере, но производительнее файловой однозначно, т.к. есть SQL сервер
   Гений 1С
 
151 - 16.05.21 - 19:52
т.е. за 600 рублей человек получает решение, которое работает быстрее файловой.
   Гений 1С
 
152 - 16.05.21 - 19:53
(148) а в чем сложность? Сделать SELECT по нужным полям и заполнить поля формы? Да любой кто писал универсальный редактор реквзитов (я писал) понимает, что это раз плюнуть.
   Конструктор1С
 
153 - 16.05.21 - 20:00
(152) проблема только одна. На выходе ты получишь уродливую костылину, которую по удобству использования заткнёт даже древняя FoxPro, не говоря уже о множестве современных систем. Удобством 1с там и не будет пахнуть
   Гений 1С
 
154 - 16.05.21 - 20:11
(153) опять без аргументов
   Конструктор1С
 
155 - 16.05.21 - 20:16
(154) ты не хочешь слышать аргументы. Но флаг тебе в руки, пиши свой движок. Потом покажешь решения на нем и на обработках, а мы оценим
   Гений 1С
 
156 - 16.05.21 - 20:20
(155) так я готов послушать, но аргументов не вижу
   Ivan_495
 
157 - 16.05.21 - 21:24
щас все это на ruby легко пишется
   Гений 1С
 
158 - 16.05.21 - 21:46
(157) нужны детали, бро
   pechkin
 
159 - 16.05.21 - 21:48
(157) на питоне ты хотел сказать
   Ivan_495
 
160 - 16.05.21 - 21:49
ruby rails
 
 
   Гений 1С
 
161 - 16.05.21 - 22:41
(160) 0 бит
   Ivan_495
 
162 - 16.05.21 - 22:49
(161) -10 бит
   Leonardo1c
 
163 - 16.05.21 - 22:53
Гений 1с - что за 10тест вы мне прислали?
Работодатель - это IQ тест
Гений 1с - мне его нужно пройти.
Работодатель - уже нет.
   Конструктор1С
 
164 - 17.05.21 - 04:43
(150) >>ну мы пока еще не доказали, что скорость разработки там будет сложнее

Как бы тебе рассказать суровую реальность... Участвовал в проекте "тесной" интеграции здоровой самописки 1с и БД под Oracle. Было это давно, когда ещё никаких ВИД даже в проекте не было. На стороне Oracle было примерно с десяток таблиц, из которых нужно было только забирать данные, и раскидывать эти данные в справочники и документы 1с. Так вот, два человека больше года (!) писали "движок" на 1с для этой интеграции. И я тебе ответственно заявляю, с ADODB ты потратишь в 20-30 раз больше времени, чем если бы делал всё то же самое на объектах 1с
   Гений 1С
 
165 - 17.05.21 - 06:15
(164) не знаю что там они писал, мне кажется, ты ошибаешься, и всё просто. Может они пошли сложным путем?
   Paint_NET
 
166 - 17.05.21 - 06:32
(165) Когда кажется, Геня, креститься надо. Тебе только это и поможет, бо эффект Даннинга-Крюгера не позволяет.
   ДенисЧ
 
167 - 17.05.21 - 06:38
(164) Больше года для забора данных из внешней БД? Они там по часу в неделю работали, что-ли?
   Конструктор1С
 
168 - 17.05.21 - 06:59
(165) это тебе кажется, будто бы всё легко, а такая вот реальность. Но ты можешь начать писать свои свистоперделки, потом расскажешь, как легко и быстро тебе это далось

(167) нет, работали фуллтайм. Я же говорю, тесная интеграция со сторонней БД
   Конструктор1С
 
169 - 17.05.21 - 07:06
(165) скачай и поковыряй библиотеку интеграции с документооборотом (встроена в некоторых типовых). Она не через ADODB, но как раз воплощение всех твоих мечт - работа со сторонней БД через обработки. Там тоже написан свой "движок", но это не избавило от написания десятков тыщ кода, работающего с этим движком. Маленько спустишься с небес
   ДенисЧ
 
170 - 17.05.21 - 07:07
(168) Просто я в своё время начал грузить данные из оракля через неделю после того, как мы с админом заставили работать егоный (с) долбаный коннектор с 64бит сервером на иноязычной виндосервере.
Причём там не просто селект фром табле был. Там и вызывы хранимок, и запись в таблицы...
   Конструктор1С
 
171 - 17.05.21 - 07:08
(170) очевидно, у тебя была примитивная интеграция
   ДенисЧ
 
172 - 17.05.21 - 07:14
(171) Да. Совершенно очевидно. Ведь я сделал за неделю, а твои знакомые год возились. Это совершенно очевидный показатель примитивности
   Paint_NET
 
173 - 17.05.21 - 07:23
(172) Год, конечно, многовато, но всё-таки от задачи зависит. Просто сынтегрировать и перетащить плоские данные - одно, может, там постобработка была на уровне "запилите мне супер-пупер олап с даксом на платформе 1С, и шобы всё летало".
   Конструктор1С
 
174 - 17.05.21 - 07:23
(172) разумеется. Показатель трудозатрат как раз и показывает очевидную разность масштабов
   BIP1
 
175 - 17.05.21 - 07:29
(174) 1 стажер может месяц делать и не сделать то, что специалист сделает за часы. Факт.
3 стажера могут месяц делать и сделать то, что специалист сделает за часы. Факт.
   Конструктор1С
 
176 - 17.05.21 - 07:30
(175) там были не стажеры, скорее синьоры
   BIP1
 
177 - 17.05.21 - 07:32
(176) Это примитивно упрощенный пример, чтобы показать, что одну и ту же задачу разные люди могут делать за разное время. При этом, добавление новых исполнителей не всегда приводит к улучшению качества исполнения.
   BIP1
 
178 - 17.05.21 - 07:37
(176) 1 человек полжизни работает с зоопарком баз 1с - интеграции, обмены, доработки в куче разных конфигураций (типовых и нетиповых).
2-ой человек полжизни работает с 1 конфигурацией, например, УПП. Знает её лучше, чем 1-ый человек, не только с точки зрения учета, но и с точки зрения внутренних механизмов, которые он может менять как хочет с закрытыми глазами.
Кто из них "синьористей"? Кто быстрее решит задачу интеграций, обменов и т.п.
   PLUT
 
179 - 17.05.21 - 07:39
(175) очевидно же, если задачу оценили в 100 часов, то нужно 10 программистов и за 10 часов задача будет решена. а 100 программистов сделают ее за 1 час :)
   PLUT
 
180 - 17.05.21 - 07:42
(178) задачу интеграции быстрее решит трудолюбивый. нафиг ему внутренние механизьмы УПП знать? он сбоку навалит тонны кода
   ДенисЧ
 
181 - 17.05.21 - 07:45
(179) зависит от задачи. Если подмести Красную Площадь - то это сработает...
   PLUT
 
182 - 17.05.21 - 07:47
(181) школьная задача про землекопов. сколько землекопов нужно, если один землекоп копает 1 кубометр в час
   SiAl-chel
 
183 - 17.05.21 - 07:51
(9) Рассказывай
   Конструктор1С
 
184 - 17.05.21 - 07:53
(177) чудес не бывает. Я ещё не видил суперменов программирования, которые смогли бы за неделю сделать то, что их опытные коллеги делали год. Какой-нибудь дичайший нуб-стажер может протупить месяц над задачей, которую опытный решит за 2 часа. Но когда речь идет об "опытный vs. опытный", такого разрыва впринципе быть не может
   Гений 1С
 
185 - 17.05.21 - 07:54
(171) так расскажи что такого было в этой интеграции.
отобразить в форме по ADO данные из базы данных не требует месяцев работы.
   Конструктор1С
 
186 - 17.05.21 - 07:56
(178) да ты за неделю-две разберешься в "нутряных механизмах", с которыми тебе предстоит плотно работать. Через месяц плотного сношения с таким механизмом будешь знать его не хуже, чем автор того самого механизма
   Paint_NET
 
187 - 17.05.21 - 07:56
(184) Да вы слишком абстрактную задачу обсуждаете, оттуда и разночтения.
"Интеграция" - очень и очень размытое понятие. Варьируется от "прочитать табличку из другой БД" до полноценного двустороннего взаимодействия с кучей промежуточных консолидаций и обработок данных.
   Конструктор1С
 
188 - 17.05.21 - 07:58
(179) в программировании так обычно не работает. В проектной деятельности даже есть такая поговорка: одна женщина за один месяц родит одного ребёнка, но девять женщин за один месяц не смогут родить  одного ребенка
   Paint_NET
 
189 - 17.05.21 - 07:59
(188) Да явно же ирония была :)
   Гений 1С
 
190 - 17.05.21 - 08:00
(187) да, я вот представляю свою задачу и из 20-летнего опыта 1С ее могу оценить.
о каких "интеграцияхъ" вещает конструктор, понятия не имею. Пусть подробно объяснит в одну сторону или две, в чем сложности были и т.п., иначе это банальная "гуру-манипуляция".
   PLUT
 
191 - 17.05.21 - 08:02
(190) ну например интеграция самописьки и эквайринга с банком. за сколько часов/дней напишешь? ну у тебя вроде бы и зокащег есть на интеграцию
   Конструктор1С
 
192 - 17.05.21 - 08:03
(185) долго рассказывать. Да и ты всё равно не поймёшь. Но чтобы приземлиться, пощупай интеграциию с 1с документооборотом. Она встроена в УТ и ERP, возможно и в другие основные типовые. Делаешь отбор по подсистеме ИнтеграцияС1СДокументооборотом и вуаля. По-сути ничего особенного там нет, тупо имитация бизнес-процессов в текущей конфе, хотя вся бизнес-логика всё равно реализована на стороне документооборота. На всё это добро работают несколько десятков тысяч строк кода
   PLUT
 
193 - 17.05.21 - 08:07
(192) ну тот же Битрикс "изкаропки" для обмена с сайтом. для трех товаров красиво работает, но когда большие объемы информации нужно гонять, почему то все переписывают.

интеграция с ДО жутко тормозная вещь получилась и когда несколько десятков пользователей и у каждого по паре десятков актуальных задач по согласованию - интеграция пишет - превышено время ожидания работы интернета - идите в ж.пу
   Конструктор1С
 
194 - 17.05.21 - 08:08
(190) ты на ADODB сделал хэллоуворлд и теперь витаешь в иллюзии, что с такой же легкостью напишешь целую конфу на ADODB
   PLUT
 
195 - 17.05.21 - 08:09
+(191) Г1С - расскажи, в чем сложности у тебя с эквайрингом банка?
   Garykom
 
196 - 17.05.21 - 08:09
(131) ты геня идиот и да не доступны com в базовых как и в учебных
   Конструктор1С
 
197 - 17.05.21 - 08:13
(193) речь не про внутреннюю кухню, тормознутость, удобство или что-либо другое. Речь про объемность функционала, обеспечивающего тесную интеграцию со сторонней системой. Тот же Г1С, услышав задачу подобной интеграции (нарисовать обработку с формами, имитирующими работу с бизнес-процессами документооборота), оценил бы её в пару недель работы
   Garykom
 
198 - 17.05.21 - 08:15
(190) к сожалению очень ограниченный опыт за эти 20 лет

да теоретически можно написать внешние обработки в 1С базовой и на них сэмулировать работу с внешней бд
но это дико неудобно и проще сделать сразу следующий шаг и писать сразу на чем то другом, где с лицензированием таких проблем нет

но вот сам механизм удобного доступа к внешним бд (всяческим mssql, mysql, sqlite и прочим postgres и даже nosql) из любой 1С вполне может пользоваться популярностью и востребованностью
ибо типовой в 8-ке через "Внешние источники данных" ужасен в использовании и часто недоступен если нет прав и т.д.
и если на него навертеть удобный механизм по типу автосоздания CRUD интерфейса то вполне да полезная штука

но не потому что базовая деньги дешевая а просто удобно для тех у кого уже есть любая 1С
   Garykom
 
199 - 17.05.21 - 08:18
(198)+ только нативный кроссплатформенный (да включая линукс, макось и android/ios) а не через ADO под одну винду
причем в разных вариантах и через ВК и через просто запуск консольных и через http-запросы
   Paint_NET
 
200 - 17.05.21 - 08:22
(190) Геня, твой "20-летний" опыт эквивалентен году джуна так-то.
  1  2  3   

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.