Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Удалить последнюю страницу в печати табличного документа

Удалить последнюю страницу в печати табличного документа
Я
   Ilnazio
 
29.04.21 - 10:47
Доброго времени суток! Есть большой макет без областей рассчитанная на одну страницу. При печати выходят две страницы. Автомасштаб = истина спасает и уменьшает масштаб страницы тем самым все печатается на одной странице. Однако мы печатаем поверх выверенных ячеек и автомасштаб поставить не можем. Получается у нас макет немного шире чем рассчитывает для печати 1ска. Единственный выход который я нашел после всего этого - удаление последней страницы. Нашел код ниже, но адаптировать его не получилось, "КонецСтраницы" истину не принимает. Кто-нибудь находил решение по данному вопросу?

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.Область(1,1).Текст = "1";
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
ТабДокумент.Область(2,1).Текст = "2";
Сообщить(ТабДокумент.КоличествоСтраниц());

Для Сч = 1 По ТабДокумент.ВысотаТаблицы Цикл
    ОбластьЯчеек = ТабДокумент.Область(Сч,,Сч);
    Если ОбластьЯчеек.КонецСтраницы Тогда
        ОбластьЯчеек.КонецСтраницы = Ложь;
    КонецЕсли;
КонецЦикла;

Сообщить(ТабДокумент.КоличествоСтраниц());
   Ilnazio
 
1 - 29.04.21 - 10:47
ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.Область(1,1).Текст = "1";
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
ТабДокумент.Область(2,1).Текст = "2";
Сообщить(ТабДокумент.КоличествоСтраниц());

Для Сч = 1 По ТабДокумент.ВысотаТаблицы Цикл
    ОбластьЯчеек = ТабДокумент.Область(Сч,,Сч);
    Если ОбластьЯчеек.КонецСтраницы Тогда
        ОбластьЯчеек.КонецСтраницы = Ложь;
    КонецЕсли;
КонецЦикла;

Сообщить(ТабДокумент.КоличествоСтраниц());
   RomanYS
 
2 - 29.04.21 - 10:55
(0) >>  Однако мы печатаем поверх выверенных ячеек и автомасштаб поставить не можем. Получается у нас макет немного шире чем рассчитывает для печати 1ска.
Какие-то взаимноисключающие вводные: или вы печатаете и попадаете в ячейки бланка или "макет немного шире".
   Ilnazio
 
3 - 29.04.21 - 11:02
(2) Мы попадаем в клетки, с этим все в порядке. Пожалуйста, давайте сосредоточимся на том что нужно удалить последнюю или вторую страницу
   mikecool
 
4 - 29.04.21 - 11:03
(3) не на том ты сосредотачиваешься
посмотри на макет свой - удали снизу и справа лишние пустые колонки
   Kassern
 
5 - 29.04.21 - 11:03
(3) а зачем ее выводить, а потом удалять? Использовать области в макете религия не позволяет? Есть замечательный метод у таб дока  - проверитьВывод()
   mikecool
 
6 - 29.04.21 - 11:04
+4 так то параметрами задать печать только 1 страницы
   mikecool
 
7 - 29.04.21 - 11:04
сорри за офф, но очередной хирург - удаление гландов через зад
   Kassern
 
8 - 29.04.21 - 11:11
(7) мне эта ветка напомнила тему с бекапами, где один пытался делать бекапы скульной базы через выгрузку ДТ, искал способы, как всех выкинуть из 1ски, издевался над шедулером скриптами, пытался писать события в журнал винды, чтобы по ним понимать, когда последний пользователь вышел из 1ски и многое другое...И так же писал, мол скульную выгрузку не предлагать, давайте сосредоточимся на выгрузку ДТ и пофиг, что она может не загрузиться потом)
   Вафель
 
9 - 29.04.21 - 11:36
можно задать область печати если уж так нужно
   Ilnazio
 
10 - 29.04.21 - 14:09
(8) Я понимаю что вы поопытнее, но не шакалами же быть ёмае) Будьте добрее!
Макет большой по краям, но мне так и нужно чтобы распечатать данные поверх листка нетрудоспособности.
Информация которую я могу вытащить методом ПроверитьВывод() о том помещается ли страница или нет, я полагаю мне ничего не даст. Я получу информацию что не помещается, а дальше что?
   RomanYS
 
11 - 29.04.21 - 14:14
(10) Твои мучения не понятны. Если это фиксированный макет, то просто его поправь чтобы влезал.
Первое что стоит попробовать - поставить поля снизу равными 0. Возможно этого будет достаточно.
   НЕА123
 
12 - 29.04.21 - 14:17
(0)
ОбластьПечати
?
   Ilnazio
 
13 - 29.04.21 - 14:48
(11) Не могу подправить, пойми, видел листок нетрудоспособности? Печать поверх ячеек выверена до миллиметра
   Ilnazio
 
14 - 29.04.21 - 14:48
(12) Можно поподробнее пожалуйста, что вы имели в виду?
   RomanYS
 
15 - 29.04.21 - 14:55
(13) Ещё раз мысль из (2): или выверено до миллиметра или не помещается. Если не помещается, значит надо поправить. Поле (в параметрах страницы) изменить пробовал?
   mikecool
 
16 - 29.04.21 - 14:57
   МимохожийОднако
 
17 - 29.04.21 - 14:58
(10) Добавляешь новую страницу, заголовки таблицы и т.д и т.п.
   d_monah
 
18 - 29.04.21 - 15:01
Макет шире или длиннее?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.