Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Программное закрытие выскакивающего окна

Программное закрытие выскакивающего окна
Я
   argon4ik
 
28.04.21 - 16:18
Доброго времени суток, уважаемые форумчане! Прошу подсказки. Имеется внешняя обработка в конфигурации 1С:УНФ. В заказе покупателя при заполненной табличной части после выбора организации вылезает окно "Цены и валюта". Пытаюсь в процедуре "ОрганизацияПриИзменении" отловить момент открытия формы и закрыть ее. Но особо не получается. Сейчас появляется ошибка отсутствия объекта "ДатаДокумента".
Закрывать пытаюсь так:
Форма = ПолучитьФорму("ОбщаяФорма.ФормаЦеныИВалюта");
  Если Форма.Открыта() Тогда
    Сообщить(Форма.Открыта());
    Форма.Закрыть();                        
  КонецЕсли;
   del123
 
1 - 28.04.21 - 17:31
Как вариант, поставить точку остановки у формы ФормаЦеныИвалюта в процедуре "ПриСозданииНаСервере" и посотреть Стек вызовов, что бы понять откуда именно она открывается.
   argon4ik
 
2 - 28.04.21 - 17:40
Откуда открывается - знаю: Процедура ОбработатьИзмененияПоКнопкеЦеныИВалюты(Знач ВалютаРасчетовПередИзменением, ПересчитатьЦены = Ложь, ПерезаполнитьЦены = Ложь, ТекстПредупреждения = "")
Открывается этой строчкой: ОткрытьФорму("ОбщаяФорма.ФормаЦеныИВалюта", СтруктураПараметров, ЭтотОбъект, , , , ОписаниеОповещения, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);

Вот в том и вопрос, как из внешней обработки отменить этот исходный код?..
   del123
 
3 - 28.04.21 - 18:17
Так, видимо, нужно доработать внешнюю обработку, что бы данная процедура не выполнялась? Полагаю, изменить способ заполнения документа Заказ покупателя
   dmt
 
4 - 28.04.21 - 18:30
Окна = ПолучитьОкна();
    Для каждого Ок Из Окна Цикл
        Если Ок.Заголовок = "Мое" Тогда
            Ок.Содержимое[0].Закрыть();
        КонецЕсли; 
    КонецЦикла;
   argon4ik
 
5 - 29.04.21 - 14:27
(4)Большое спасибо! То, что нужно!
   argon4ik
 
6 - 29.04.21 - 14:28
(3) (4) Но вот все-таки очень стал интересовать вопрос, как из обработки можно отменить выполнение строки исходного кода конфигурации?
   argon4ik
 
7 - 29.04.21 - 15:49
(6) Сделал аннотацией &Вместо, но заменил всю процедуру..

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.