Вход | Регистрация
 

размер бумаги программно из 1С при сохранении в PDF

размер бумаги программно из 1С при сохранении в PDF
Я
   Гений 1С
 
28.04.21 - 10:58
Опять стала актуальна тема: Как указать размер бумаги принтера из 1с?
Можно указать размер бумаги при сохранении в PDF?
хочу этикетки сохранянять по размеру.
   d4rkmesa
 
1 - 28.04.21 - 11:01
   Гений 1С
 
2 - 28.04.21 - 12:00
(1) спасибо
   Гений 1С
 
3 - 28.04.21 - 20:41
(1) сработало:
    Если ВыбВидФайлаРезультата = "MXL" Тогда
        ТРезультат.Записать(ИмяВременногоФайлаРезультата);
    ИначеЕсли ВыбВидФайлаРезультата = "PDF" Тогда
        Если ВыбПолеММ <> 0 Тогда
            ТРезультат.ПолеСлева = ВыбПолеММ;
            ТРезультат.ПолеСправа = ВыбПолеММ;
            ТРезультат.ПолеСнизу = ВыбПолеММ;
            ТРезультат.ПолеСверху = ВыбПолеММ;
        КонецЕсли;
        Если ВыбШиринаММ <> 0 Тогда//100*60?

            ТРезультат.ШиринаСтраницы = ВыбШиринаММ;
        КонецЕсли;
        Если ВыбВысотаММ <> 0 Тогда//100*60?

            ТРезультат.ВысотаСтраницы = ВыбВысотаММ;
        КонецЕсли;
        Если ВыбМасштаб <> 0 Тогда//100*60?

            ТРезультат.МасштабПечати = ВыбМасштаб;
        КонецЕсли;
        ТРезультат.Записать(ИмяВременногоФайлаРезультата, ТипФайлаТабличногоДокумента.PDF);
    КонецЕсли;
   d4rkmesa
 
4 - 28.04.21 - 20:50
(3) "Custom" формат не помог? Возможно, нужны еще драйверы целевого принтера, я заметил, 1С-овское сохранение в pdf без них нормально иногда не работает.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.