Вход | Регистрация
 

Вызвать оповещение закрытия формы в документе.

Вызвать оповещение закрытия формы в документе.
Я
   23th
 
27.04.21 - 07:02
Я из обрбаотки открываю новый документ. Потом его заполняю и нажимаю "Записать и закрыть", и мне необходимо получить ссылку на только что созданный документ в форму обработки.

Для этого я открываю форму нового дока.

ПараметрыОткрытияФормы = Новый Структура;
ПараметрыОткрытияФормы.Вставить("Партнер", Партнер);
ПараметрыОткрытияФормы.Вставить("ИДПартнера", ИДПартнера);
ПараметрыОткрытияФормы.Вставить("НомерЗаказа", НомерЗаказа);
        
ОткрытьФорму(
"Документ.ПриходнаяНакладная.ФормаОбъекта",
ПараметрыОткрытияФормы,
ЭтотОбъект,,,,
Новый ОписаниеОповещения("ОбработкаКомандыЗавершенияСозданияДокумента", ЭтотОбъект));

Описываю процедуру оповещения:

&НаКлиенте
Процедура ОбработкаКомандыЗавершенияСозданияДокумента(Результат, ДополнительныеПараметры)  Экспорт
    
    Если Результат = Неопределено тогда
        Возврат;
    КонецЕсли;
    
    Если Результат <> Неопределено тогда
        Если ТипЗнч(Результат) = Тип("ДокументСсылка.ПриходнаяНакладная") тогда
            ПриходнаяНакладная = Результат;
        ИначеЕсли  ТипЗнч(Результат) = Тип("ДокументСписок.РасходнаяНакладная") тогда
            РасходнаяНакладная = Результат;
        КонецЕсли;
    КонецЕсли;
    
    УстановитьКнопку();
    
КонецПроцедуры

А затем в самой форме документа не пойму куда писать передаваемые параметры.
Посмотрел в событии ПриЗакрытии(ЗавершениеРаботы), но там ничего такого нет.
Например если сделать свою кнопку "Закрыть" и закрывать с помощью нее, то можно через команду Закрыть(Параметры.Ключ) передать этот параметр в обработку. Но тут же я не буду придумывать свою кнопку. Хочу пользоваться штатной кнопкой "Записать и закрыть".

Всем спасибо за помощь и совет!
   23th
 
1 - 27.04.21 - 07:18
Оповещение закрытия выдает "Неопределено" конечно же.
Где этот Результат в форме документа можно прописать?
   Vinianel
 
2 - 27.04.21 - 07:43
(1) ПриЗакрытии, Оповестить().

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.