Вход | Регистрация
 

УФ: Как перехватить возвращаемое формой значение и вернуть другое

УФ: Как перехватить возвращаемое формой значение и вернуть другое
Я
   Гений 1С
 
25.04.21 - 18:06
Закрыть(ВозвращаемоеЗначение)
Как перехватить и вернуть другое в расширении?
   Ненавижу 1С
 
1 - 25.04.21 - 19:16
Реквизит формы МояПодменаЗакрытия - булево
В перед закрытием:

Если Не МояПодменаЗакрытия Тогда
  Отказ = Истина;
  СтандарнаяОбработка = Истина;
  МояПодменаЗакрытия = Истина;
  Закрыть(КакЯХочу);
КонецЕсли;
   Гений 1С
 
2 - 25.04.21 - 19:42
(1) КакЯхочу хотелось бы получить, чтобы не подменять типовой код по его заполнению.
   Ненавижу 1С
 
3 - 25.04.21 - 22:22
&НаКлиенте
Перем ОписаниеЗакрытия;

&НаКлиенте
Процедура Расш1_ПриОткрытииПосле(Отказ)
    
    ОписаниеЗакрытия = ОписаниеОповещенияОЗакрытии;
    ОписаниеОповещенияОЗакрытии = Новый ОписаниеОповещения("ЗакрытиеФормы",ЭтотОбъект);
    
КонецПроцедуры

&НаКлиенте
Процедура ЗакрытиеФормы(Результат,ДопПараметры) Экспорт

    Если ТипЗнч(Результат)=Тип("Структура") Тогда
        Результат.Вставить("Дополнение","Есть!");    
    КонецЕсли; 
    
    Если ОписаниеЗакрытия<>Неопределено Тогда
        Выполнить("ОписаниеЗакрытия.Модуль."+ОписаниеЗакрытия.ИмяПроцедуры+"(Результат,ДопПараметры);");        
    КонецЕсли;     
    
КонецПроцедуры
   Конструктор1С
 
4 - 26.04.21 - 07:33
(0) опять элитарные костыли прикручиваешь?
   Гений 1С
 
5 - 26.04.21 - 08:07
(3) погоди, ЗакрытиеФормы - когда вызовется и где, на вызывающей форме или на закрываемой? Что-то не уловил логики.
   Ненавижу 1С
 
6 - 26.04.21 - 08:16
(5) это все модуль расширения "закрываемой" формы
в при открытии переопределяется оповещение о закрытии формы
   Гений 1С
 
7 - 26.04.21 - 09:00
(6) дошло, прикольно. Только вот есть сомнения что отработает. При закрытии все локальные переменные очищаются. В модуле процедуры по нажатию кнопки ОК была переменная МассивСтрок.
Я вынес ее во внешние, так вот при закрытии она уже была пуста.
Думаю, лучше использовать дополнительные параметры оповещения.
   Ненавижу 1С
 
8 - 26.04.21 - 11:03
(7) я проверил работает, откуда дрова про "При закрытии все локальные переменные очищаются"?
   Ненавижу 1С
 
9 - 26.04.21 - 11:03
(8) если объект еще не уничтожен
   Гений 1С
 
10 - 26.04.21 - 11:05
(8) проверил отладчиком, жди статьи на гении
   Гений 1С
 
11 - 26.04.21 - 11:05
(9) в любом случае если использовать параметры, так надежнее и не нужно локальную переменную создавать.
   Ненавижу 1С
 
12 - 26.04.21 - 11:06
(10) мы уже устали ждать про RLS
   Гений 1С
 
13 - 26.04.21 - 11:07
(12) ну статья написана, только там через неделю наверное выйдет. я сейчас пишу статьи на гения во время работы
   Гений 1С
 
14 - 26.04.21 - 11:23
4 мая в 10:00 читай.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.