Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1С-ЭДО отправка Счетов на оплату через роуминг в PDF

1С-ЭДО отправка Счетов на оплату через роуминг в PDF
Я
   Garykom
 
24.04.21 - 15:39
Собственно через 1С-ЭДО счета на оплату контрагентам улетают в XML формате CML_2.08 сейчас в т.ч. через роуминг ЭДО.
Контрагент же использует допустим СБИС или Диадок или еще что т.е. другой оператор ЭДО не понимает этот
https://v8.1c.ru/tekhnologii/obmen-dannymi-i-integratsiya/standarty-i-formaty/standarty-commerceml/commerceml-2/

Кто то уже заморачивался написанием расширения чтобы автоматом выставить настройку для таких контрагентов свою
И улетали https://1c-edo.ru/handbook/22/3978/ Произвольные документы автоматом
   Garykom
 
1 - 24.04.21 - 15:42
(0)+ Нашел полезное в комментариях https://infostart.ru/public/1124365/

Сейчас вот собираюсь сам такое расширение ваять, но подумал а вдруг уже есть?
   Garykom
 
2 - 26.04.21 - 09:56
Так сталкивался кто с подобной проблемой?
   Builder
 
3 - 26.04.21 - 10:39
С какой проблемой? Что счета в xml в роуминге не работают? Да, столкнулись.
Отправляем счета в PDF, все работает.
   Garykom
 
4 - 26.04.21 - 10:41
(3) Как "Отправляем счета в PDF"?

Вручную бух сидит и делает "Отправка произвольного документа" ?
   Garykom
 
5 - 26.04.21 - 10:42
(4)+ у нас 6к счетов в месяц :)
   Builder
 
6 - 26.04.21 - 11:01
(4) Нет конечно, но у нас хитрая схема.
Основная база первички на 7.7, там формируется комплект документов (счет в PDF и УПД в XML) и через СБИС-Коннект все отправляется в одном пакете автоматом.
   Garykom
 
7 - 26.04.21 - 11:07
(6) таки я про 1С-ЭДО спрашиваю
   Builder
 
8 - 26.04.21 - 11:09
(7) Таки я отвечаю что тоже столкнулся с проблемой счетов в роуминге :)
   Ногаминебить
 
9 - 26.04.21 - 11:35
(5) При таком объеме кнопка в просмотре печати не особо поможет. Я сделал чтобы электронный документ автоматом создавался, цеплялась пдф и клалось все на подпись и отправку в ЭДО в момент формирования документа в 1С.
   Garykom
 
10 - 26.04.21 - 11:37
(9) Иии?
Конфа какая и как сделал? Расширением? Можно глянуть?
   Ногаминебить
 
11 - 26.04.21 - 12:04
Конфа БП КОРП 3.0. Сделал в обработку автоматического создания документов. Просто те, что не на ЭДО - на принтер идет печать комплекта, а для этих чтоб бумагу не переводить впустую электронный создается. Не расширение.
Там небольшая процедурка строк на 50, текст которой даже вроде частично стянул откуда-то. Могу в почту пульнуть если интересно. Наверное она не особо православна, но работает и ладно. :)
   lepoissonherisson
 
12 - 26.04.21 - 12:10
И мне, и мне.
Так как у меня все это было мимо ЭДО, но у меня была 2.0 , а теперь 3.0 будет , а думать некогда ..
переход на новую версию 15 мая ..
litoolu@mail.ru
заранее признателен
   sitex
 
13 - 26.04.21 - 12:21
(0) Может пакет сформировать для тех кто сидит на 1С ЭДО и  для тех кто сидит на остальных , к одному контейнеру  формировать и  в pdf и xml.
   lepoissonherisson
 
14 - 26.04.21 - 12:27
(11) Спасибо !
   Garykom
 
15 - 26.04.21 - 12:33
(13) вот собираюсь с таким поэкспериментировать
   Aleksey
 
16 - 26.04.21 - 13:48
   Garykom
 
17 - 26.04.21 - 13:54
(16) Намекаешь отладчиком проследить что происходит и сделать аналогично?
   sitex
 
18 - 26.04.21 - 14:04
(17) Есть другие варианты ?
   Garykom
 
19 - 24.05.21 - 12:22
Подниму тему

Последнее обновление типовой БП3 позволяет кучу документов отправлять разных по ЭДО

Но вот для "Счет покупателю" по прежнему только "CML 2.08"
https://i2.paste.pics/61a3e774a7ce07f4d6c39aab441ad19a.png

И вот хочется воскликнуть: "Доколе?"

ЗЫ
А еще теперь низзя отправить документы по ЭДО из закрытого периода
Вероятно потому что пытается нечто в них записать при отправке и перепровести

ЗЗЫ
Раньше можно было до обновления подсистемы ЭДО

ЗЗЗЫ
Бухи волнуются
   Ногаминебить
 
20 - 24.05.21 - 15:51
Блин. Сел как раз посмотрел новый релиз... Эти гады половину объектов заменили на другие, а что не заменили, то переименовали и тип поменяли. Теперь все, что нажито непосильным трудом, заново рисовать.
Про закрытый период странно. Регистр же для состояния ЭДО был. Значит и туда добрались.
   Garykom
 
21 - 24.05.21 - 16:20
(20) Угу они теперя галочку "Подписан" ставят в доке походу
   Garykom
 
22 - 24.05.21 - 16:21
(21)+ Короче как обычно допиливать расширением придется
   Aleksey
 
23 - 24.05.21 - 16:41
Ну они вообще в бухии отдельный документ запилили
   Garykom
 
24 - 24.05.21 - 17:13
Еще одна бага всплыла
Теперь акты сверок автоматом попадают в исходящие по ЭДО

Бухам привалило работы ибо большая часть актов они для себя, отправлять их не надо

И проблема что менеджеры коммерческого отдела с правом создавать документы акты сверки взаиморасчетов но без прав на ЭДО теперь не могут из записать (и провести) после создания и заполнения

Короче обновление ЭДО какой то ахтунг

Еще и дату получения эл.дока исходящего в списке (в архиве) теперь не видно, только отправки и подписания
   Ногаминебить
 
25 - 24.05.21 - 17:17
А это 92 или 93?
   Garykom
 
26 - 24.05.21 - 17:18
(25) У нас уже 93
Бухгалтерия предприятия, редакция 3.0 (3.0.93.20)
   pechkin
 
27 - 24.05.21 - 17:33
а зачем нужен акт сверки для себя. можно же просто оборотку посмотреть
   Garykom
 
28 - 24.05.21 - 17:47
(27) Нету у менагеров прав на оборотку
   polosov
 
29 - 24.05.21 - 17:50
(28) Компания - адепт мысли, что БП подходит для всего и вся?
   Garykom
 
30 - 24.05.21 - 17:53
(29) Компания пока не смогла КА и выкручивается как может
 
 
   Garykom
 
31 - 24.05.21 - 17:55
Проблема что 1С выкатила конкретно недоработанное обновление 1С-ЭДО

Не думаю что только у нас траблы, остальные просто вероятно еще не обновились и/или не напоролись
   Ногаминебить
 
32 - 08.06.21 - 11:54
Добрались мои руки до этого релиза. Сразу же мой самосборный профиль группы доступа оказался недостаточным. Есть у кого-то актуальный список ролей, которые надо дать?
   Garykom
 
33 - 08.06.21 - 12:44
(32) Это чтобы доки записывать?
Там Чтение настроек обмена с контрагентами минимум
И Чтение электронных документов если надо
   sitex
 
34 - 08.06.21 - 12:52
(33) Так получилось расширение то создать или нет?
   Garykom
 
35 - 08.06.21 - 13:11
(34) Пока не до того, там много других проблем и ошибок выявилось, более срочных
   Ногаминебить
 
36 - 09.06.21 - 15:18
А мне пока местами даже нравится. ИнтерфейсДокументовЭДОВызовСервера.СоздатьЭлектронныйДокументПоФайлу прямо порадовало когда нашел. Правда полдня убил на поиск своего же косяка, когда вместо имени файла в один из параметров фиганул полный путь и оно сыпалось в момент отправки с нецензурными словами о транспортных контейнерах и неизвестных ошибках.
   Ногаминебить
 
37 - 17.06.21 - 16:54
Столкнулся то ли с багом, то ли с фичей.
Счет-фактура на аванс иногда не попадает автоматически в обработку Текущие дела ЭДО. И в форме списка висит без статуса ЭДО (должно быть Не начат). Ранее такое решалось перепроведением документа, а сейчас вот хоть тресни, не хочет. Понимаю, что почему-то не пишет в регистр СостоянияПоОбъектамУчетаЭДО, но пока не выходит отловить на каком шаге затык. Может кто такое же чинил?
   Garykom
 
38 - 17.06.21 - 17:40
(37) Столкнулся с другой багой, наоборот галочки для всех контрагентов в настройках с АктСверки сняты но отдельные все равно как то в ЭДО к созданию проскакивают
   zak555
 
39 - 17.06.21 - 17:56
(37) что в настройке с контрагентом?

Используются упд /укд?
   Ногаминебить
 
40 - 17.06.21 - 17:58
(38) Ощущение, что оно своей жизнью живет. Буду на 95.15 переходить (все равно счет-фактура новый необходим). Ну и мабуть что-то пофиксится. А как временное решение - регламент, который ищет где нет записи регистра и ее создает. Иначе точно забудут доки отправить.
Мне вот удивительно. Неужели только пара человек на всю мисту с ЭДО мучается?
   Ногаминебить
 
41 - 17.06.21 - 18:05
(39) Счет-фактура выданный -  УПД 2019. Но с галочками экспериментировал, вообще не нашел закономерности никакой. Эта запись и в предыдущих релизах могла по какому-то произвольному счету-фактуре не создаться, но перепроведением хотя бы фиксилось. А сейчас фигушки. Хотя статистики пока маловато собрал по новому релизу и наверное временно решу костылем, а уже после 95.15 буду думать.
   Ногаминебить
 
42 - 23.06.21 - 18:09
Раз уж тема есть, то тоже сюда.
Не могу найти кнопку Добавить в пакет на форме Электронного документа исходящего. Пусто там. И главное все описания на ИТС подразумевают, что она есть по умолчанию начиная с 3.0.92.51. Сейчас 3.0.93.20, но что-то подсказывает, что и в 3.0.95.15 она сама собой не появится.
   Ногаминебить
 
43 - 23.06.21 - 18:21
Отбой. Выкопал что оно доступно только для ЧерезСервис1СЭДО, а у нас ЧерезОператораЭДОТакском. Печаль.
   Slashman6667
 
44 - 25.06.21 - 17:17
Народ, всем привет)))
Нашел единомышленников))) У меня ЭДО был перепахан ОТ и ДО, пытаюсь понять что куда теперь улетело после обновы))) Сейчас разом с 89 на 95 скачу... Кто подскажет куда улетела функция СформироватьXMLФайл?

У меня там был вот такой код, не могу теперь понять куда лезть чтобы по аналогии сделать:

Результат = дн_ЭДОВызовСервера.СформироватьСчетНаОплатуPDF(
                    ОбъектДляВыгрузки, ПараметрыФормирования);

//    

//Результат = ОбменСКонтрагентамиВнутренний.СформироватьСчетНаОплатуПоДокументу(
                              //    ОбъектДляВыгрузки, ПараметрыФормирования);
   Garykom
 
45 - 25.06.21 - 17:20
(44) ссылка в (1) смотри комменты
и тут не так давно геня1с писал https://infostart.ru/1c/articles/1453038/
   Slashman6667
 
46 - 27.06.21 - 10:12
(45) Да читал. Но инфы капец мало как...
Раньше я тупо подменял процедуру формирования файла CML процедурой формирования PDF файла. Сейчас там все не так однозначно.
Прочитал выше в комментах про ИнтерфейсДокументовЭДОВызовСервера.СоздатьЭлектронныйДокументПоФайлу.
Но у меня ЭДО-Такском. Вопрос будет ли это работать? Хочу попробовать PDF теперь не привязывать к документу Счет, а создавать произвольный документ с PDF вложением и связывать структурой подчиненности.
ИМХО наверное самый простой способ будет...
И еще вопрос. Раньше я одной процедурой делал комплект документов по массиву ссылок объектов учета...
Сейчас где аналог? И есть ли особенности?
Процедура СоздатьКомплектДокументов(ПараметрКоманды, ПараметрыВыполненияКоманды) Экспорт
    
    Отказ = Истина;
    Если ЗначениеЗаполнено(ПараметрКоманды) Тогда
        Если ТипЗнч(ПараметрКоманды) = Тип("ДокументСсылка.СчетНаОплатуПокупателю") ИЛИ 
            (ТипЗнч(ПараметрКоманды) = Тип("Массив") И ТипЗнч(ПараметрКоманды[0]) =  Тип("ДокументСсылка.СчетНаОплатуПокупателю"))    Тогда
            Отказ = Ложь;
        КонецЕсли;            
    КонецЕсли;
    
    Если Отказ = Истина Тогда
        Сообщить("Комплект ЭД создается на основании счета!");
        Возврат;
    КонецЕсли;
    
    Если ТипЗнч(ПараметрКоманды) = Тип("Массив") Тогда
        МассивСсылок = ПараметрКоманды;
    Иначе
        МассивСсылок = Новый Массив;
        МассивСсылок.Добавить(ПараметрКоманды);
    КонецЕсли;
    
    МассивСсылокКомплекта = дн_ЭДОВызовСервера.ВернутьСписокДокументов(МассивСсылок);

    ОбменСКонтрагентамиКлиент.СформироватьПодписатьОтправитьЭД(МассивСсылокКомплекта);
    
КонецПроцедуры
   Slashman6667
 
47 - 27.06.21 - 13:28
В общем разобрался))) Все легко с PDF оказалось))) 
Следующий этап для меня - найти функцию как его программно автоматом подписывать и отправлять) И тоже самое с остальными документами)
   Garykom
 
48 - 27.06.21 - 16:27
(47) Выложи пример как сделал с pdf
   Slashman6667
 
49 - 28.06.21 - 07:55
(48) Да, доеду сейчас до офиса и выложу.
   Ногаминебить
 
50 - 28.06.21 - 09:53
(44) Добро пожаловать в клуб. У меня уже при упоминании ЭДО глаз начинает дергаться.
3.0.95.24 никто еще не пробовал ставить? Напрягло вот это
"Реализована передача сведений о прослеживаемых товарах в электронных документах УПД 2019 (ММВ-7-15/820@), УКД 2020 (ЕД-7-26/736@). Изменения действуют с 01.07.2021 (Постановление Правительства РФ от 02.04.2021 № 534).".  
Оно на более низком релизе с 01.07 вообще не будет слать УПД электронно или если бутоны цветов не продаем - то и пофиг?
   Slashman6667
 
51 - 28.06.21 - 11:47
Процедура СоздатьСчетНаОплатуPDF(ПараметрКоманды, ПараметрыВыполненияКоманды) Экспорт
    
    Отказ = Истина;
    Если ЗначениеЗаполнено(ПараметрКоманды) Тогда
        Если ТипЗнч(ПараметрКоманды) = Тип("ДокументСсылка.СчетНаОплатуПокупателю") ИЛИ 
            (ТипЗнч(ПараметрКоманды) = Тип("Массив") И ТипЗнч(ПараметрКоманды[0]) =  Тип("ДокументСсылка.СчетНаОплатуПокупателю"))    Тогда
            Отказ = Ложь;
        КонецЕсли;            
    КонецЕсли;
    
    Если Отказ = Истина Тогда
        Сообщить("Счет на оплату создается на основании счета!");
        Возврат;
    КонецЕсли;
    
    Если ТипЗнч(ПараметрКоманды) = Тип("Массив") Тогда
        СсылкаНаОбъект = ПараметрКоманды[0];
        ОУ = ПараметрКоманды;
    Иначе
        СсылкаНаОбъект = ПараметрКоманды;
        ОУ = Новый Массив;
        ОУ.Добавить(ПараметрКоманды);
    КонецЕсли;
    
    ПараметрыСоздания = ОбменСКонтрагентамиКлиент.НовыеПараметрыСозданияЭлектронногоДокументаПоФайлу();

    ПараметрыСоздания.ОбъектыУчета  = ОУ; 
    
    Оп = Новый ОписаниеОповещения("ВыполнитьПослеОкончания", ЭтотОбъект);
    
    ОбменСКонтрагентамиКлиент.НачатьСозданиеЭлектронногоДокументаПоФайлу(Оп,ПараметрыСоздания,дн_ЭДОВызовСервера.СформироватьСчетНаОплатуPDF(СсылкаНаОбъект,,КаталогВременныхФайлов(),ПараметрыСоздания));
    
    ИнтерфейсДокументовЭДОКлиент.ОткрытьЭлектронныйДокументОбъектаУчета(СсылкаНаОбъект);
    
КонецПроцедуры
   Slashman6667
 
52 - 28.06.21 - 11:47
Функция СформироватьСчетНаОплатуPDF(СсылкаНаОбъект, ПараметрыФормирования = Неопределено,АдресКаталога, ПараметрыСоздания) Экспорт
    
    ПараметрыСоздания.ВидДокумента = Справочники.ВидыДокументовЭДО.НайтиПоНаименованию("Счет на оплату").Ссылка;
    ПараметрыСоздания.ДатаДокумента = СсылкаНаОбъект.Дата;
    ПараметрыСоздания.Контрагент = СсылкаНаОбъект.Контрагент;
    ПараметрыСоздания.НомерДокумента = СсылкаНаОбъект.Номер; 
    ПараметрыСоздания.Организация = СсылкаНаОбъект.Организация; 
    ПараметрыСоздания.СуммаДокумента = СсылканаОбъект.СуммаДокумента;

    //Если ПечатнаяФорма = Неопределено Тогда //Доделать проброс конкретной формы

    ПечатнаяФорма = ПолучитьПечатнуюФормуДокумента(СсылкаНаОбъект, "СчетНаОплату");
    //КонецЕсли;

    
    ПараметрыПечати = Новый Структура();
    ПараметрыПечати.Вставить("ПечатнаяФорма", ПечатнаяФорма);
    ПараметрыПечати.Вставить("ФорматОтправки",Новый Структура());

    МассивОбъектов = Новый Массив;
    МассивОбъектов.Добавить(СсылкаНаОбъект);
    
    КоллекцияПечатныхФорм = Новый ТаблицаЗначений;
    Для Каждого ИмяКолонки Из УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() Цикл
        КоллекцияПечатныхФорм.Колонки.Добавить(ИмяКолонки);
    КонецЦикла;
    КоллекцияПечатныхФорм.Индексы.Добавить("ИмяВРЕГ");
    
    НоваяСтрПФ = КоллекцияПечатныхФорм.Добавить();
    НоваяСтрПФ.ИмяВРЕГ      =  ВРег(ПечатнаяФорма.Шаблон);
    НоваяСтрПФ.ИмяМакета    =  ПечатнаяФорма.Шаблон;
    НоваяСтрПФ.Экземпляров  =  1;
    
    ПараметрыОтправки = Новый Структура;
    ПараметрыОтправки.Вставить("Получатель", Неопределено);
    ПараметрыОтправки.Вставить("Текст","");
    ПараметрыОтправки.Вставить("Тема","");
    
    ПараметрыВывода = Новый Структура;
    ПараметрыВывода.Вставить("ПараметрыОтправки", ПараметрыОтправки);
    
    Обработки.ПечатьСчетаНаОплату.Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, Новый СписокЗначений(), ПараметрыВывода);
    
    ТабличныйДокумент = КоллекцияПечатныхФорм[0].ТабличныйДокумент;
    
    //Макет = Обработки.ОбменСКонтрагентами.ПолучитьМакет("СчетНаОплату");

    //

    //ДеревоДанных = ЭлектронноеВзаимодействие.ДеревоДокумента(Макет);

    //ОбменСКонтрагентамиПереопределяемый.ЗаполнитьДанныеПоСчету(ДокументЗаполнения, СтруктураЭД, ДеревоДанных, Ложь);

            
    ШаблонПредставлениеВерсии = НСтр("ru = ' (ver. %1)'");
    ПредставлениеВерсии = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонПредставлениеВерсии, 1);
    
    ШаблонПредставленияЭД = НСтр("ru = '%1 %2 %3%4.pdf'");
    СтрокаИмениФайла = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонПредставленияЭД, "Счет на оплату",
        СсылкаНаОбъект.Номер, Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=D"), ПредставлениеВерсии);
        
    ПолноеИмяФайла = АдресКаталога + СтрокаИмениФайла;
    
    ТабличныйДокумент.Записать(ПолноеИмяФайла, ТипФайлаТабличногоДокумента.PDF);
            
    ДвоичныеДанные = Новый ДвоичныеДанные(ПолноеИмяФайла);
        
    ПФ = Новый Структура;
    ПФ.Вставить("ИмяФайла",СтрокаИмениФайла);
    ПФ.Вставить("АдресХранилища",ПоместитьВоВременноеХранилище(ДвоичныеДанные));

    Возврат ПФ;
    
КонецФункции
   Slashman6667
 
53 - 28.06.21 - 11:48
Рабочая функция. Есть немного моей специфики) И просьба не обращать внимание на качество кода пока, все еще в процессе доработки)))
   Slashman6667
 
54 - 28.06.21 - 11:51
(50) Поставил только что))) Но для меня это не самое страшное обновление, так как у меня услуги и очень много агентирования))
С агентированием вообще отдельный вопрос - мне приходится немного извращаться, чтобы отчеты агента(о закупках) отправлять вместе с актом и счет-фактурой. Тут основная сложность, что объект учета у них один - отчет комитента. Приходится одну форму пробрасывать как произвольный документ основнаием которого является отчет комитента(чтобы было видно в структуре), а из самого отчета шлется акт/упд
   Slashman6667
 
55 - 28.06.21 - 11:53
(50) Я буду в ночь со среды на четверг накатывать на боевую базу обнову с релиза 89 на 95-й))) Будет "весело"))
   Arikka
 
56 - 28.06.21 - 15:31
всем привет. в пдф все формирует, исходящий док создает. единственная печаль сейчас вот:
Выполнение операции: Отправка электронного документа.
{"Details":"В контейнере отсутствуют файлы, указанные в meta.xml","AdditionalData":"Не удалось найти в контейнере файл, содержащий тело документа, или файл пуст: c55a71b8-5c03-4be0-9a41-5483a6a8e05f\/C:\\Users\\krasnova\\AppData\\Local\\Temp\\v8_DC01_b.pdf","ApiErrorCode":2105,"CommonDescription":"Некорректный транспортный контейнер","DocflowInfo":null,"StatusCode":400}

как будто он этот нехороший файлик не видит. кто нибудь знаешь что можно с этой бедой сделать?
   Ногаминебить
 
57 - 28.06.21 - 15:46
В имени файла точно только имя, а не полный путь?
   Ногаминебить
 
58 - 28.06.21 - 15:49
Вот тут вот возможно
            ПараметрыФайла = Новый Структура;
            ПараметрыФайла.Вставить("ИмяФайла", "ЗдесьДолжноБытьТолькоИмя.pdf");
            ПараметрыФайла.Вставить("АдресХранилища", ПоместитьВоВременноеХранилище(
                        двданные, УникальныйИдентификатор));
   Arikka
 
59 - 28.06.21 - 15:49
господи, конечно же полный путь(((( неужели в это проблема? почему тогда в файловом варианте все ок, а эта ошибка только в клиент-серверном?
   Ногаминебить
 
60 - 28.06.21 - 15:54
(59) Ну вот так оно сделано. Я в (36) эту косточку уже упоминал. Полдня долбился, не помню уже как догадался, но в итоге заработало.
 
 
   hhhh
 
61 - 28.06.21 - 15:56
(59) наверно путаете клиент и сервер. Полный путь на клиенте, а работаете на сервере. Или наоборот, полный путь указываете на сервере, а обращаетесь с клиента.
   Arikka
 
62 - 28.06.21 - 15:56
Спасибо, добрый человек! я несколько по другому сделала отправку через пдф, как написано в (51). если все пройдет гладенько - отпишусь про свой вариант
   Slashman6667
 
63 - 28.06.21 - 16:01
(59) как костыль можно в сетевую папку сохранять чтобы путь одинаковый был с сервера и с клиента)))) Но это реально костыль)
   Slashman6667
 
64 - 28.06.21 - 16:05
Я тем временем уже нащупал дно в новом ЭДО)
Сейчас доработал Отчет агента в PDF в паре с нетиповым произвольным документом, который находится в общей структуре с документом "ОтчетКомитента".  При этом еще в произвольный документ вставил типовой функционал по статусу отправки))

Осталось мне, в общем, только сделать отдельную команду на пакетную отправку разных комплектов документов по разным видам договоров))
Я думаю что я уже по итогам финиша своего ЭДОмарафона выложу сюда финальный код и описание решений)
   Arikka
 
65 - 29.06.21 - 12:37
в общем счета благополучно отправляются в пдф, отдельное спасибо (36) и вообще этому доброму человеку. функция НачатьСозданиеЭлектронногоДокументаПоФайлу() меня спасла. Для тех, кто так же столкнется с подобной проблемой и будет сидеть и думать с чего начать:
действия можно начинать с формы обработки ИнтерфейсДокументовЭДО форма ТекущиеДелаПоЭДО функция СформироватьПодписатьИОтправить
здесь у нас в наличии массив с объектами учета из которого прекрасно выдираются отдельные счета на оплату Если ТипЗнч(СсылкаНаДок) = Тип("ДокументСсылка.СчетНаОплатуПокупателю") Тогда
ну а далее вот такой код

///////////можно например пройти массив НаборОбъектовУчета циклом, можно как то еще - тут ограничение - только фантазия

для каждого стр из НаборОбъектовУчета цикл
        СсылкаНаДок = стр;    

///////////////////////////////////////

/////////// далее определяем параметры, которые нужно передать в вышеупомянутую функцию

/////////// именно с этим было больше всего проблем, так как не удалось найти типовых аналогов ее вызова


                
                
////////////// функция ПолучитьПараметры() описана ниже. возможно есть что-то типовое, мне было лень с этим возиться

//в целом здесь я определяю основные реквизиты документа ЭДО

                ПараметрыФормирования = ПолучитьПараметры(СсылкаНаДок);
////////////////////////////////////////////////////////////////

///////////////здесь определяю типовую обработку завершения и ее параметры                

                ПраметрыОжидания = ОжиданиеОперацийБЭДКлиент.НовыеПараметры();
                ПраметрыОжидания.Заголовок = НСтр("ru = 'Выполняется обмен электронными документами'");
                КонтекстОжиданияОперации = ОжиданиеОперацийБЭДКлиент.НовыйКонтекст(ПраметрыОжидания);
                
                ПараметрыОповещения = Новый Структура;
                ПараметрыОповещения.Вставить("КонтекстОжиданияОперации", КонтекстОжиданияОперации);
                ПараметрыОповещения.Вставить("ОповещениеЗавершения", ОповещениеЗавершения);
                
                ОповещениеОЗавершении = Новый ОписаниеОповещения("ОтправкаПолучениеЭДЗавершение", ИнтерфейсДокументовЭДОКлиент,ПараметрыОповещения);

//////////////////////////////////////////////////

//Структура, по сути есть смысл возвращать только ТабДок, то есть стандартная ПФ только в ПДФ. как и откуда ее вызывать - решайте сами                                
                СтруктураВозврата = СоздатьСчетНаОплатуPDF(СсылкаНаДок); 


        ////ну а далее с этим табдоком делаем всякое, для этого по идеи надо отдельную функцию, я запихала это сюда для примера        

                ТабДок = СтруктураВозврата.ТабДок;
                путьКФайлу=ПолучитьИмяВременногоФайла("pdf");
                ТабДок.Записать(путьКФайлу,ТипФайлаТабличногоДокумента.PDF);
                
                ВыбФайл = Новый Файл(путьКФайлу);
                ИмяФайла = ВыбФайл.Имя;
                
                ДвоичныеДанные = Новый ДвоичныеДанные(путьКФайлу);
                
                АдресХранилища = ПоместитьВоВременноеХранилище(ДвоичныеДанные);
////для того, чтобы сформировать вот такие параметры файла и передать их в типовую функцию


                ПараметрыФайла = новый Структура;
                ПараметрыФайла.Вставить("АдресХранилища",АдресХранилища);  
                ПараметрыФайла.Вставить("ИмяФайла",ИмяФайла);  
                
////здесь мы к ней и обращаемся, дальше 1с все делает сама

                ИнтерфейсДокументовЭДОКлиент.НачатьСозданиеЭлектронногоДокументаПоФайлу(ОповещениеОЗавершении,ПараметрыФормирования,ПараметрыФайла);





функция ПолучитьПараметры(СсылкаНаДок)  
    ПараметрыФормирования  = новый Структура;
    
    ПараметрыФормирования.Вставить("Контрагент",СсылкаНаДок.Контрагент);
    ПараметрыФормирования.Вставить("Организация",СсылкаНаДок.Организация);
    ПараметрыФормирования.Вставить("Договор",СсылкаНаДок.ДоговорКонтрагента);
    ПараметрыФормирования.Вставить("НомерДокумента",СсылкаНаДок.Номер);
    ПараметрыФормирования.Вставить("ДатаДокумента",СсылкаНаДок.Дата);
    ПараметрыФормирования.Вставить("СуммаДокумента",СсылкаНаДок.СуммаДокумента);
    ПараметрыФормирования.Вставить("ВидДокумента","");
    ПараметрыФормирования.Вставить("ТипДокумента",Перечисления.ТипыДокументовЭДО.СчетНаОплату);

    
    ОбъектыУчета = Новый Массив;
    ОбъектыУчета.Добавить( СсылкаНаДок);
    ПараметрыФормирования.Вставить("ОбъектыУчета",ОбъектыУчета);
    
    возврат ПараметрыФормирования;
КонецФункции


Надеюсь кому-то поможет и будет понятен такой вариант решения, я с этим делом хлебнула горя, поэтому по возможности делюсь
   Ногаминебить
 
66 - 01.07.21 - 14:29
Встретил вчера еще один веселый глюк. Поделюсь, вдруг кто-то так же попадет.
При попытке создать Электронный документ вылетает окошко с требованием настроить обмен с контрагентом. При этом обмен давно настроен и уже документами обмениваемся год. Повторная запись настроек не помогает.
Причина. В документ (в моем случае реализация, но может быть и еще что-то) в реквизит ВидЭлектронногоДокумента записано значение перечисления ТипыДокументовЭДО, от которого 1С в новом релизе отказалось и оно теперь имеет приставку (Не используется). И все. Хоть перезаполняй, хоть перепроводи - фигушки тебе, а не ЭДО. Решается программной подстановкой в реквизит актуального значения.
   Garykom
 
67 - 01.07.21 - 15:29
(66) Там еще глюка есть что надо в доках перевыбрать Контрагента и тогда исходящий ЭДО создаст
   PuhUfa
 
68 - 01.07.21 - 16:01
Ну раз апнули тему, спрошу: А как отказаться от ЭДО по конкретному виду документа? Убираю в настройках обмена "галку" со счета, но один фиг, ЭДО предлагает мне создать по нему электронный документ и произвести обмен. Приходится каждый счет руками принудительно закрывать.
   Garykom
 
69 - 01.07.21 - 16:27
(68) Это баг - уже сообщил через своего франча
   Garykom
 
70 - 01.07.21 - 16:28
(69)+ У нас акты сверки некоторые проскакивают почему то, хотя для всех контрагентов галки поснимали
   Ногаминебить
 
71 - 02.07.21 - 14:25
Кто уже на 3.0.95.29 или хотя бы на 3.0.95.24 - в ЭЛЕКТРОННОМ варианте Счета-Фактуры поле "Документ об отгрузке №" заполняется?
Потому что у меня в 3.0.95.15 оно пустое (в печатных формах все хорошо) и вот думаю либо срочно обновляться, либо искать причину в коде.
Описание релиза смотрел.
"Реализована передача сведений о прослеживаемых товарах в электронных документах УПД 2019 (ММВ-7-15/820@), УКД 2020 (ЕД-7-26/736@). Изменения действуют с 01.07.2021 (Постановление Правительства РФ от 02.04.2021 № 534)." - это оно и есть?
   Ногаминебить
 
72 - 06.07.21 - 12:13
Новый день, новые глубины адской задницы. То, что продолжают сыпаться транспортные контейнеры непонятно от кого с пустым идентификатором отправителя- это ладно. Отменяем, надеемся, что придут потом нормальные.
Но вот один случай прям вопиющий. Во ВХОДЯЩИХ появился НАШ акт выполненных работ, где МЫ исполнитель. Причем мы его отправили 31.03 и он так и висит в исходящих со статусом ожидается подтверждение, а теперь вот пришел нам с подписью контрагента, но без нашей.
   Ногаминебить
 
73 - 28.07.21 - 09:54
Подниму ветку ибо у меня уже походу глюки начинаются. Надеюсь кто-то поможет их упорядочить.
В исходных данных имеем БП КОРП 3.0.96.30. (Знаю, что вышла уже 98. Вот прибыль с имуществом сдадут и буду обновляться.) В настройках обмена с контрагентом для счета-фактуры стоит УПД 2019 (ММВ-7-15/820@) (ну а там ничего больше и не выберешь в общем-то).
В (71) я уже интересовался заполняется ли в электрическом счете-фактуре графа 5а. Тогда не ответили, но у меня в башке почему-то прочно сидит, что я после перехода на 3.0.96.30 проверил и убедился в правильности работы и ЧСХ главбух тоже проверила и убедилась. В общем не суть. Проблема в том, что вчера вдруг обнаружилось неприятное. Туда попадает не номер реализации, а номер самого счета фактуры. Чья дата туда попадает непонятно ибо они одинаковые (такой вот тонкий утренний программистский юмор, да). Изучение кода Процедуры ЗаполнитьОсновнуюЧастьУПД_2019 из общего модуля ОбменСКонтрагентамиБП выдало вот такой кусочек:
        СведенияОДокументеОтгрузки = Новый Структура;
        СведенияОДокументеОтгрузки.Вставить("Номер", ДанныеШапки.Номер);
        СведенияОДокументеОтгрузки.Вставить("Дата" , ДанныеШапки.Дата);
        
        НоваяСтрока.СведенияОДокументеОтгрузки = СведенияОДокументеОтгрузки;
То есть номер счета-фактуры туда пихают совершенно осознанно.
При этом в выше есть 
ДокументРеализации = ДокументРеализацииУПД(ДанныеДляФормированияЭД);
но эти данные почему-то никак не используются.
Дальше больше. В процедуру передаются ДанныеШапки и там есть ДокументыОбОтгрузке. Строка, в которой аккуратно собрано то, что надо поместить в 5а. И в ДеревоДанных тоже есть ДокументОбОтгрузке с типом строка. Но почему-то скрестить их друг с другом забыли (или не нужно оно и это вообще из другой оперы, или это задел на будущее, короче неясно) Хотя и напрашивается "ЭлектронноеВзаимодействие.ЗаполнитьЗначениеРеквизитаВДереве(ДеревоДанных, "ДокументОбОтгрузке", ДанныеШапки.ДокументыОбОтгрузке);"
Ну и собственно что я сделал.
1. Подменил номер и дату счета фактуры на номер и дату реализации.
2. На всякий случай добавил ЭлектронноеВзаимодействие.ЗаполнитьЗначениеРеквизитаВДереве(ДеревоДанных, "ДокументОбОтгрузке", ДанныеШапки.ДокументыОбОтгрузке);

Эксперименты показали, что после 1 графа 5а в Содержимом Исходящего электронного документа заполняется правильно. После 2 без 1 этого не происходит, но на всякий случай решил оставить то и другое.

Ну и все же хочется понять. Как такое вообще может быть? Ведь если оно типовое и так у всех - то почему никто не заметил? У всех остальных что в графу 5а попадает?
   RomanYS
 
74 - 28.07.21 - 09:59
(73) вроде обсуждали в семерочной ветке. Если вы выставляете УПД, то он и является документом отгрузки и в 5а ссылается сам на себя.
   Ногаминебить
 
75 - 28.07.21 - 10:04
Так мы не выставляем УПД. Просто для счета-фактуры нет никакого другого варианта формата или я не нашел как и где его выбрать. :(


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.