Вход | Регистрация
 

При программном создании документа реализации в БП, поле договор "серое"

При программном создании документа реализации в БП, поле договор "серое"
Я
   ArturDoo
 
22.04.21 - 11:21
Доброго дня. Подскажите, в чём ошибка. Создаю реализацию, заполняю Контрагента, склад, дата, договор оставил на совести бухов, а он серый) Что не так? Контрагент заполнен, договоры у него есть, даже через консоль запросов посмотрел.
   Garykom
 
1 - 22.04.21 - 11:23
ВидОперации не забыл?
   ArturDoo
 
2 - 22.04.21 - 11:24
Вид операции тоже на бухах, он запрашивается при открытии документа
   ArturDoo
 
3 - 22.04.21 - 11:29
Ещё из странного, говорит, что ему не нужна СФ
   ArturDoo
 
4 - 22.04.21 - 11:30
Вот код:
РТУ = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
        РТУ.Дата = Дата;
        РТУ.Контрагент = Контрагент;
        РТУ.Склад = Справочники.Склады.НайтиПоНаименованию ("");
        /////////////////////////////////////Заполнение ТЧ документа///////////////////////////////////

        Для Каждого Строка Из ТЗ Цикл
            ТЧ = РТУ.Товары.Добавить();
            ТЧ.Номенклатура = Строка.Номенклатура;
            ТЧ.Количество = Строка.Количество;
            ТЧ.Цена = Строка.Цена;
            ТЧ.Сумма = Строка.Сумма-Строка.НДС;
            ТЧ.СуммаНДС = Строка.НДС;
        /////////////////////////////////////НДС///////////////////////////////////////////////////////    

            Для каждого ЭлементПеречисления Из Метаданные.Перечисления.СтавкиНДС.ЗначенияПеречисления Цикл
                    Если ЭлементПеречисления.Синоним = Строка.ПроцНДС Тогда
                        СсылкаНаПеречисление = Перечисления.СтавкиНДС[ЭлементПеречисления.Имя];
                       Прервать;
                    КонецЕсли; 
             КонецЦикла;
             ТЧ.СтавкаНДС = СсылкаНаПеречисление;
        ///////////////////////////////////////////////////////////////////////////////////////////////

        КонецЦикла;    
         
        РТУ.Записать();
        ТЗ.Очистить();
   RomanYS
 
5 - 22.04.21 - 11:34
(4) А где заполнение организации?
   ArturDoo
 
6 - 22.04.21 - 11:47
(5) Тоже заметил, сейчас протестирую
   ArturDoo
 
7 - 22.04.21 - 12:01
Да, это была организация. Всем спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.