Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при сборке мобильного приложения

Ошибка при сборке мобильного приложения
Я
   Alres
 
20.04.21 - 16:08
Пытаюсь собрать приложение, получаю

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/4.10.1/userguide/gradle_daemon.html.

FAILURE: Build failed with an exception.

* What went wrong:
Unable to get mutable Windows environment variable map

Параметры такие:
[info] Android ARM 64 (Gradle)
[info] Дата и время начала сборки: 20.04.2021 16:01:35
[info] Файловый вариант ИБ       : Нет
[info] Версия ОС                 : Windows x86-64, Microsoft Windows 7 version 6.1 Service Pack 1 (Build 7601)
[info] Оперативная память        : 122 879
[info] Версия 1С:Предприятия     : 8.3.15.1830 Windows x86-64
[info] Версия сборщика           : 2.0.10.77
[info] Версия мобильной платформы: 8.3.16.142
[info] Тип сборки                : app
[info] Графическая информация    :
[info] Аудиоинформация           :
[info] Путь к Android SDK        : C:\Mobile\SDK
[info] Android API Level         : 30
[info] Путь к Java               : C:\Program Files\Java\jdk-16
[info] Версия Java               : java version "16" 2021-03-16
[info] Архитектура Java          : 64
[info] Рабочий каталог (и кеш)   : C:\Mobile\TEMP

Подскажите коллеги где искать решение проблемы
   Kongo2019
 
1 - 20.04.21 - 16:12
(0) Попробуй собирать не на системном диске. То бишь не диске С.
   Alres
 
2 - 20.04.21 - 16:14
(1) только рабочий каталог нужно на другой диск перенести или SDK тоже?
   Garykom
 
3 - 20.04.21 - 16:21
(0) JDK слишком новый поставил или несколько и с JAVA_HOME трабла
   Necessitudo
 
4 - 20.04.21 - 17:28
Собирать уж надо-то на 8 джаве.
   Garykom
 
5 - 20.04.21 - 17:30
(4) Технически собирать надо на той что Android SDK требует
   Garykom
 
6 - 20.04.21 - 17:34
Прикольно Chrome OS дополнила большую тройку ОС (win, linm mac) до 4-ки
Судя по System requirements для https://developer.android.com/studio
   SilentMan
 
7 - 20.04.21 - 18:33
(0) Сборщик надо бы обновить .. сильно
Java - не выше 11, лучше на 8
   Alres
 
8 - 21.04.21 - 09:19
(3) (4) (7) Поставил JDK 8
В JAVA_HOME был прописан путь к Liberica JDK (видимо на сервер когда-то ставили EDT) - поправил.

И взлетело.
Всем огромное спасибо!
   mikecool
 
9 - 21.04.21 - 09:48
на новых жавах вроде с 17 моб платформы

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.