Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как в обработке удалить данные тех. поддержки?

Как в обработке удалить данные тех. поддержки?
Я
   ded20ded
 
16.04.21 - 21:22
&НаСервере
Процедура ВыполнитьНажатиеНаСервере()
    Попытка
        Для Каждого Элемент Из ДанныеАвторизации Цикл
            Сообщить(Элемент.Ключ + ":  " + Элемент.Значение);
            Если Элемент.Ключ = "Логин" Тогда
                Реквизит1 = Элемент.Значение;
            ИначеЕсли Элемент.Ключ = "Пароль" Тогда
                Реквизит2 = Элемент.Значение;            
            КонецЕсли;
            
        КонецЦикла;
    Исключение
        Сообщить("Нет данных регистрации ИТС.");
        ОбщегоНазначения.ЗаписатьДанныеВБезопасноеХранилище(ИнтернетПоддержкаПользователей.ИдентификаторПодсистемы(),"Логин","***********");
        ОбщегоНазначения.ЗаписатьДанныеВБезопасноеХранилище(ИнтернетПоддержкаПользователей.ИдентификаторПодсистемы(),"Пароль","**********");
    КонецПопытки
    
КонецПроцедуры
   ded20ded
 
1 - 16.04.21 - 21:24
возращает логин и пароль который в базе, пропала кнопка ОТКЛЮЧИТЬ Интернет поддержку - выдаешь ошибку, в базе сохранен не верный пароль - хочу заменить на новый, но как сохранить.
Помогите
   ded20ded
 
2 - 16.04.21 - 21:29
   ded20ded
 
3 - 16.04.21 - 21:35
&НаСервере
Процедура ВыполнитьНажатиеНаСервере()
ДанныеАвторизации = ИнтернетПоддержкаПользователей.ДанныеАутентификацииПользователяИнтернетПоддержки();
    Попытка
        Для Каждого Элемент Из ДанныеАвторизации Цикл
            Сообщить(Элемент.Ключ + ":  " + Элемент.Значение);
            Если Элемент.Ключ = "Логин" Тогда
                Реквизит1 = Элемент.Значение;
            ИначеЕсли Элемент.Ключ = "Пароль" Тогда
                Реквизит2 = Элемент.Значение;            
            КонецЕсли;
            
        КонецЦикла;
    Исключение
        Сообщить("Нет данных регистрации ИТС.");
        ОбщегоНазначения.ЗаписатьДанныеВБезопасноеХранилище(ИнтернетПоддержкаПользователей.ИдентификаторПодсистемы(),"Логин","***********");
        ОбщегоНазначения.ЗаписатьДанныеВБезопасноеХранилище(ИнтернетПоддержкаПользователей.ИдентификаторПодсистемы(),"Пароль","**********");
    КонецПопытки
    
КонецПроцедуры
   ded20ded
 
4 - 16.04.21 - 21:36
как правильно записать
   Гений 1С
 
5 - 16.04.21 - 22:17
ни фига не понял
   ded20ded
 
6 - 16.04.21 - 22:42
обработка выводит логин и пароль на ИТС техподдержку, в базе нет кнопки - отключить тех. поддержку, из-за этого нет способа сменить логин и пароль.
   Winnie Buh
 
7 - 17.04.21 - 12:36
это в какой конфе нет кнопки Оключить в интернет-поддержке?

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.