Вход | Регистрация
 

Хм. А в запрос всегда можно было передать массив массива массива?..

↓ [Волшебник, 15.04.21 - 10:21]
Хм. А в запрос всегда можно было передать массив массива массива?..
Я
   Галахад
 
15.04.21 - 10:20
Не знал, что так работает:

Процедура ТестМассиваВЗапросе()
    
    Запрос = Новый Запрос;
    
    Запрос.Текст =
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |    БанковскиеСчета.Ссылка КАК Ссылка
    |ИЗ
    |    Справочник.БанковскиеСчета КАК БанковскиеСчета";
    МассивТоваров = Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Ссылка");
    
    Для Сч = 1 По 1000 Цикл
        МассивТоваров = ДобавитьВМассив(МассивТоваров);
    КонецЦикла;
    
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Массив", МассивТоваров);
    
    Запрос.Текст =
    "ВЫБРАТЬ
    |    БанковскиеСчета.Ссылка КАК Ссылка
    |ИЗ
    |    Справочник.БанковскиеСчета КАК БанковскиеСчета
    |ГДЕ
    |    БанковскиеСчета.Ссылка В(&Массив)";
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        Сообщить(Выборка.Ссылка);
    КонецЦикла;                      
    
КонецПроцедуры

Функция ДобавитьВМассив(ТекМассив)
    
    Массив = Новый Массив;
    Массив.Добавить(ТекМассив);
    
    Возврат Массив;
    
КонецФункции
   Волшебник
 
1 - 15.04.21 - 10:29
Месье знает толк в извращениях!...
   1Сергей
 
2 - 15.04.21 - 11:11
Мы добавили для Вас массив в массив, чтобы вы могли работать с массивом пока работаете с массивом
   ManyakRus
 
3 - 15.04.21 - 11:24
А результат какой ? Чего добились ?
   Галахад
 
4 - 15.04.21 - 12:37
(1) Ну можно назвать и так, а можно исследование.

(3) Результат - знание, с чем может работать запрос.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.