Вход | Регистрация
 

проблема с расширением после обновления БП 3.0.91.31

проблема с расширением после обновления БП 3.0.91.31
Я
   Мисти
 
13.04.21 - 22:36
Точнее - вообще в конфигуратор не могу попасть!
После обноволения при открытии базы был вопрос, что запускается расширение и доверяю ли я ему, но "доверяю" варианта не было, а только закрыть или перезапустить.
При этом в конфигуратор вообще не могу попасть!
Это была копия с доработками и я не сделала архивчик. Так обидно! Др этого 100 раз сделала и они не пригодились.
Но для обновления чужих баз - это закон.
   Garykom
 
1 - 13.04.21 - 23:01
(0) было подобное от расширения не зависит
сбойнуло на postgresql базе делал обновление с реструктуризацией в момент делания бэкапа средствами postgres
и база все
хорошо бэкап который сделался оказался рабочим и со всеми данными
   Garykom
 
2 - 13.04.21 - 23:03
(0) короче бэкап восстанавливай
если нет и база нужна то предстоит недолгая прелюдия с установкой чистой конфы БП той же версии и долгий секс с переносом данных из таблиц sql (с файловой секса еще больше)
   Мисти
 
3 - 13.04.21 - 23:08
мне только конфигурация нужна. И база-то открывается! только опять запускает при открытии обновление, которое не может установить.
   Garykom
 
4 - 13.04.21 - 23:15
(3) кэш почисти тогда чтобы конфигуратор запустился
   zva
 
5 - 14.04.21 - 07:25
Так не сработает?
https://infostart.ru/public/426048/
   Фрэнки
 
6 - 14.04.21 - 09:15
// только опять запускает при открытии обновление, которое не может установить. //


Причем там наличие Расширение? Тебе нужно сорвать запуск стандартной процедуры обновления, а не применение расширения.
// только конфигурация нужна // 


Конфигурация чего? Расширения или типовой базы? Типовую можешь взять из полного дистриба - теперь что-то шарахнула в мозги разработчиков и полные дистрибы начали выкладывать в релизы.
Кстати, а не в этом причина? Ведь раньше они полные дистрибы не давали, а приходилось обновлениями доводить конфиг до кондициции в каких-то тесто-демо-копиях базы.
   Фрэнки
 
7 - 14.04.21 - 09:17
Ну и самое красивое, что бакап перед началом обновления херить нельзя.
А еще второе красивое - перед началом получения конфигурации надо сносить не только расширение, но и патчи
   Garykom
 
8 - 14.04.21 - 09:39
(7) >сносить не только расширение, но и патчи

а есть автоматизация п.2?
   Garykom
 
9 - 14.04.21 - 09:40
(8)+ ибо заи уже вручную
   Garykom
 
10 - 14.04.21 - 09:40
(9)+ да наверно можно самому написать... но отень
   Фрэнки
 
11 - 14.04.21 - 10:01
(10) Оно почти есть. Технически, если какой-то патч сам себя заменяет, то оно перезаписывается. Такое можно заметить, что оно вроде бы работает.
А так я открываю Администрирование-Обслуживание-Установленные патчи - все их выделяю и удаляю. Затем после обновления на типовую надо еще раз Обновление открыть и отметить загрузку патчей. Или оставить там, что патчи грузить автоматически...

Я замечал, когда внимательно смотрел на обновление, что при применении обновления патчи иногда удаляются автоматически, типа, проверка какая-то происходит. Но доверия этому механизму пока еще нет.
   Garykom
 
12 - 14.04.21 - 10:05
(11) Тьфу я в конфигураторе их оптом удалить не смог, в режиме предприятия получается можно выделить и разом удалить

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.