Вход | Регистрация
 

Как выполняются обе процедуры?

↓ [Волшебник, 11.04.21 - 09:40]
Как выполняются обе процедуры?
Я
   nikitas2020
 
10.04.21 - 21:22
Какие различия в работе обеих процедур имеются? Какие данные будут выведены в окно сообщений?

Процедура Задание8()
    
    перем Значение1, Значение2;
    
    Значение1 = 1;
    Значение2 = 2;
    
    Сообщить("Значение1 - "+Значение1);
    Изменить(Значение1);
    Сообщить("Значение1 - "+Значение1);
    
    Сообщить("Значение2 - "+Значение2);
    Изменить2(Значение2);
    Сообщить("Значение2 - "+Значение2);
    
КонецПроцедуры


Процедура Изменить(ВхПеременная)

    ВхПеременная = ВхПеременная+10;
    Сообщить("Переданная переменная изменена, новое значение - "+ВхПеременная);

КонецПроцедуры

Процедура Изменить2(знач ВхПеременная)

    ВхПеременная = ВхПеременная+10;
    Сообщить("Переданная переменная изменена, новое значение - "+ВхПеременная);

КонецПроцедуры
   acht
 
1 - 10.04.21 - 21:32
Я вот чой-то не понял, кто кого экзаменует. Да еще с таким апломбом.
   acht
 
2 - 10.04.21 - 21:36
Обе процедуры выполняются в порядке, определенным программистом. Различия в них отображают замысел автора. В окно сообщения будут выведены результирущие данные.

Совсем обленилось школиё.
   PR
 
3 - 10.04.21 - 23:03
(0) Сколько платишь?
   nicxxx
 
4 - 10.04.21 - 23:27
Ни тебе "здравствуйте", ни "пожалуйста". Ну и народ пошел.
   alexxx961503
 
5 - 11.04.21 - 00:34
(0)тут все написано https://its.1c.ru/db/metod8dev/content/2606/hdoc
   Chameleon1980
 
6 - 11.04.21 - 05:53
Кандидат кому-то
   Chameleon1980
 
7 - 11.04.21 - 08:40
(4) чел оббесилен. Челу даже сил не хватает на ввод и проверку
Кода.
   TormozIT
 
8 - 11.04.21 - 12:06
Процедура Задание8() - в следующий раз лучше маскируй тестовое задание для приема на работу под личное исследование, ну и женское ник и формы глаголов помогут =)
   Михаил Козлов
 
9 - 11.04.21 - 13:06
(0) Обратите внимание на слово "знач" в процедуре Изменить2.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки — вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.