Вход | Регистрация
 

А где в БП3,0 включить что ИП является работодателем, а то УСН на стр.взносы неправильно..

А где в БП3,0 включить что ИП является работодателем, а то УСН на стр.взносы неправильно..
Я
   Джордж1
 
09.04.21 - 14:38
А где в БП3,0 включить что ИП является работодателем, а то УСН на страховые взносы неправильно уменьшаются
   Фрэнки
 
1 - 09.04.21 - 14:50
скорей всего, что просто не включены понижающие тарифы в настройках страховых взносов.

попробуй с этого начать https://its.1c.ru/db/answers1c/content/1101/hdoc
   Джордж1
 
2 - 09.04.21 - 14:56
(1)Это не то. Я ЗП считаю в отдельной программе.
А взносы ручками заношу документом Записи книги доходов и расходов.

Так вот программа считает что УСН можно уменьшить на 100%, при этом уменьшает налог только на ОПС и ОМС - т.к. считает что уплачиваться могут только фиксированные взносы ИП
   Фрэнки
 
3 - 09.04.21 - 15:04
(2) Ну так это документ Отражение зарплаты в бухгалтерском учете.
Там что? Если суммы по колонкам в таб части показаны и они неправильные, то сама БП их исправлять не будет, а только проводки и движения создаст из них.
   Джордж1
 
4 - 09.04.21 - 15:08
(3)Да мне не надо ничего отражать в бухучете.

Документ Запись книги доходов и расходов - туда можно внести все что нужно и Книга... все корректно отражает. А вот расчет УСН считает что ИП не работодатель. Там конечно можно и ручками налог посчитать - всего 2 цифры. Но интересно где же они эту настройку скрыли
   Джордж1
 
5 - 09.04.21 - 15:29
Раньше была галочка - Используется труд наемных работников. Ее убрали.
Вроде как статус работодателя должен определятся по заполненному номеру ФСС, однако не работает

Сдается мне или сотрудника принять или какое начисление по зарплате провести. Глупость конечно такой подход в последних БП
   RomanYS
 
6 - 09.04.21 - 15:39
Функция ИПИспользуетТрудНаемныхРаботников(Организация, ПроверятьФункциональность = Истина) Экспорт

    УстановитьПривилегированныйРежим(Истина);
    
    Если ПроверятьФункциональность Тогда
        Если НЕ ПолучитьФункциональнуюОпцию("ВедетсяУчетЗарплатыКадров") Тогда
            Возврат Ложь;
        КонецЕсли;
    КонецЕсли;
    
    Если ТипЗнч(Организация) = Тип("СправочникСсылка.Организации")
        И НЕ ОбщегоНазначенияБПВызовСервераПовтИсп.ЭтоЮрЛицо(Организация) Тогда
        ОрганизацияСсылка = Организация;
    ИначеЕсли  ТипЗнч(Организация) = Тип("СправочникОбъект.Организации")
        И Организация.ЮридическоеФизическоеЛицо = Перечисления.ЮридическоеФизическоеЛицо.ФизическоеЛицо Тогда
        ОрганизацияСсылка = Организация.Ссылка;
    Иначе
        Возврат Ложь;
    КонецЕсли;
    
    Если НЕ ЗначениеЗаполнено(ОрганизацияСсылка) Тогда
        Возврат Ложь;
    КонецЕсли;
        
    // Дальнейшая проверка только для индивидуального предпринимателя

    
    // при наличии регистрации в ФСС можно судить о наличии работников

    
    РегистрационныйНомерФСС = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ОрганизацияСсылка, "РегистрационныйНомерФСС");
    Если ЗначениеЗаполнено(РегистрационныйНомерФСС) Тогда
        Возврат Истина;
    КонецЕсли;

    // не заполняли реквизиты, а сотрудников ввели

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ГоловнаяОрганизация", ОрганизацияСсылка);
    Запрос.Текст = 
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |    Сотрудники.Ссылка КАК Ссылка
    |ИЗ
    |    Справочник.Сотрудники КАК Сотрудники
    |ГДЕ
    |    Сотрудники.ГоловнаяОрганизация = &ГоловнаяОрганизация";
    
    Возврат НЕ Запрос.Выполнить().Пустой();
    
КонецФункции
   Джордж1
 
7 - 09.04.21 - 15:43
(6)Это в каком модуле функция?

И в 8-ке нельзя выполнить глобальный поиск?
   RomanYS
 
8 - 09.04.21 - 15:49
(7)
1. УчетЗарплаты
2. Можно: Правка-...
   Джордж1
 
9 - 09.04.21 - 15:52
(8)2. Это поиск в модулях не ищет - только в дереве конфигурации

У меня базовая конфигурация
   МимохожийОднако
 
10 - 09.04.21 - 16:22
Вноси бухгалтерской справкой, если не хочешь\не умеешь использовать типовые настройки
   Джордж1
 
11 - 09.04.21 - 16:24
(10)Да я уже все настройки перебрал.

И при чем тут бухсправка - если взносы видятся, программа не понимает что ИП работодатель и их надо 50% ограничивать
   МимохожийОднако
 
12 - 09.04.21 - 16:26
Какие документом вносишь взносы?
   Джордж1
 
13 - 09.04.21 - 16:29
Я же написал Запись книги доходов и расходов
   RoRu
 
14 - 09.04.21 - 16:30
(11) рег номер фсс внёс ?
попробуй прими сотра и уволь
   Джордж1
 
15 - 09.04.21 - 16:35
Номер фсс внес
   МимохожийОднако
 
16 - 09.04.21 - 16:54
Включи раздел Зарплата и кадры https://its.1c.ru/db/answers1c/content/911/hdoc
   Фрэнки
 
17 - 09.04.21 - 17:01
(15) посмотрел по коду - самое простое будет включить Константы.УчетЗарплатыИКадровСредствамиБухгалтерии
т.е. ответ выше в самый раз.
Это с учетом того, что конфига Базовая.

з.ы. Надо вопросы по Базовой сразу в тексте топика указывать
   Джордж1
 
18 - 09.04.21 - 17:11
(17)эта константа и так включена

А что не базовой разве что-то по другому может работать
   Фрэнки
 
19 - 09.04.21 - 17:39
(18) ты будешь ломать базовую? ставить на нее расширения какие-то и т.д. Ковырять код? Пользоваться отладчиком?
   Джордж1
 
20 - 09.04.21 - 17:42
(19)Отладчик там и так работает. код ковырять тоже можно

Ломать, ставить расширения - нахрена?
   Джордж1
 
21 - 09.04.21 - 17:43
Внешние обработки тоже пишу
   Фрэнки
 
22 - 09.04.21 - 17:43
(20) т.е. у тебя взломанная. На кой тогда пишешь, что она Базовая?
   Джордж1
 
23 - 09.04.21 - 17:44
(22)Обижаешь, лицензия.

И 1С и Windows и Office - все лицензия
   Джордж1
 
24 - 09.04.21 - 17:47
Так вы в упор не хотите видеть что я пишу.

У меня Лицензия Базовая!!!
   Фрэнки
 
25 - 09.04.21 - 17:49
короче говоря, по коду все должно работать, если тебя интересует ответ на вопрос "как указать что у ИП есть работники"
Почему при этом нет верного расчета суммы взносов - хз

зы. На базовой лицензии лазить в конфигураторе по коду нельзя. Как минимум, на том компе где ты сейчас пытаешься работать с базой. И если затем база будет переставлена на комп с базовой, то есть риск, что она там не запустится под базовой лицензией.
   Джордж1
 
26 - 09.04.21 - 17:51
(25)Ерунду пишите. Вам скрин что ли сделать?

Без проблем лазаю по коду, пишу обработки и отлаживаю их
   Фрэнки
 
27 - 09.04.21 - 18:11
Давно под руками базовой не было.
Почему-то в памяти засело, что отладчиком на базовой пользоваться не получается.
Приходилось на отдельном компе с проф лицензией выполнять какие-то доработки и ставить их в базовую внешними
   Джордж1
 
28 - 09.04.21 - 18:13
(27)Можно


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.