Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

QR Code И Word

QR Code И Word
Я
   FreeWay
 
07.04.21 - 14:49
Стоит задача:
Прочитать Qr коды из Word и распознать их.
У кого какие соображения?
   Irbis
 
1 - 07.04.21 - 14:50
Что читаем изображение или текст двумерного штрих кода?
   Garykom
 
2 - 07.04.21 - 14:51
Соображение что вам понадобится программист
   FreeWay
 
3 - 07.04.21 - 14:55
(1) нужно прочитать картинку в документе и распознать изображение
   FreeWay
 
4 - 07.04.21 - 14:55
(2) сарказм ))
   Griffin
 
5 - 07.04.21 - 14:58
В БП есть блок для счетов на оплату. Оттуда недавно выдрал кусок для своей нетленки, теперь клиенты по мобильнику счета оплачивают.
   FreeWay
 
6 - 07.04.21 - 15:00
(5) камеру не используем, только содержимое Word
   NorthWind
 
7 - 07.04.21 - 15:00
ну наверно сначала нужно дернуть из ворда изображения, потом попытаться натравить на них какую-нибудь библиотеку, которая умеет распознавать QR из картинок.
   Irbis
 
8 - 07.04.21 - 15:01
(6) Извращенцы. Придётся вам самим разбирать двоичку от картинки в ворде
   Griffin
 
9 - 07.04.21 - 15:02
(6) Ну для распознавания картинок надо нейронку разворачивать и обучать. В Python есть библиотеки. Вот такие мысли.. :)
   NorthWind
 
10 - 07.04.21 - 15:03
(9) либы уже есть готовые для распознания QR-кодов из изображений
   NorthWind
 
11 - 07.04.21 - 15:03
ZXing, например, упоминают в инете. Сам не пользовался
   Irbis
 
12 - 07.04.21 - 15:05
Интересно в каком процессе такое понадобилось. Чтобы читать картинку, которая предназначена для чтения сканером, читать непосредственно из файла, да ещё из Ворда
   NorthWind
 
13 - 07.04.21 - 15:06
скорее всего какая-то документация с qr'ами внутри. Были же извращенцы, которые даже "Евгения Онегина" qr'ами напечатали в книжку.
   Garykom
 
14 - 07.04.21 - 15:07
Предлагаю взять сканер ШК, который умеет читать с экрана (оптика не лазер) и в автоматическом режиме и закрепить его напротив монитора
Затем скриптом(ами) открыть файл word и прокручивать документ
   Garykom
 
15 - 07.04.21 - 15:07
(14) к (4)
   Garykom
 
16 - 07.04.21 - 15:09
(14) прокручивать посылкой кодов кнопки "стрелка вниз" через 
ОбъектShell = Новый COMОбъект("Wscript.Shell");
ОбъектShell.SendKeys("{DOWN}"); 

http://1clenta.ru/pattern/49
   FreeWay
 
17 - 07.04.21 - 15:11
(12) Ссылки на авторизацию в виде инструкции в Word файле (картинки QR кода). Разработчики любыми путями отписываются, не желают дать в текстовом формате. Руководство наседает и требует выдать результат для внесения данных в свою базу.
   NorthWind
 
18 - 07.04.21 - 15:17
(17) количество кодов-то хоть какими количествами исчисляется? Если меньше нескольких сотен, то я бы это все руками предпочел сделать
   FreeWay
 
19 - 07.04.21 - 15:17
походу придётся работать с word как с zip архивом. использовать document.xml и содержимое папки media
   FreeWay
 
20 - 07.04.21 - 15:18
(18) в пределах 2700 шт
   NorthWind
 
21 - 07.04.21 - 15:19
(19) если файл docx, то, конечно, так будет проще всего
   NorthWind
 
22 - 07.04.21 - 15:21
и если задачка разовая, то вариант (16) вполне имеет право на существование, кстати. Подумайте.
   FreeWay
 
23 - 07.04.21 - 15:22
(22) разовая, но труда уйдет куча. проще код нарисовать
   Garykom
 
24 - 07.04.21 - 15:24
(23) С подобными вопросами вам проще взять сканер со скотчем и палками
   arsik
 
25 - 07.04.21 - 15:25
Готового дочерта. 1я в выдаче гугла http://catalog.audit-balans.ru/public/157814/
Только там с камеры забирается картинка, вам же эту часть пропустить и использовать часть распознавания.
   FreeWay
 
26 - 07.04.21 - 15:29
(25) с камерой не работаем
   arsik
 
27 - 07.04.21 - 15:41
(26) А при чем там камера. Из описания понятно, что есть 2 части обработки. 1я снимает фото с камеры, 2я распознает уже картинку. Тебе для себя нужно 2ю часть скопипастить.
   mdao
 
28 - 07.04.21 - 16:03
(0) конвертить doc в jpg, далее jpg в txt программой Zbar
   Garykom
 
29 - 07.04.21 - 16:05
(28) >конвертить doc в jpg
предлагаю через распечатку и сканирование

ЗЫ но можно просто на выходе принтера сканер ШК прилепить ))
   DGorgoN
 
30 - 07.04.21 - 16:15
2700 шк за пару часов распознать с помощью тсд можно ну или за день с помощью сотового. Вам точно что то пару дней тратить нужно на разработку и отладку обработки?
 
 
   arsik
 
31 - 07.04.21 - 16:17
(30) Лучше полдня потерять, потом за 5 минут долететь.
   FreeWay
 
32 - 08.04.21 - 02:25
ИмяФайлаРаспознования=ПолучитьИмяВременногоФайла("txt");
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл(ПутьКФайлуDocuments);  //Открываем файл

    Пока ЧтениеXML.Прочитать() Цикл  //Цикл по структуре

        Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда  //Определяем начало элемента

            Пока ЧтениеXML.ПрочитатьАтрибут() Цикл
                Если ЧтениеXML.Имя="Target" и Лев(ЧтениеXML.Значение,6)="media/" Тогда
                    Если НЕ (Найти(ЧтениеXML.Значение,"_app_ios") или Найти(ЧтениеXML.Значение,"_app_android_")) Тогда
                        ИмяФайлаИзображения=ПутьККаталогу+СтрЗаменить(ЧтениеXML.Значение,"/","\");
                        ПутьКПрограммеРаспознованияШтрихкода="C:\Program Files (x86)\ZBar\bin"; 
                        СтрокаЗапуска="cmd /c zbarimg.exe --raw   """+ИмяФайлаИзображения+""" >> """+ИмяФайлаРаспознования+"""";
                        КодВозврата=0;                   
                        ЗапуститьПриложение(СтрокаЗапуска,ПутьКПрограммеРаспознованияШтрихкода,Истина,КодВозврата);
                                КонецЕсли;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли ;
    КонецЦикла;
   FreeWay
 
33 - 08.04.21 - 02:29
Профит ))


Список тем форума
 
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.