Вход | Регистрация
 

Пропало форматирование табличной части

Пропало форматирование табличной части
Я
   NIGHTHUNTER
 
06.04.21 - 10:15
Вывожу запрос с выборкой контрагентов и их контактной информации.
Провозившись несколько дней вижу требуемый результат.
Не буду вдаваться в подробности процесса, и мыслей меня преследующих.
Но вот прокрутив ползунок вниз, увидел что, после 142 строки, пропало форматирование. Линии, выравнивание, что было до.
Из за чего это может произойти??? Так как все моменты выводимые уже выведены, и ничего не слетало, а после 142 строки, вдруг слетело (((
   NIGHTHUNTER
 
1 - 06.04.21 - 10:15
   NIGHTHUNTER
 
2 - 06.04.21 - 10:16
(0+)

        # Область ВыводСтрок

        ТДВыводПечатиУТ.НачатьАвтогруппировкуСтрок();
        Для Каждого СтрТзКИУТ Из ТзКИУТ Цикл
            // 1. ВЫВОД КОНТРАГЕНТА НЕ ИМЕЮЩЕГО ВООБЩЕ КОНТАКТНОЙ ИНФОРМАЦИИ

            # Область КонтрагентБезКИ

            Если Не ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) Тогда
                ИндексШапкиТаблицы = 1;
                Для Каждого КолонкаТз Из ТзКИУТ.Колонки Цикл                
                    Если ИндексШапкиТаблицы = 1 Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = Ном;
                        ТДВыводПечатиУТ.Вывести(ОбластьСтроки, 1, "ГруппаКонтрагент", Ложь);
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки           = 5;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ВертикальноеПоложение   = ВертикальноеПоложение.Центр;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху           = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева            = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу            = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа           = Линия;
                        ИндексШапкиТаблицы                                                                                    = ИндексШапкиТаблицы + 1;
                        //

                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 3  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 4  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 5  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 6  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 7  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 8  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 9  Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 10 Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 11 Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 12 Тогда    
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    КонецЕсли;
                    ИндексШапкиТаблицы = ИндексШапкиТаблицы + 1;
                КонецЦикла;
                Ном = Ном + 1;
            # КонецОбласти

            // 2. ВЫВОД КОНТРАГНЕТА СО ЗНАЧЕНИЕМ КОНТАКТНОЙ ИНФОРМАЦИИ

            # Область КонтрагентСКИ

        ИначеЕсли ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) и НаименованиеКонтрагента <> СтрТзКИУТ["Наименование"] Тогда
            ИндексШапкиТаблицы = 1;
            Для Каждого КолонкаТз Из ТзКИУТ.Колонки Цикл                
                // *** Вывод Контрагента

                Если ИндексШапкиТаблицы = 1 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = Ном;
                    ТДВыводПечатиУТ.Вывести(ОбластьСтроки, 1, "ГруппаКонтрагент", Ложь);
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки           = 5;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ВертикальноеПоложение   = ВертикальноеПоложение.Центр;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху           = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева            = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу            = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа           = Линия;
                    ИндексШапкиТаблицы                                                                                    = ИндексШапкиТаблицы + 1;
                    //

                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 3 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 4 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 5 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 6 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 7 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 8 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 9 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 10 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 11 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 12 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                КонецЕсли;
                ИндексШапкиТаблицы = ИндексШапкиТаблицы + 1;
            КонецЦикла;
            Ном = Ном + 1;
            //

            ИндексШапкиТаблицы = 1;
            Для Каждого КолонкаТз Из ТзКИУТ.Колонки Цикл                
                // *** Вывод КИ

                Если ИндексШапкиТаблицы = 1 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Вывести(ОбластьСтроки, 2, "ГруппаКонтактнаяИнформация", Ложь);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки           = 5;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ВертикальноеПоложение   = ВертикальноеПоложение.Центр;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху           = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева            = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу            = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа           = Линия;
                    ИндексШапкиТаблицы                                                                                    = ИндексШапкиТаблицы + 1;
                    //

                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 3 Тогда                
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 4 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = "";
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 5 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 6 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 7 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 8 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 9 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 10 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 11 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                ИначеЕсли ИндексШапкиТаблицы = 12 Тогда
                    ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                    ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                    //

                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                    ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                КонецЕсли;
                ИндексШапкиТаблицы = ИндексШапкиТаблицы + 1;
            КонецЦикла;
            # КонецОбласти

            // 3. ВЫВОД КОНТРАГНЕТА С НЕСКОЛЬКИМИ ЗНАЧЕНИЯМИ КОНТАКТНОЙ ИНФОРМАЦИИ

            # Область КонтрагентСНесколькимиКИ

            ИначеЕсли  ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) и НаименованиеКонтрагента = СтрТзКИУТ["Наименование"] Тогда
                ИндексШапкиТаблицы = 1;
                Для Каждого КолонкаТз Из ТзКИУТ.Колонки Цикл                
                    Если ИндексШапкиТаблицы = 1  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Вывести(ОбластьСтроки, 2, "ГруппаКонтактнаяИнформация", Ложь);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки           = 5;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ВертикальноеПоложение   = ВертикальноеПоложение.Центр;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху           = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева            = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу            = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа           = Линия;
                        ИндексШапкиТаблицы                                                                                    = ИндексШапкиТаблицы + 1;
                        //

                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 3  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПе
   mikecool
 
3 - 06.04.21 - 10:17
проверяй выводимые области
   Bigbro
 
4 - 06.04.21 - 10:18
у тебя в 141 уже группировка, но видимо из одной строки
а в 142 - много строк попало, ищи откуда группировки эти.
   NIGHTHUNTER
 
5 - 06.04.21 - 10:18
(3) уже все выведено, то есть отработали все возможные варианты кода, как проверять?
   NIGHTHUNTER
 
6 - 06.04.21 - 10:20
(4) выводилось и по три строки в группировке, и по одной

http://joxi.ru/Dr8zonjCMqxGp2
   NIGHTHUNTER
 
7 - 06.04.21 - 10:20
   Bigbro
 
8 - 06.04.21 - 10:21
ну я тебе о том и говорю - ты где то с группировкой накосячил.
ее нет а ты в нее толкаешь уже другие строки.
   NIGHTHUNTER
 
9 - 06.04.21 - 10:22
Не пойму саму природу из за чего что могло отвалиться, весь вывод в условии по Если
        # Область ВыводСтрок

        ТДВыводПечатиУТ.НачатьАвтогруппировкуСтрок();
        Для Каждого СтрТзКИУТ Из ТзКИУТ Цикл
            // 1. ВЫВОД КОНТРАГЕНТА НЕ ИМЕЮЩЕГО ВООБЩЕ КОНТАКТНОЙ ИНФОРМАЦИИ

            # Область КонтрагентБезКИ

            Если Не ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) Тогда
            # КонецОбласти

            // 2. ВЫВОД КОНТРАГНЕТА СО ЗНАЧЕНИЕМ КОНТАКТНОЙ ИНФОРМАЦИИ

            # Область КонтрагентСКИ

        ИначеЕсли ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) и НаименованиеКонтрагента <> СтрТзКИУТ["Наименование"] Тогда
            # КонецОбласти

            // 3. ВЫВОД КОНТРАГНЕТА С НЕСКОЛЬКИМИ ЗНАЧЕНИЯМИ КОНТАКТНОЙ ИНФОРМАЦИИ

            # Область КонтрагентСНесколькимиКИ

            ИначеЕсли  ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) и НаименованиеКонтрагента = СтрТзКИУТ["Наименование"] Тогда
                ИндексШапкиТаблицы = 1;
                Для Каждого КолонкаТз Из ТзКИУТ.Колонки Цикл                
                    Если ИндексШапкиТаблицы = 1  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Вывести(ОбластьСтроки, 2, "ГруппаКонтактнаяИнформация", Ложь);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки           = 5;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ВертикальноеПоложение   = ВертикальноеПоложение.Центр;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху           = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева            = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу            = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа           = Линия;
                        ИндексШапкиТаблицы                                                                                    = ИндексШапкиТаблицы + 1;
                        //

                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 3  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 4  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = "";
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 5  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 6  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 7  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 8  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 9  Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 10 Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 11 Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    ИначеЕсли ИндексШапкиТаблицы = 12 Тогда
                        ОбластьСтроки.Параметры.СтрокиКИ = СтрТзКИУТ[КолонкаТз.Имя];
                        ТДВыводПечатиУТ.Присоединить(ОбластьСтроки);
                        //

                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ШиринаКолонки = 17;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСверху = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСлева  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСнизу  = Линия;
                        ТДВыводПечатиУТ.Область("R" + ИндексСтрокиТаблицы + "C" + ИндексШапкиТаблицы).ГраницаСправа = Линия;
                    КонецЕсли;
                    ИндексШапкиТаблицы = ИндексШапкиТаблицы + 1;
                КонецЦикла;
            КонецЕсли;
            # КонецОбласти

            //

            НаименованиеКонтрагента = СтрТзКИУТ["Наименование"];            
            //Ном                     = Ном + 1;

            ИндексСтрокиТаблицы     = ИндексСтрокиТаблицы + 1;
        КонецЦикла;
        ТДВыводПечатиУТ.ЗакончитьАвтогруппировкуСтрок();
        # КонецОбласти

        //

    КонецЕсли;
КонецПроцедуры
   NIGHTHUNTER
 
10 - 06.04.21 - 10:24
(8) Правильно я понимаю, что я ставлю точку останова Ном = 142, и далее смотрю как идет вывод этой строки на которой нет линий и форматирования?

Дело в том что я так и делал, там все нормально идет.

То есть нужно ещё так же смотреть, но внимательнее? Чего то не увидел?
   ZDenis
 
11 - 06.04.21 - 10:25
(10) А если не выполняются эти два условия, то что?
        Если Не ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) Тогда
            

        ИначеЕсли ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) и НаименованиеКонтрагента <> СтрТзКИУТ["Наименование"] Тогда
   RomanYS
 
12 - 06.04.21 - 10:32
(2) ппц. Макеты так и не осилил.
   NIGHTHUNTER
 
13 - 06.04.21 - 10:45
(11) Выполнится тогда это???
 ИначеЕсли  ЗначениеЗаполнено(СтрТзКИУТ["Тип"]) и НаименованиеКонтрагента = СтрТзКИУТ["Наименование"] Тогда
   NIGHTHUNTER
 
14 - 06.04.21 - 10:46
(11)  Всего как я понял, нужно три условия, для вывода всех вариантов. Что и работает. Но вот после строки 142, пропали линии и выравнивание (.
   NIGHTHUNTER
 
15 - 06.04.21 - 10:59
Посмотрел вывод строки 143, но там все нормально, так же как и выведены выше множество строк, все с рамками и выравниванием.

Как определить из за чего слетели рамки?
   Ёпрст
 
16 - 06.04.21 - 11:07
(9) Феерический п..ц
Автор открой для себя существования макета + методы
ПолучитьОбласть() + Вывести() + Присоединить().
И если делаешь через ж..пу, то заместо R1C2 открой для себя в параметрах метода Области Номер начальной строки, номер начальной колонки, номер конечной строки, номер конечной колонки
   Ёпрст
 
17 - 06.04.21 - 11:08
Хотя.. мот ты с фузины пересел на 1с ? Они там любят, всё  кодом рисовать
   NIGHTHUNTER
 
18 - 06.04.21 - 11:12
(17) В коде три ветки.
Все они уже отработали, и то о чем вы пишете там все учтено. Мне нечего открывать.
Не смотря на это в 143 строке пропадает форматирование. И я не понимаю почему. Если все идет по отработанному уже предварительно коду. Но не выполняется.
   Ёпрст
 
19 - 06.04.21 - 11:22
(18) СП почитай на ночь
   ZDenis
 
20 - 06.04.21 - 11:23
(18) Посмотри на ТзКИУТ в отладчике (через вычислить) и посмотри на заполненность ее значениями. В частности на колонки "Наименование" и "Тип". Может там где то NULL. У тебя слетает ИндексСтрокиТаблицы после 142 строки и расскраска не происходит
   RomanYS
 
21 - 06.04.21 - 11:25
(16) +100500
(19) Уже не поможет. Сначала отформатировать носитель нужно.
   NIGHTHUNTER
 
22 - 06.04.21 - 11:27
   Ёпрст
 
23 - 06.04.21 - 11:28
На вот, дарю..

Процедура ПечатьТаблицыЗначений(Объект,ТабДок)
    ПострПечать = Новый ПостроительОтчета;
    ПострПечать.ИсточникДанных = Новый ОписаниеИсточникаДанных(Объект);
    ПострПечать.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Интерфейс);
    ПострПечать.Выполнить();
    Для каждого Колонка Из ПострПечать.ВыбранныеПоля Цикл
    Колонка.Представление = Объект.Колонки[Колонка.Имя].Заголовок;
    КонецЦикла; 
    ПострПечать.Вывести(ТабДок); 
КонецПроцедуры

......
ТабДок = Новый ТабличныйДокумент;
ПечатьТаблицыЗначений(ТДВыводПечатиУТ,ТабДок );
ТабДок.Показать();


Занимайся
   ZDenis
 
24 - 06.04.21 - 11:29
(22) И кстати, ИндексСтрокиТаблицы у тебя меняется только в конце цикла, а внутри ты по несколько строк выводишь
   NIGHTHUNTER
 
25 - 06.04.21 - 11:30
Все я разрешил.

http://joxi.ru/n2YpYzvCeWMWWm
   NIGHTHUNTER
 
26 - 06.04.21 - 11:31
(24) Да в этом было дело. В (25) поправил, его там нужно чаще наращивать, поправил.
   NIGHTHUNTER
 
27 - 06.04.21 - 11:32
(23) Интересный ваш пример. Я с построителем вообще не работал. Не знаю его преимущества, особенности. Что как.
   Kassern
 
28 - 06.04.21 - 11:34
я прост одного не пойму, зачем эти портянки с километровым кодом, ковырянием с макете и т.д. когда есть просто СКД, результат которого можно сохранить и отправить без проблем. Завтра у вас попросят поменять структуру выводимых данных и вы опять уйдете в "астрал" на неделю клепая новые ветки на мисте, хотя можно было тупо в настройках отчета поменять структуру...
   MouHacTaBHuk
 
29 - 06.04.21 - 11:35
Мои любимые темы )
   NIGHTHUNTER
 
30 - 06.04.21 - 11:44
(28) Я делаю это для поддержки собственного развития. Придумал вот, что хочу и как вывести и делаю.
Но столкнулся с тем что это не идет. Вот я и упорно решал и устранял недочеты. Сейчас сделаю, аналог на скд, и буду дальше думать что делать.
 
 
   Kassern
 
31 - 06.04.21 - 11:49
(30) для собственного развития почитайте книжку Хрусталевой по СКД
   NIGHTHUNTER
 
32 - 06.04.21 - 11:52
(31) Прям реально? Электронный вариант да? В планшет. На диван и читать ежедневно. Пусть в любом качестве, главное получить информацию.
Или же вы все же рекомендуете бумажный вариант? Я не знаю что у меня за проблемы, но как то я не читаю книги (((. Интернет все.
   hhhh
 
33 - 06.04.21 - 12:00
(32) вы хотите сделаться инвалидом? Остаться без глаз с этим интернетом? Если книга большая, а не 2 странички, то только бумажный вариант.
   Kassern
 
34 - 06.04.21 - 12:08
(32) в бумажных книжках есть своя прелесть, запах бумаги, вкладочки в интересных страницах, подпорка под монитор на худой конец))
   Dzenn
 
35 - 06.04.21 - 12:38
(2) какой ужасный код (
   Kassern
 
36 - 06.04.21 - 12:45
(35) код из серии ctrl+C ctrl+V с подменой пары строчек и превращением в гигантскую портянку.
   NIGHTHUNTER
 
37 - 06.04.21 - 13:26
(34) Ну так само собой, что бумажные книги это очень хорошо. Где их только взять. Точнее денег на них.
   NIGHTHUNTER
 
38 - 06.04.21 - 13:27
(35) А как нужно прекрасно ?
   hhhh
 
39 - 06.04.21 - 13:29
(38) БСП откройте, посмотрите там код.
   Kassern
 
40 - 06.04.21 - 13:35
(37) https://rarus.ru/books/1c-prakticheskoe-posobie-razrabotchika-primery-i-tipovye-priemy/
цена вопроса 250р, пару раз шаурму не покушаете и будет вам книжка.
   Kassern
 
41 - 06.04.21 - 13:36
   NIGHTHUNTER
 
42 - 06.04.21 - 13:36
(39) Предлагаете открыть конфигурацию "Библиотека стандартных подсистем" и посмотреть в ней код?
Какой код? И с какой целью? Я знаю что эта конфигурация с избыточным кодом, в котором не разобраться.
Что бы что то делать нужно иметь цель.
Я когда делал вот эту наработку, я видел цель и делал.
Я не профессионал. Так копаюсь.
   NIGHTHUNTER
 
43 - 06.04.21 - 13:38
(41) как это купить? Никогда не покупал. Думаю и не буду. Я не читаю книги.
   Kassern
 
44 - 06.04.21 - 13:40
(42) (43) "Я знаю что эта конфигурация с избыточным кодом, в котором не разобраться. " ,"Я не читаю книги." дальше продолжать разговор не имеет смысла...
   NIGHTHUNTER
 
45 - 06.04.21 - 13:44
(44) Нужна цель. Да смысла нет никакого вообще ничего продолжать. И жить тоже.

Аналог на скд, как убрать вот эти значения? буду заниматься. И как то вроде дольше формировалось. Не знаю конечно на сколько я правильно там что сделал.

http://joxi.ru/4AkXZOaHk4N1Vr

(44) Совет ваш правильный что нужно книги читать. Только это все же рассуждения, разговоры. Я не читаю книги, я сказал честно. И не буду читать!!!! Это честно.
Хотел бы , но не знаю как это что бы было. Что бы начать. Видимо моя жизнь, кошмарная, что мне нет дела, до таких занятий как чтение книг. Или не знаю я в чем дело. Душевно больной я.
   H A D G E H O G s
 
46 - 06.04.21 - 14:24
Кто выпустил Петера?
   H A D G E H O G s
 
47 - 06.04.21 - 14:31
Я просто оставлю это здесь
https://coub.com/view/cqawg
   Mikeware
 
48 - 06.04.21 - 14:33
(33) почему "сделаться"? он "уже"...
   Kassern
 
49 - 06.04.21 - 14:42
(45) поставь себе цель писать красивый код, да вообще стараться все в жизни делать не через задницу, чтобы было приятно читать и пользоваться и не только тебе. А тут как раз и книжки понадобятся и примеры с удачными решениями и т.д.
   novichok79
 
50 - 07.04.21 - 13:45
(2) как же DRY и SOLID и все такое?


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.