Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Авто ширина колонок при выводе табличного документа в форме

Авто ширина колонок при выводе табличного документа в форме
Я
   КонецЦикла
 
06.04.21 - 01:10
Если поместить поле таб. документа на форму и выводить туда макет - все столбцы принимают ширину 9 пунктов + появляется несколько лишних строк вверху перед шапкой
8.3.9.2309, изменить не могу, хозяйство чужое
Только одну ветку нашел старую, там не решилось
   КонецЦикла
 
1 - 07.04.21 - 16:42
Никто не сталкивался?
Можно, конечно, оставить макетом без формы...
   RomanYS
 
2 - 07.04.21 - 16:51
(0) Значит до вывода там уже были строки (пустые), а в твоих строках формата строк нет, поэтому применяются ширины от имеющихся.
   RomanYS
 
3 - 07.04.21 - 16:51
(1) Разобраться откуда строки и или очищать табдок
   КонецЦикла
 
4 - 07.04.21 - 16:56
Макетом без формы вообще-то нежелательно, потребуется сохранять по кнопке в xlsx, а потом может еще что-то
Суть в том, что табличный документ помещается на форму и тот макет который выводится без формы, через Таб.Показать() в полном порядке
А если выводится на форму то его корежит
Пробовал использовать свою форму, дергал имеющуюся из другого места как копию - одинаковая фигня
При этом в конфиге есть нормально работающие формы по такому же принципу
   RomanYS
 
5 - 07.04.21 - 17:31
(4) Понятнее не стало, к (2) добавить нечего. Код покажи.
   КонецЦикла
 
6 - 07.04.21 - 17:34
(5) Погоди, щас попробую как внешнюю обработку куда-то выложить
   КонецЦикла
 
7 - 07.04.21 - 17:39
https://dropmefiles.com/sUAPn

Макет СпецификацияШтриход, там для него есть форма ФормаТабличногоДокумента
   КонецЦикла
 
8 - 07.04.21 - 17:40
*ПротоколШтрихкод, сорян
   RomanYS
 
9 - 07.04.21 - 18:01
(7) смешно. Проблема явно не в макете, а разбираться в обработке с 100500 форм и макетов вряд ли найдутся желащие
   КонецЦикла
 
10 - 07.04.21 - 18:12
(9) Кому смешно а кому и не очень
   Cthulhu
 
11 - 07.04.21 - 18:18
(10): особенн обидно, наверное, когда смешно всем кроме тебя...
   azernot
 
12 - 07.04.21 - 18:56
Если ВидПечатнойФормы = "ПротоколШтрихкод" Тогда//1c911.by

        ФормаТабличногоДокумента = ПолучитьФорму("ФормаТабличногоДокумента");
        Таб = ФормаТабличногоДокумента.ЭлементыФормы.ПолеТабличногоДокумента;

        Таб.Очистить();// <- вот это попробуй!


    Иначе
   azernot
 
13 - 07.04.21 - 19:00
И дай угадаю, ширина 9 - только у первых 5 колонок, а добавляется сверху ровно 9 строк?
   КонецЦикла
 
14 - 07.04.21 - 19:14
(12) Спс
Спасибо всем за помощь
Понимаю, что в чужих каках неохота копаться, сам плевался, там такое наворочено

Короче помогло удаление с формы ПолеТабличногоДокумента и добавление ПолеТабличногоДокумента1, соотв-но в коде исправлено 
Таб = ФормаТабличногоДокумента.ЭлементыФормы.ПолеТабличногоДокумента1;
   КонецЦикла
 
15 - 07.04.21 - 19:15
(13) У всех одинаковая ширина, по 9, сколько строк не подсчитал :)
   azernot
 
16 - 07.04.21 - 20:48
Значит ты так и не понял, в чём же дело было...
Ну, значит обречен на повторение, рано или поздно.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.