Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как добавить в СтруктуруПодчиненности документ?

Как добавить в СтруктуруПодчиненности документ?
Я
   idw
 
04.04.21 - 20:27
В УТ 11.4 БСП 3.1.3 надо добавить в структуру подчиненности документ. В критерии отбора СвязанныеДокументы добавил его.
Но меню структуры подчиненности не появилось.
Читал что в модуле менеджера надо добавить вот это:

Процедура ДобавитьКомандыОтчетов(КомандыОтчетов, Параметры) Экспорт
    
    ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуСтруктураПодчиненности(КомандыОтчетов);    
    
КонецПроцедуры

Но такой процедуры уже нет.
   Chameleon1980
 
1 - 04.04.21 - 20:37
В команду тип добавить
   idw
 
2 - 04.04.21 - 20:55
(1) в смысле в команду добавить тип?
   papagan
 
3 - 04.04.21 - 21:13
ИнтеграцияИСПереопределяемый.ДобавитьКомандуСтруктураПодчиненности(КомандыОтчетов);
   idw
 
4 - 04.04.21 - 21:37
(3) пробывал, не помогает. В типовой УТ в документе Реализации например нет вызова данной процедуры, но структура есть.
   papagan
 
5 - 04.04.21 - 22:21
проверь в  модуле формы своего документа
наличие процедур помеченных комментарием
//СтандартныеПодсистемы.ПодключаемыеКоманды


таких будет несколько

например
// СтандартныеПодсистемы.ПодключаемыеКоманды

ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
   idw
 
6 - 04.04.21 - 22:26
(5) всё есть:

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
....
// СтандартныеПодсистемы.ПодключаемыеКоманды

    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
.....
КонецПроцедуры
// СтандартныеПодсистемы.ПодключаемыеКоманды

&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат) Экспорт
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
   Вафель
 
7 - 04.04.21 - 22:54
В вариантах отчётов переопеделяемый док указан?
   idw
 
8 - 04.04.21 - 23:39
(7) в справочнике ПредопределенныеВариантыОтчетов ? Не нашел там отчета Связанные документы
   Кот16
 
9 - 05.04.21 - 06:19
Документ свой или типовой? Если в критерии отбора добавил, то смотри, подключена ли подсистема "Подключаемые команды" к этому документу.

И да, читать на ИТС инструкцию именно к этой версии БСП.
   DrZombi
 
10 - 05.04.21 - 06:22
(0) В обработку (или общую форму), еще добавь.
   DrZombi
 
11 - 05.04.21 - 06:23
(0) В общем там
1. Критерий отбора.
2. Обработка или общая форма (на форме реквизит)
3. Общая команда.
   idw
 
12 - 05.04.21 - 10:42
(9) документ типовой, доверенность.
(10) да читал я, там нифига нет по структуре подчиненности.
   ptiz
 
13 - 05.04.21 - 11:00
   idw
 
14 - 05.04.21 - 11:45
(13)
Структура подчиненности
Подсистема Структура подчиненности предоставляет отчет о взаимосвязах родительских и подчиненных документов. Например, просматривать цепочки связанных документов для заказов, договоров и т.п.

Настройка
Принять решение по поводу списка документов, справочников и планов видов характеристик (далее - документы), для которых требуется выводить отчет Связанные документы. Например, заказы, договоры и т.п.

Если в конфигурацию внедрена подсистема Подключаемые команды, то дополнительных действий не требуется: команда для открытия отчета Связанные документы автоматически размещается в подменю Отчеты.
Если в конфигурации отсутствует подсистема Подключаемые команды, то задать список типов выбранных документов в типах параметра общей команды СвязанныеДокументы.
Для настройки связи между родительскими и подчиненными документами, справочниками и ПВХ, выводимыми в отчет Связанные документы, необходимо настроить критерий отбора СвязанныеДокументы. В свойстве Тип требуется указать возможные типы родительских документов, а в свойстве Состав – реквизиты подчиненных документов, справочников и планов видов характеристик, в которых будет происходить поиск родительских документов. Например, указать, что в реквизите Договор заказа покупателя находится ссылка на родительский договор.

Настройка переопределяемых модулей
При необходимости вписать реализацию в функции переопределяемого модуля подсистемы СтруктураПодчиненностиПереопределяемый.

Настройка прав доступа пользователей
Для настройки прав доступа пользователей к данным подсистемы следует использовать следующую роль:

№    Роли и их назначение
ПросмотрСвязанныеДокументы.
Дает пользователю право на команду и общую форму СвязанныеДокументы.
Использование при разработке конфигурации
   idw
 
15 - 05.04.21 - 11:46
ни о чем в итс написано.
   Вафель
 
16 - 05.04.21 - 12:26
Подменю отчёты появляется если (7)
   idw
 
17 - 05.04.21 - 14:33
(16) Меню отчеты есть, там два отчета: Права пользователей и места использования.
   idw
 
18 - 05.04.21 - 14:35
(16) только я не понял что за варианты отчетов. Это справочник?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.