Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Атол не печатает CustomerINN(тег 1228)

Атол не печатает CustomerINN(тег 1228)
Я
   yakovlev_alex
 
02.04.21 - 15:47
Добрый день. Сталкивался ли кто либо с тем что на чеке не выходит ИНН покупателя?
Атол 25Ф. Прошивка по заверению атола должна поддерживать этот тег.

Обработка обслуживания АТОЛ: ККТ с передачей данных версия 2,80
   d4rkmesa
 
1 - 02.04.21 - 15:53
(0) Сейчас поновее есть, попробуйте тупо обновить.
   Garykom
 
2 - 02.04.21 - 15:53
(0) конфигуратор отняли?
напрямую нативно тогда юзай https://integration.atol.ru/api/?pascal#primer-ispolzovaniya
   d4rkmesa
 
3 - 02.04.21 - 15:57
(0) А, еще в самой конфигурации поищите по "CustomerINN", там должен быть код, который заполняет этот тег. Что-то вроде:

ЗаписьXML.ЗаписатьАтрибут("CustomerINN", XMLСтрока(ОбщиеПараметры.ПолучательИНН));
   yakovlev_alex
 
4 - 02.04.21 - 16:17
(1) Попробую. С 3.04 у нас даже кассовая смена не открылась.
(3) Я знаю где это, и уже добавил туда все необходимые поля. Никакого результата это не принесло, поэтому написал сюда.

(2) Не не отняли. Если вы предполагаете что у человека нет конфигуратора то зачем ему советовать работать на прямую? Сказал бы спасибо за ссылку, но ее нашел сам.
   Garykom
 
5 - 02.04.21 - 16:20
(4) там через ВК (интеграционный компонент) идет работа, в нем может не быть поддержки тега (отправляешь а результат 0)
через конфигуратор разобраться есть ли, попробовать добавить если нет то или ищем новую версию ВК или напрямую без лишней ВК
   d4rkmesa
 
6 - 02.04.21 - 16:26
(4) Версия драйвера какая стоит? Это имеет значение, грубо говоря, желательно все обновить.
   yakovlev_alex
 
7 - 02.04.21 - 16:28
(5) Не подскажете где можно раздобыть 
1) методы ВК
2) Совместимость ВК с дровами атола?

(6) Сейчас 10.4.6. Пробовал 10.8 - не взлетело, откатился назад.
   d4rkmesa
 
8 - 02.04.21 - 16:33
(7) Когда я делал подобную доработку, работало это уже на 10.5. Имеет смысл, наверное, сейчас пробовать 10.7 или 10.8 с крайней обработкой обслуживания.
   yakovlev_alex
 
9 - 02.04.21 - 16:47
(8) 10.8 при открытии списка смен выдает
```
Ошибка вызова метода <ОбъектДрайвера.ПолучитьОписание> Слишком много фактических параметров

ОбъектДрайвера.ПолучитьОписание(НаименованиеДрайвера, ОписаниеДрайвера, ТипОборудования, РевизияИнтерфейса, 
                                        ИнтеграционныйКомпонент, ОсновнойДрайверУстановлен, URLЗагрузкиДрайвера);
```

Описание получается лишь только с одним параметром
```
ОбъектДрайвера.ПолучитьОписание(НаименованиеДрайвера)
```
В описание падает XML

```
<?xml version="1.0" encoding="UTF-8"?>

<DriverDescription 
Name="АТОЛ:ККТ с передачей данных в ОФД (54-ФЗ) 10.x" 

Description="АТОЛ: Драйвер ККТ – программный компонент (драйвер), предназначенный для работы с ККТ АТОЛ." 

EquipmentType="ККТ" IntegrationComponent="true" 

MainDriverInstalled="true" DriverVersion="10.8.1.0" 

IntegrationComponentVersion="10.6.2.0" 

DownloadURL="http://files.atol.ru/temp/1C-installer/dKKT_10.ZIP"

LogIsEnabled="true" 

LogPath="%AppData%\Roaming\ATOL\drivers10\"

/>
```
   d4rkmesa
 
10 - 02.04.21 - 16:58
(9) Странно, а что за конфигурация и какой версии?
   yakovlev_alex
 
11 - 02.04.21 - 17:02
(10) УТ 10.3.3.3 много что дописываем сами
[1C]
DriverVersion="10.8.1.0"

IntegrationComponentVersion="10.6.2.0"
[1C]

Меня вот этот кусок смутил. Обработку скачал последнюю - 3.04. IntegrationComponentVersion="10.6.2.0" значит что она поддерживает дрова только 10.6.2?
   Garykom
 
12 - 02.04.21 - 17:11
(11) >значит что она поддерживает дрова только 10.6.2?

значит ВК из состава этих дров 10.6.2
можно ВК обновить как и дрова, но могут быть иные вызовы новой ВК
   d4rkmesa
 
13 - 02.04.21 - 20:09
(11) Ну, спецификация компоненты могла не измениться, но это не всегда так... Но можно попробовать в макет обработки засунуть компоненту с нового драйвера 10.8 - там обычный zip-архив с файлами (можно сохранить чтобы посмотреть что там должно быть). Еще, как вариант, могу скинуть обработку обслуживания под 10.5 драйвера, не совсем стандартную - там заменена компонента и номер версии.
   karpik666
 
14 - 02.04.21 - 21:18
(11) пора дописывать поддержку ревизии 3002 для драйверов АТОЛ, чтобы использовать актуальный функционал
   yakovlev_alex
 
15 - 05.04.21 - 08:15
(14) Говоря о ревизии вы имели ввиду вот это - https://its.1c.ru/db/metod8dev#content:5974:hdoc ?
   yakovlev_alex
 
16 - 05.04.21 - 08:17
(14) в ревизии 2.5 https://its.1c.ru/db/metod8dev#content:5965:hdoc уже есть поддержка поля CustomerINN.
   yakovlev_alex
 
17 - 05.04.21 - 13:38
(8) 10.4.6 - имеет ревизию интерфейса 2004, а следующие за ней 10.5 - уже 3000. Куда подевалась ВК с ревизией 2005 как думаете?:)
   d4rkmesa
 
18 - 05.04.21 - 14:20
(17) Внешняя обработка, которая тогда была выпущена и не работала [с изменениями 10.5] была 2.9 версии т.е. 2009.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.