Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Внешняя обработка. Вопрос клиенту из модуля обработки

Внешняя обработка. Вопрос клиенту из модуля обработки
Я
   Родом из детства
 
02.04.21 - 11:12
Салют всем, скорее всего вопрос довольно васянский и мои предположения ниже могут быть неверны - в уф я совсем новенький.
Так вот, задача в том, что по одной табличной части документа нужно заполнить вторую. При этом сохранить его на поддержке. Было решено создать внешнюю обработку.
Вид - ЗаполнениеОбъекта. Также добавил соответствующую команду(ВызовСерверногоМетода). В процедуре ВыполнитьКоманду(...) получаю мой документ и выполняю заполнение.
Добавляю обработку. В документе появляется новая кнопка, обработчиком нажатия которой является моя процедура, написанная в модуле обработки.
Нужно, чтобы после нажатия на эту кнопку, пользователю задавался вопрос с предупреждением: "предыдущие данные заполняемой тч будут очищены. Продолжить?". И, в зависимости, от ответа пользователя, будем выполнять дальнейшее заполнение, или нет. Клиент, вроде, есть только в клиентских общих модулях и на формах. Тут же модуль обработки.
Заранее спасибо за ответы. Я запутался:)
   VladZ
 
1 - 02.04.21 - 11:20
(0) Вместо ВызовСерверногоМетода вызывать клиента и там спрашивать.
   dka80
 
2 - 02.04.21 - 11:21
на клиенте выполняй ВызвовКлиентскогМетода.
Лично мое мнение, задавать такой вопрос это пережиток конфигураций на обычных формах. Там это применялось. Раз пользователь нажал - распишитесь получите. Если не понравилось - не сохраняй документ
   Родом из детства
 
3 - 02.04.21 - 11:22
(1) То есть вызывать процедуру из модуля формы обработки?
   Родом из детства
 
4 - 02.04.21 - 11:23
(2) так и есть, до этого только ими и занимался%)
   Kondarat
 
5 - 02.04.21 - 11:27
(0)
в основной форме внешнего объекта следует определить клиентскую экспортную процедуру по шаблону:
   Для глобальных отчетов и обработок (Вид = "ДополнительнаяОбработка" или Вид = "ДополнительныйОтчет"):
       &НаКлиенте
       Процедура ВыполнитьКоманду(ИдентификаторКоманды) Экспорт
        // Реализация логики команды.

       КонецПроцедуры
   Для печатных форм (Вид = "ПечатнаяФорма"):
       &НаКлиенте
       Процедура Печать(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
        // Реализация логики команды.

       КонецПроцедуры
   Для обработок создания связанных объектов (Вид = "СозданиеСвязанныхОбъектов"):
       &НаКлиенте
       Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив, СозданныеОбъекты) Экспорт
        // Реализация логики команды.

       КонецПроцедуры
   Для обработок заполнения и контекстных отчетов (Вид = "ЗаполнениеОбъекта" или Вид = "Отчет"):
       &НаКлиенте
       Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
        // Реализация логики команды.

       КонецПроцедуры
   Дополнительно (для всех видов):
     В параметре формы "ДополнительнаяОбработкаСсылка" передается ссылка этого объекта
     (элемент справочника ДополнительныеОтчетыИОбработки, соответствующий этому объекту),
     которая может использоваться для фонового выполнения длительных операций.
     Подробнее см. в документации к подсистеме, раздел "Фоновое выполнение длительных операций".
   Родом из детства
 
6 - 02.04.21 - 11:28
Всем спасибо! Вроде, разобрался)

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.