Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Помогите проблема с общ модулем

Помогите проблема с общ модулем
Я
   Savgonnik
 
01.04.21 - 20:28
&НаКлиенте
Функция РозничнаяЦена(АктуальнаяДата, ЭлементНоменклатуры) Экспорт
// Создать вспомогательный объект "Отбор".
Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);
// Получить актуальные значения ресурсов регистра.
ЗначенияРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(АктуальнаяДата, Отбор);
Возврат ЗначенияРесурсов.Цена;
КонецФункции
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
СтрокаТабличнойЧасти.Сумма =
СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена;
КонецПроцедуры
КонецЦикла


Сама ошибка

{ОбщийМодуль.РаботаСДокументами.Модуль(7,13)}: Обнаружено логическое завершение исходного текста модуля
КонецФункции<<?>>; (Проверка: Тонкий клиент)
   Вафель
 
1 - 01.04.21 - 20:31
; лишняя
   тук-тук
 
2 - 01.04.21 - 20:32
КонецЦикла к чему?
   mikecool
 
3 - 01.04.21 - 20:39
(1) +1 после КонецФункции
   Savgonnik
 
4 - 04.04.21 - 11:19
; какая именно?
   Chameleon1980
 
5 - 04.04.21 - 11:24
(0)
1. вы кто?
2. кто писатель этого чуда?
3. неожиданно:
КонецПроцедуры
КонецЦикла

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.