Вход | Регистрация
 

Как получить данные реквизитов справочника находящихся в расширении

↓ [Волшебник, 01.04.21 - 12:46]
Как получить данные реквизитов справочника находящихся в расширении
Я
   spiller26
 
01.04.21 - 12:39
Справочник "Контрагент"
В расширении "InvoiceAPI" добавлен реквизит "апи_База"
Как получить данные реквизита "апи_База", желательно в запросе, можно и по ссылке?
   Волшебник
 
1 - 01.04.21 - 12:40
ВЫБРАТЬ апи_База ИЗ Справочник.Контрагент
   spiller26
 
2 - 01.04.21 - 12:46
(1) Всё увидел! Вопрос снят.
   spiller26
 
3 - 01.04.21 - 12:54
(1) В консоли в клиенте виден, а вот при разработке в конфигураторе нет такого.
   spiller26
 
4 - 01.04.21 - 13:13
Короче сделал так, всё равно общ.модуль есть свой.
Сделал там пустую функцию
Функция ЗапросВРасширениеАПИ(пСсылка) Экспорт
    Возврат Неопределено;
КонецФункции    

, которую потом определил в свое расширение 

&Вместо("ЗапросВРасширениеАПИ")
Функция апи_ЗапросВРасширениеАПИ(пСсылка) Экспорт
    
    Результат = ПродолжитьВызов();
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Контрагенты.апи_Сервер КАК апи_Сервер,
        |    Контрагенты.апи_База КАК апи_База,
        |    Контрагенты.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |    Контрагенты.Ссылка = &Ссылка";
    
    Запрос.УстановитьПараметр("Ссылка", пСсылка);
    РезультатЗапроса = Запрос.Выполнить().Выбрать();
    Если РезультатЗапроса.Следующий() Тогда
        Возврат РезультатЗапроса.апи_База;    
    КонецЕсли;;

    Возврат Результат;
КонецФункции
   spiller26
 
5 - 01.04.21 - 13:14
(4) Данные запрашиваю всё норм.

ДанныеКонтрагентаАПИ = абтДополнительноНаСервере.ЗапросВРасширениеАПИ(СтрТК.Контрагент);
   Почему 1С
 
6 - 01.04.21 - 13:29
Вот абстрактные методы, а говорят в 1с нет нет ООП

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.