Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Справочник. Отбор по нескольким значениям.

v7: Справочник. Отбор по нескольким значениям.
Я
   exec11
 
31.03.21 - 10:54
Сейчас у меня настроен отбор по одному значению.
Я это использую в форме отчета, поле ввода -> Дополнительно -> Форма:
Для выбора определенных счетов.

Процедура ПриОткрытии()
    УстановитьОтбор("ТипСчета",Перечисление.ТипСчета.Сбер);
КонецПроцедуры

Понадобилось добавить еще один счет в отбор.

Подскажите, как это можно сделать ??

Сам пробовал так:

СписОтбора= СоздатьОбъект("СписокЗначений");
СписОтбора.ДобавитьЗначение( Перечисление.ТипСчета.Сбер);
СписОтбора.ДобавитьЗначение( Перечисление.ТипСчета.ВТБ)
ИспользоватьСписокЭлементов(СписОтбора);
   Волшебник
 
1 - 31.03.21 - 10:55
Банки в перечислении — моветон
   acanta
 
2 - 31.03.21 - 10:56
Запрос и выгрузка в таблицу значений или список значений.
   Builder
 
3 - 31.03.21 - 10:57
Перечисление.ТипСчета.Сбер - прикольно.
Появился новый банк - заводи перечисление...... ТРЕШ
   Mikeware
 
4 - 31.03.21 - 10:57
(1) банк должен быть один!
   exec11
 
5 - 31.03.21 - 11:01
(4) За место банка может быть что угодно.

Суть, есть перечисления, как отфильтровать по двум перечислениям ??
   Волшебник
 
6 - 31.03.21 - 11:02
(5) Заведите новый реквизит "СБЕР_или_ВТБ" для фильтрации по условию "равно".
   Builder
 
7 - 31.03.21 - 11:03
(5) Запросом
   acanta
 
8 - 31.03.21 - 11:04
Сделайте закладки на форме. Два банка две закладки. Выглядит как отбор по двум значениям, а на самом деле это отбор по одному.
   Builder
 
9 - 31.03.21 - 11:05
+ к (7)
Запросом отобрать что надо, выгрузить в СЗ, дальше ИспользоватьСписокЭлементов()
   acanta
 
10 - 31.03.21 - 11:06
Метод "закладки отбора", если исходных данных для закладок много, то просто закладки из списка значений.
   exec11
 
11 - 31.03.21 - 11:13
Так я просто, без запроса, добавляю СЗ.
Истользую

ИспользоватьСписокЭлементов()

На выходе пусто.

Список значение создается, проверяю так :

    Сообщить(СписОтбора.ПолучитьЗначение(1));     
    Сообщить(СписОтбора.ПолучитьЗначение(2));

Закладки не подходят ...
   Андрей_Андреич
 
12 - 31.03.21 - 11:16
(2) поддержу. ПриНачалеВыбораЗначения() заполнить список значений по нужным критериям и выбирать из списка
   Builder
 
13 - 31.03.21 - 11:30
(11) Ты не перечисления отбирай, а свои банки отбирай запросом по 2-м перечислениям и там уже ИспользоватьСписокЭлементов()
Отбор по списку не работает.
   exec11
 
14 - 31.03.21 - 11:40
(13) Жаль что отбор по списку не работает.

Можно пример как можно это сделать ? Так как я не вижу смысла в запросе, если у меня вариантов для отбора то три. Которые указаны в перечислении.
Я список значение и так, без запроса соберу. Вопрос как его применить. Вот какой момент не ясен.
   exec11
 
15 - 31.03.21 - 12:04
Вообщем сделал так:

    СписОтбора= СоздатьОбъект("СписокЗначений");
    СпрСчета= СоздатьОбъект("Справочник.Счета");
    СпрСчета.ВыбратьЭлементы();
    
    Пока СпрСчета.ПолучитьЭлемент() = 1 Цикл     
        Если (СокрЛП(СпрСчета.ТекущийЭлемент().ТипСчета)="Сбер")
        ИЛИ (СокрЛП(СпрСчета.ТекущийЭлемент().ТипСчета)="ВТБ") Тогда         
            СписОтбора.ДобавитьЗначение( СпрСчета.ТекущийЭлемент()); 
        КонецЕсли;    
    КонецЦикла;
    ИспользоватьСписокЭлементов(СписОтбора);
   Bigbro
 
16 - 31.03.21 - 12:06
сойдет.
   Arbuz
 
17 - 31.03.21 - 16:34
>> Так как я не вижу смысла в запросе
Вот жешь... А у меня местами для такого же списка прямой запрос используется а там четыре элемента всего. ب_ب
   HawkEye
 
18 - 31.03.21 - 20:10
(15) правильнее загнать нужные тебе значения в списокЗначений и в условии проверять через НайтиЗначение()
   Исновая
 
19 - 31.03.21 - 20:50
(14) почему не работает? все там работает..только надо ответить на вопрос что такое список значений
   Cthulhu
 
20 - 01.04.21 - 03:13
ИспользоватьСписокЭлементов - отбор по списку элементов. написано жеш. собираешь в список элементы. которые удовлетворяют твоему условию - и делай с ним использоватьсписокэлементов.
   Cthulhu
 
21 - 01.04.21 - 03:17
но имей ввиду - если будешь так делать в многоуровневом справочнике с просмотром в режиме иерархии - надо для кажой группы когда в нее ходишь - переформировывать список элементов для фильтра. ограничивая условие фильтра дополнительно "И" условием принадлежности к текущей группе. и так при каждом переходе в другую группу. как это ловить - думай сам уже. как по мне - использоватьсписокэлементов оправдывает себя сугубо на небольших справочниках (или на плане счетов, да) и исключительно одноуровневых или в принудительно устанавливаемом и неотключаемым ИерархическийСписок(0,0)
   Cthulhu
 
22 - 01.04.21 - 03:18
аваще - еука бпысь назад в восьмерку. не трожь семерку.
   Cthulhu
 
23 - 01.04.21 - 03:18
*нука
   Cthulhu
 
24 - 01.04.21 - 03:19
*брысь


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.