Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Определения процедур и функций должны размещаться перед операторами тела модуля

Определения процедур и функций должны размещаться перед операторами тела модуля
Я
   Евгений39
 
21.03.21 - 01:27
При написании следующего кода всплывает сообщение:"{МодульУправляемогоПриложения(40,1)}; Определения процедур и функций должны размещаться перед операторами тела модуля". При этом никаких точек с запятыми после концов процедур в моём коде не стоит.

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
        // Заполнение шапки
        Клиент = ДанныеЗаполнения.Клиент;
        Склад = ДанныеЗаполнения.Склад;
        Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
            НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
            НоваяСтрока.Товар = ТекСтрокаТовары.Товар;
            НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
        КонецЦикла;
    КонецЕсли;
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    // регистр Взаиморасчёты Приход
    Движения.Взаиморасчёты.Записывать = Истина;
    Движение = Движения.Взаиморасчёты.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
    Движение.Период = Дата;
    Движение.Контрагент = Клиент;
    Движение.Сумма = СуммаДокумента;

    // регистр Продажи
    Движения.Продажи.Записывать = Истина;
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение = Движения.Продажи.Добавить();
        Движение.Период = Дата;
        Движение.Клиент = Клиент;
        Движение.Номенклатура = ТекСтрокаТовары.Товар;
        Движение.Количество = ТекСтрокаТовары.Количество;
        Движение.Сумма = ТекСтрокаТовары.Сумма;
    КонецЦикла;

    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
    // Вставить содержимое обработчика.
КонецПроцедуры


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    Для Каждого СтрокаТЧ ИЗ Товары Цикл
          СуммаДокумента=СуммаДокумента + СтрокаТЧ.Сумма;
    КонецЦикла;
КонецПроцедуры
   VladZ
 
1 - 21.03.21 - 01:33
А теперь посмотри на код и сам скажи в чем проблема
   Chameleon1980
 
2 - 21.03.21 - 09:12
{0}это весь код?
   Ненавижу 1С
 
3 - 21.03.21 - 09:28
у тебя ошибка в модуле управляемого приложения причем тут документ?

>>{МодульУправляемогоПриложения(40,1)}
   Провинциальный 1сник
 
4 - 21.03.21 - 09:38
(3) "А тут светлее" (с)
   Вафель
 
5 - 21.03.21 - 10:02
после конецпроцедуры наверняка где-то стоит ;
   Chameleon1980
 
6 - 21.03.21 - 12:15
щелкни уже по ошибке, чтобы перейти к ней
   Евгений39
 
7 - 21.03.21 - 13:31
Друзья, прошу прощения за беспокойство. Проблема была в модуле приложения, так как там был написан лишний код.
   RetardedToBoot
 
8 - 21.03.21 - 16:53
>СуммаДокумента=СуммаДокумента + СтрокаТЧ.Сумма;

Потенциальная ошибка. Без обнуления перед этим.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.