Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Событие ОбработкаВыбора у элемента формы с составным типом

Событие ОбработкаВыбора у элемента формы с составным типом
Я
   brenli
 
20.03.21 - 21:34
Всем привет.
Конфа на обычных формах.
Пишу обработку которая будет создавать или изменять элемент справочника.
На форме есть реквизит составного типа Тип у реквизита Строка и СправочникСсылка.ОбъектыУчета.
Если работаем с типом СправочникСсылка происходит выбор элемента из справочника с отбором,
если работаем со Строкой создаем новый объект.

Процедура ГосНомерОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;

КонецПроцедуры

Не пойму до конца как обработать тип. Подскажите кто в теме
   Lexey_
 
1 - 20.03.21 - 21:51
(0) Если ТипЗнч(ВыбранноеЗначение) = Тип("Строка") Тогда...
   brenli
 
2 - 20.03.21 - 21:55
(1) Не проходит в выбранном значении при выборе типа Тип

ТипЗнч(ВыбранноеЗначение)  - Результат Тип
   brenli
 
3 - 20.03.21 - 21:59
Вообще связался с отключением стандартной обработки по той причине что нужен отбор.
Я правильно понимаю что отбор в форму выбора никак не установить кроме как
ФормаСписка = Справочники.ОбъектыУчетаСтороннихОрганизаций.ПолучитьФормуВыбора(,ЭтаФорма);
ФормаСписка.Отбор.Владелец.Установить(Контрагент,Истина);
?
   Chameleon1980
 
4 - 21.03.21 - 05:23
(3)уф?
передай параметр в открытьформу
   brenli
 
5 - 21.03.21 - 07:28
(4) Обычные формы
   Вафель
 
6 - 21.03.21 - 10:09
(4) лучше так не делать
   brenli
 
7 - 21.03.21 - 11:08
Проблему решил другим обработчиком события.
Корректно происходит работа с типами Строка и Справочник.

Процедура ГосНомерНачалоВыбора(Элемент, СтандартнаяОбработка)
    Если ТипЗнч(Элемент.Значение) = ТипЗнч(Неопределено) Тогда 
        Возврат;
    КонецЕсли;
    ВыбратьОбъектУчетаНажатие(Элемент);
    
    СтандартнаяОбработка = Ложь;
    
КонецПроцедуры
   Chameleon1980
 
8 - 21.03.21 - 12:12
(6)с какого перепуга?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.