Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Бухпроводки по должности в ЗУП 3

Бухпроводки по должности в ЗУП 3
Я
   Juliette_Juliette
 
17.03.21 - 14:16
В справочнике штатного расписания предусмотрено заполнение способа отражения расходов, по крайней мере в конфигураторе.
Не могу добиться отражения этого поля в режиме предприятия, какая ФО влияет на это, мне кажется я все пересмотрела.
У кого была такая необходимость, рабочий ли механизм, как его включить?
   dnab
 
1 - 17.03.21 - 14:38
Эта реализовано для конфы для госучреждений. Я добавлял свой доп реквизит и делал свою заполнялку регистра БухучетСотрудников
   Juliette_Juliette
 
2 - 17.03.21 - 14:46
(1) вот как, а если просто включить для хозрасчетной, не пробовали?
Скелет-то конфигурации один по сути
   Juliette_Juliette
 
3 - 17.03.21 - 14:51
эта какаха?
    Если ОбщегоНазначения.ПодсистемаСуществует("ЗарплатаКадрыПриложения.ГосударственнаяСлужба") Тогда
        МодульГосударственнаяСлужба = ОбщегоНазначения.ОбщийМодуль("ГосударственнаяСлужба");
        МодульГосударственнаяСлужба.ДополнитьФормуЭлементаСправочникаШтатноеРасписание(Форма);
    КонецЕсли;
   dnab
 
4 - 17.03.21 - 15:24
(2) я не пробовал
   alexxx961503
 
5 - 17.03.21 - 15:45
(3) думаю вот это (модуль менеджера значения константы ИспользоватьГосударственнуюСлужбу)

Процедура ПередЗаписью(Отказ)
    
    ПодсистемаСуществует = ОбщегоНазначения.ПодсистемаСуществует("ЗарплатаКадрыПриложения.ГосударственнаяСлужба");
    Если Не ПодсистемаСуществует Тогда
        Если Значение Тогда
            ВызватьИсключение НСтр("ru = 'Нельзя установить значение ИспользоватьГосударственнуюСлужбу'");
        КонецЕсли;
    КонецЕсли;
    
    Если ЗарплатаКадры.ОтключитьБизнесЛогикуПриЗаписи(ЭтотОбъект) Тогда
        Возврат;
    КонецЕсли;
    
    Если ПодсистемаСуществует Тогда
        ИспользоватьМуниципальнуюСлужбу = Константы.ИспользоватьМуниципальнуюСлужбу.Получить();
        Если Значение И ИспользоватьМуниципальнуюСлужбу Тогда
            ВызватьИсключение НСтр("ru = 'В программе уже ведется расчет денежного содержания Муниципальных служащих, не допускается использовать одновременно расчет денежного содержания Государственных и Муниципальных служащих'");    
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры


Ну и если подсистемы нет(а ее в обычном ЗУПе как понимаю нет, то и настройку эту не включить)
   ixijixi
 
6 - 17.03.21 - 16:10
МодульГосударственнаяСлужба.ДополнитьФормуЭлементаСправочникаШтатноеРасписание(Форма)

Сходил в модуль в ЗГУ, он там ограничивает видимость флажков ЯвляетсяДолжностьюГосударственнойСлужбы и ЯвляетсяДолжностьюВоеннойПравоохранительнойСлужбы. Бухучет не трогает.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.