Вход | Регистрация
 

Помогите разобраться с передачей ТЗ между клиентом и сервером

Помогите разобраться с передачей ТЗ между клиентом и сервером
Я
   Novichok VX
 
15.03.21 - 12:53
Вот так не работает, что не так и как надо?

&НаСервере
Процедура Хран ()
    ТЧВТЗ=объект.ТабличнаяЧасть1.Выгрузить();    
    

ПоместитьВоВременноеХранилище(ТЧВТЗ, Новый УникальныйИдентификатор);
    
КонецПроцедуры    

&НаКлиенте
Процедура Загрузить2(ФайлПоставкиXML)
    
ТЧВТЗ=ПолучитьИзВременногоХранилища( УникальныйИдентификатор);
   Андроны едут
 
1 - 15.03.21 - 12:59
Правильно передавать с сервера на клиент массив структур.
   yzimin
 
2 - 15.03.21 - 13:05
&НаСервере
Процедура Хран ()
    ТЧВТЗ=объект.ТабличнаяЧасть1.Выгрузить();    
    

    АДРЕС = ПоместитьВоВременноеХранилище(ТЧВТЗ, Новый УникальныйИдентификатор);
    
КонецПроцедуры    

&НаКлиенте
Процедура Загрузить2(ФайлПоставкиXML)
    
ТЧВТЗ=ПолучитьИзВременногоХранилища(АДРЕС);
   Classic
 
3 - 15.03.21 - 13:06
(0)
На клиенте таблицы значений нет. Надо юзать что-то другое.
   Novichok VX
 
4 - 15.03.21 - 13:08
(2)
Переменная не определена (АДРЕС)
ТЧВТЗ=ПолучитьИзВременногоХранилища(<<?>>АДРЕС); (Проверка: Тонкий клиент
   Novichok VX
 
5 - 15.03.21 - 13:09
У меня текстовый файл читается. Надо чтобы выбор был на клиенте, а обработка использует ТЗ. Как быть?
   yzimin
 
6 - 15.03.21 - 13:10
(4) Ну так обеспечь передачу АДРЕСА с сервера на клиент
   Novichok VX
 
7 - 15.03.21 - 13:13
(6)
вот так не работает

&НаСервере
Функция Хран ()
    ТЧВТЗ=объект.ТабличнаяЧасть1.Выгрузить();    
    

    АДРЕС = ПоместитьВоВременноеХранилище(ТЧВТЗ, Новый УникальныйИдентификатор);
  возврат адрес;  
КонецФункции   

&НаКлиенте
Процедура Загрузить2(ФайлПоставкиXML)
    
ТЧВТЗ=ПолучитьИзВременногоХранилища(Хран ());
   Fedor-1971
 
8 - 15.03.21 - 13:15
(0) Это всё в рамках управляемой формы?
   acht
 
9 - 15.03.21 - 13:15
На клиенте тип таблицы значений не существует. Используй другие типы данных.
   Novichok VX
 
10 - 15.03.21 - 13:15
(8)
да
   elCust
 
11 - 15.03.21 - 13:17
ПоместитьВоВременноеХранилище - возвращает адрес где хранится значение.
Почитайте уже справку как использовать метод блин.
   программистище
 
12 - 15.03.21 - 13:19
сформируй файл на сервере и передай его либо ввиде текста, либо через вереммное хранилище двоичными данными
   Kassern
 
13 - 15.03.21 - 13:41
(7) какой смысл передавать ТЗ на клиент? Если бы на форме была ТЗ, то тогда и передавать ничего не надо, после заполнения на сервере она автоматом на клиенте отобразится. Если уж так приспичило именно ТЗ вернуть на клиент, тогда массив структур вам в помощь.
   Fedor-1971
 
14 - 15.03.21 - 13:43
(10) Сделай реквизит формы с типом ТаблицаЗначений
при контекстном вызове он (реквизит, а по сути ТаблицаЗначений) приедет НаСервер, там её и заполнишь
По сути: перебор строк оной можно сделать и НаКлиенте
  Например, так:
1. читаем файл НаКлиенте и заполняем Реквизит формы
2. Идём НаСервер и дозаполняем Ссылки

Дальше на вкус и цвет, хочешь сравнивай НаКлиенте, хочешь
   Fedor-1971
 
15 - 15.03.21 - 13:44
14+ Только это КоллекцияФормы, а не совсем ТЗ
   ejikbeznojek
 
16 - 15.03.21 - 15:02
Ну или если это обработка, то табличную часть))
   fisher
 
17 - 15.03.21 - 15:17
(5) Проще сразу передать текст на сервер и обрабатывать уже там. Идея такая, что любую серьезную обработку лучше делать на сервере. Поэтому и ТЗ на клиенте спецом зарезали, чтобы форсить разрабов в эту сторону. Либо переделай обработку на клиенте так, чтобы она работала не с таблицей значений, а напрямую с табличной частью на клиенте (тип "ДанныеФормыКоллекция")
   timurhv
 
18 - 15.03.21 - 15:23
(14) при переборе строк большой таблицы на клиенте будут неявные серверные вызовы
   Новый1сник2
 
19 - 15.03.21 - 16:06
(4) адрес можно константой передавать
   ДНН
 
20 - 15.03.21 - 16:33

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.