Вход | Регистрация
 

Потеряна связь с сервером

Потеряна связь с сервером
Я
   Анцеранана
 
15.03.21 - 11:35
Уважаемые коллеги! На моем рабочем компе все работает, когда запускаю нижеследующую обработку. На другом выводится вот такое сообщение:

"Во время выполнения действия была потеряна связь с сервером. Сейчас соединение восстановлено. При необходимости повторите выбранное действие."
Гугл выдал много непонятного. На всякий случай установил таймаут, но не работает все равно.

Процедура ПодключитьсяКСбербанку(ПолныйАдресРесурса)

        Соединение = Новый HTTPСоединение("3dsec.sberbank.ru",443,,,,120,Новый ЗащищенноеСоединениеOpenSSL());
    ИмяФайла = ПолучитьИмяВременногоФайла(".rss");

    НмрЗаказа = Объект.НомерЗаказа;
    Запрос = Новый HTTPЗапрос("/payment/rest/getReceiptStatus.do?userName=ElonMask666&password=Qwerty&orderNumber="+НмрЗаказа);

    Результат=Соединение.Получить(Запрос,ИмяФайла);
    
    ТекстовыйФайл = Новый ТекстовыйДокумент;    
    ТекстовыйФайл.Прочитать(ИмяФайла);          
    СтрокаСодержащаяТекстJSON = ТекстовыйФайл.ПолучитьТекст();
    
    //она длинная
    Если СтрДлина(СтрокаСодержащаяТекстJSON)<10 Тогда
        СтандартноеСообщение(НмрЗаказа,1);
        Возврат;
    КонецЕсли;
    
    ЧтениеJSON = Новый ЧтениеJSON;
    ЧтениеJSON.УстановитьСтроку(СтрокаСодержащаяТекстJSON);

    Данные = ПрочитатьJSON(ЧтениеJSON, Ложь);
    
    Если ТипЗнч(Данные)<>Тип("Структура") Тогда
        СтандартноеСообщение(НмрЗаказа,2);
    ИначеЕсли Данные.Свойство("receipt") = Ложь Тогда
        СтандартноеСообщение(НмрЗаказа,2);
    Иначе
        ИмяСвойства = "fiscal_document_number";
        НомерЧека   = ПолучитьНомерЧека(Данные.receipt,ИмяСвойства);
        
        Сообщить("Фискальный номер документа (номер чека) :"+НомерЧека+" Код счета АИРС :"+НмрЗаказа);
        
    КонецЕсли;
    УдалитьФайлы(ИмяФайла);

КонецПроцедуры
   eeeio
 
1 - 18.03.21 - 11:23
аналогичная проблема
   piter3
 
2 - 18.03.21 - 11:25
password=Qwerty Вы серьезно?В открытом доступе?
   denis_z3x
 
3 - 26.03.21 - 16:42
1
   МихаилМ
 
4 - 26.03.21 - 18:33
Ваши коллеги на сайте https://www.govnokod.ru/1c.

по форме: нет обработчиков ошибок , параметр читается из св-ва формы.
по содержанию : (...+НмрЗаказа...) не отформатировано , используйте поток ПолучитьТелоКакСтроку  (Доступен, начиная с версии 8.2.) вместо чтения во временный файл.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.