Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывести на макет текущего пользователя

Вывести на макет текущего пользователя
Я
   kukulkan
 
14.03.21 - 17:15
Привет! Подскажите, пожалуйста.

Предприятие 8,3 УП

У меня есть документ в котором нужно вывести в подписи текущего пользователя на месте Отпустил и Получил. Спасибо за любую помощь!

Подвал.Параметры.КоличествоОтпущено        = ОбщегоНазначенияБКВызовСервера.КоличествоПрописью(ВсегоКоличество);
        Подвал.Параметры.СуммаПрописью             = ОбщегоНазначенияБКВызовСервера.СформироватьСуммуПрописью(?(ЗначениеЗаполнено(ВыборкаПоРегистратору.Сумма),ВыборкаПоРегистратору.Сумма,0), Валюта);
        ИтогоТаблицы2.Параметры.ИтогоКоличество = ВсегоКоличество;
        ИтогоТаблицы2.Параметры.ИтогоСумма        =  ?(ЗначениеЗаполнено(ВыборкаПоРегистратору.Сумма),ВыборкаПоРегистратору.Сумма,0);            
        
        //МОЛ
        ДанныеОтправителя = ПроцедурыУправленияПерсоналомВызовСервера.ДанныеФизЛица(ВыборкаПоДокументам.Организация, ВыборкаПоДокументам.МОЛОтправителя, ВыборкаПоДокументам.Дата);
        ДанныеПолучателя  = ПроцедурыУправленияПерсоналомВызовСервера.ДанныеФизЛица(ВыборкаПоДокументам.Организация, ВыборкаПоДокументам.МОЛПолучателя, ВыборкаПоДокументам.Дата);
        
        Подвал.Параметры.ДолжностьОтпустил = ДанныеОтправителя.Должность;
        Подвал.Параметры.ФИООтпустил        = ДанныеОтправителя.Представление;
        
        Подвал.Параметры.ДолжностьПолучил = ДанныеПолучателя.Должность;
        Подвал.Параметры.ФИОПолучил       = ДанныеПолучателя.Представление;
        
        Подвал.Параметры.Валюта = Валюта;
        
        ТабДокумент.Вывести(ИтогоТаблицы2);
        
        Если Не ОбщегоНазначения.ПроверитьВыводТабличногоДокумента(ТабДокумент, Подвал) Тогда
                
            // Выведем разрыв страницы
            ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                
        КонецЕсли;
    
        ТабДокумент.Вывести(Подвал);    

        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент, НомерСтрокиНачало, ОбъектыПечати, ВыборкаПоДокументам.Ссылка);
        
    КонецЦикла;
    
    Возврат ТабДокумент;
    
КонецФункции
   shuhard
 
1 - 14.03.21 - 17:17
(0) вопрос то в чем ?
   Chameleon1980
 
2 - 14.03.21 - 17:37
найти и показать
   Chameleon1980
 
3 - 14.03.21 - 17:38
или не
было тут как-то:
"дайте мне код наиболее оптимального решения"
   Dotoshin
 
4 - 14.03.21 - 17:48

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.