Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Некорректно работает обработчик НачалоВыбора

Некорректно работает обработчик НачалоВыбора
Я
   Juliette_Juliette
 
13.03.21 - 11:39
Процедура МатериалыНазначениеИспользованияНачалоВыбора(Элемент, СтандартнаяОбработка)
    Если (НЕ Элемент.Значение.Владелец.Пустая()) И (Дата >= СпецодеждаИСпецоснастка.ДатаНачалаДействияСтандартаФСБУ5_2019()) Тогда
        СтандартнаяОбработка = Ложь;
        
        ЗначениеОтбора = Новый Структура("Владелец, СпособПогашенияСтоимости", Элемент.Значение.Владелец, Перечисления.СпособыПогашенияСтоимости.ПогашатьСтоимостьПриПередачеВЭксплуатацию);
        ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);
        ОткрытьФорму("Справочник.НазначенияИспользования.ФормаВыбора", ПараметрыВыбора);
    КонецЕсли;
КонецПроцедуры

Не срабаывает отбор по СпособПогашенияСтоимости, только по Владельцу.
Почему, что упущено?
   acht
 
1 - 13.03.21 - 11:52
"Справочник.НазначенияИспользования.ФормаВыбора" - обычная или управляемая?
   Juliette_Juliette
 
2 - 13.03.21 - 11:54
(1) обычная, УПП
   Juliette_Juliette
 
3 - 13.03.21 - 12:00
все, переписала, спасибо

    Если (НЕ Элемент.Значение.Владелец.Пустая()) И (Дата >= СпецодеждаИСпецоснастка.ДатаНачалаДействияСтандартаФСБУ5_2019()) Тогда
        СтандартнаяОбработка = Ложь;
        
        нФормаВыбора = Справочники.НазначенияИспользования.ПолучитьФормуВыбора(, Элемент.Значение.Владелец);
        нФормаВыбора.ПараметрОтборПоВладельцу  = Элемент.Значение.Владелец; 
        
        нФормаВыбора.Отбор.СпособПогашенияСтоимости.ВидСравнения = ВидСравнения.Равно;
        нФормаВыбора.Отбор.СпособПогашенияСтоимости.Значение = Перечисления.СпособыПогашенияСтоимости.ПогашатьСтоимостьПриПередачеВЭксплуатацию;
        нФормаВыбора.Отбор.СпособПогашенияСтоимости.Использование = Истина;
        
        нФормаВыбора.Открыть();    
    КонецЕсли;
   acht
 
4 - 13.03.21 - 12:01
(2) А передача отбора через параметры работает только для управляемых

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.