Вход | Регистрация
    1  2  3  4  5  6  7   
О жизни... :: Как страшно жить

OFF: Соискатели не могут написать функцию, которая выводит строку в обратном порядке. Почему?

OFF: Соискатели не могут написать функцию, которая выводит строку в обратном порядке. Почему?
Я
   O-Planet
 
09.03.21 - 16:03
2. Надо сжигать тех, кто даёт такие задачи33% (12)
3. Надо сжечь всех31% (11)
4. Никого сжигать не надо28% (10)
1. Надо сжигать таких8% (3)
Всего мнений: 36

Провожу собеседование. Ищу программка 1С... Народ, скажите, это я в чем-то не прав, или мир так изменился? Приходящие делают тестовую конфу, вроде все норм. Но когда даю задачку - написать прошу, которая выводит строку в обратном порядке - ни кто не может этого сделать!!! Уже пятый претендент говорит, что дома подумает.

Ладно, иду навстречу, сам пишу эту функцию. Объясняю. Вроде поняли. Прошу переделать, чтобы на выходе выводилась строка из символов с четными индексами: 2, 4, 6 и т.д. Снова Тупак полнейший.

Снова делаю, объясняю, поняли. Прошу, чтобы в результат выводилась строка с каждым третьим символом.

Угадайте, удается им это сделать или нет?

Введите, плиииз, на законодательном уровне ИТ инквизицию! Чтобы она отправляла на костер тех, кто называет себя программистом, но не умеет работать с циклами и решать задачки из школьного курса информатики!!!

По итогам ветки родилась статья:
Перевернуть строку на разных языках программирования
   Irbis
 
101 - 09.03.21 - 17:16
(100) ... но такая херня получается...
   Половинкин
 
102 - 09.03.21 - 17:16
Хороший вброс, годный...
   программистище
 
103 - 09.03.21 - 17:17
(101) это ты про типовые? )))
   O-Planet
 
104 - 09.03.21 - 17:18
(100) Не думаю. Он возненавидит человечество.
   Garikk
 
105 - 09.03.21 - 17:18
(100) нет ИИ который на любом языке универсальный код генерит
   программистище
 
106 - 09.03.21 - 17:20
и да...

3. Надо сжечь всех
   Половинкин
 
107 - 09.03.21 - 17:21
(11) 60 нормально? Да ну нафик, вот к вам и идёт контингент соответсвующий. Те, кто поумнее давно уже на Москву по удаленке работают.
   Garikk
 
108 - 09.03.21 - 17:21
(0) при условии если вы не джуна берете

2. Надо сжигать тех, кто даёт такие задачи
   dimaldinho
 
109 - 09.03.21 - 17:22
(0) >> Чтобы она отправляла на костер тех, кто называет себя программистом, но не умеет работать с циклами и решать задачки из школьного курса информатики

Можно подумать, все, кто называют себя сантехниками, профи своего дела. Непрофессионалов полно среди представителей любой профессии. Вот, пример, знаю одного парня с ником O-Planet, так он тратит рабочее время на собеседования с "программистами", которые даже строку перевернуть не могут.

4. Никого сжигать не надо
   Hans
 
110 - 09.03.21 - 17:25
(91) База мисты что ли пропала? Почему у моих тем нет 2х лет? после 2009  идет сразу 2011?
   Garikk
 
111 - 09.03.21 - 17:25
по моим наблюдениям, профессионалов - вообще очень небольшое количество в любой сфере.

а вот считать что мерилом профи-программиста в быстром вспоминании школьных алгоритмов которые не применяются на практике нигде кроме 6 класса школы --- это вот реально маркер непрофессионализма и повышенного ЧСВ
   Garykom
 
112 - 09.03.21 - 17:29
(111) Тут речь не про школьные алгоритмы а про огромный пробел в программировании и работы со строками в 1С
Например я хз в каком порядке и как идут параметры в Сред() и даже периодически заново в СП или инете смотрю нумерация с 0 или с 1 (для строк, массивов, ТЗ и т.д.)
   Garykom
 
113 - 09.03.21 - 17:31
Кстати Лев(), Прав(), Сред() надо бы переименовать по аналогии в СтрЛ(), СтрП(), СтрС()
   Волшебник
 
114 - 09.03.21 - 17:32
(110) Наверное, Вы уходили или пользовались другим ником.
   Grekos2
 
115 - 09.03.21 - 17:32
ТС хочет унизить 1С ников.
  Придумал ужасный тест , чтобы доказать, что сам он О - хо-хо, а соискатели Хи-хи-хи.
   Гобсек
 
116 - 09.03.21 - 17:33
(110) Вероятнее всего, тебя просто забанили на год.
   Hans
 
117 - 09.03.21 - 17:33
(114) Не припоминаю что бы меня на столько банили, другими никами вроде не пользовался никогда.
   Волшебник
 
118 - 09.03.21 - 17:33
(115) И требует рекурсию. Ещё бы попросил запросом
   Garykom
 
119 - 09.03.21 - 17:35
(118) Рекурсией как раз проще
А вот запросом не уверен что даже Ильдарович смогет
   Garikk
 
120 - 09.03.21 - 17:36
(112) тут вопрос не в 1С, работа со строкой это базовый навык программиста, ТС тут прав. важен только контекст

я попадал на собесы (на сеньора) когда внезапно выдавали подобный вопрос и дальнейшее обсуждение шло в контексте 'да он даже не джун...фууу'

блин я не учебник по информатики чтобы за 2 минуты на бумажке такое изобразить, учитывая что я десяток языков знаю
   Garikk
 
121 - 09.03.21 - 17:37
(120) *в этом вопросе - важен контекст, зачем такой вопрос вообще задавать
   Волшебник
 
122 - 09.03.21 - 17:37
(119) Ну вы ещё факториал попросите посчитать.

2. Надо сжигать тех, кто даёт такие задачи
   mikecool
 
123 - 09.03.21 - 17:37
да ладно вам - не могут задачи решить
я как то собеседовал чела, мы договорились на время о собеседовании, познакомились, задаю ему простой логический вопрос, а в ответ
"я не готов вам ответить! и чего вы мне вообще позвонили, я сейчас обедаю!" и вешает трубку
странно - как он HRпрошел?
   piter3
 
124 - 09.03.21 - 17:38
Учитывая,что скорее всего подобные задания вряд ли будут приоритетными у автора то сжечь, совсем суть-чуть

2. Надо сжигать тех, кто даёт такие задачи
   Garikk
 
125 - 09.03.21 - 17:40
(123) действительно, не готов ответить в обеденное время вне собеседования - такой одинэсник нам не нужен... долЖОн в 4 утра встать и быть готов поднимать УПП
   Serg_1960
 
126 - 09.03.21 - 17:40
А слабо написать самую лаконичную (по количеству символов) функцию переворота строки? :)
   rphosts
 
127 - 09.03.21 - 17:41
(0) ты чё, опух? Тебя надо на костёр!
месяца 3 искали хоть когонить... нашли студента, да не простого, а студента техникума... не, кста пацан норм: не ленивый, знает неожиданно много, но мля, где кодеры?!!!!

4. Никого сжигать не надо
   mikecool
 
128 - 09.03.21 - 17:42
(125) ты не понял контекста )))
человек договорился на это время, в начале я спросил - готов ли он, и только после положительного ответа я начинаю задавать вопросы
то, что у него обед - его сексуальные проблемы, шерифа они не трогают ))
   rphosts
 
129 - 09.03.21 - 17:42
(113) а венгерской нотации тебе не надо?
   mikecool
 
130 - 09.03.21 - 17:43
(126) на каком языке? на питоне очень
даже можно
 
 Рекламное место пустует
   Garikk
 
131 - 09.03.21 - 17:45
(127) ну вот технарь закончит и в туман свалит, будете следующего искать
   Garikk
 
132 - 09.03.21 - 17:45
а кодеров нет, это вообще проблема всей отрасли, и не только 1С
   shpioleg
 
133 - 09.03.21 - 17:46
(0) Рекурсия и можно вырезать через несколько букв
&НаКлиенте
Процедура Перевернуть(Команда)
    ПеревернутьНаКлиенте(Объект.ИсходнаяСтрока,СтрДлина(Объект.ИсходнаяСтрока),Объект.Промежуток)
КонецПроцедуры

Процедура ПеревернутьНаКлиенте(ИсходнаяСтрока,ДлинаСтроки,Промежуток,ПеревернутаяСтрока = "")
    ДлинаСтроки = ДлинаСтроки - Промежуток;
    Если ДлинаСтроки < 0 Тогда
        ИсходнаяСтрока = ПеревернутаяСтрока;
        Возврат;
    КонецЕсли;
    ПеревернутаяСтрока = ПеревернутаяСтрока + Лев(Прав(ИсходнаяСтрока,Промежуток),1);    
    ИсходнаяСтрока = Лев (ИсходнаяСтрока,ДлинаСтроки);
    ПеревернутьНаКлиенте(ИсходнаяСтрока,ДлинаСтроки,Промежуток,ПеревернутаяСтрока);
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Объект.ИсходнаяСтрока = "Тестовая строка перевертыш.";
    Объект.Промежуток = 1//Какой символ вырезать. Если 2, то вырезание через одну букву

КонецПроцедуры



Сойдет ?
   Prog111
 
134 - 09.03.21 - 17:46
"Страшно далёк автор от народа". Зачем вообще такое задание? Ничего подобного в разработке на 1С не встречается, и нахрен не нужно. ТС бы ещё задачу на сортировку пузырьком или задачу о рюкзаке задал бы...
Это как пилоту Боинга предложить полетать на ЯК-1 или на АН-2. Пилот Боинга мыслит совсем другими категориями и решает иные задачи, поэтому с якобы простой задачей полета на АН-2 может и не справиться.

2. Надо сжигать тех, кто даёт такие задачи
   Kassern
 
135 - 09.03.21 - 17:48
(0) Да банально не могут файл с клиента передать через временное хранилище на сервер, о чем речь...И это приходят на вакансию в 150к

1. Надо сжигать таких
   rphosts
 
136 - 09.03.21 - 17:48
(126)если в лоб...
а = "ывепыаедлоывидлтжлоцмтилжыовпмылвжое";
в="";

дл = СтрДлина(а);
Для и1 = 1 По дл Цикл
    в=в+Сред(а,1+дл-и,1);
КонецЦикла;

но подозреваю что это не самый краткий вариант
   rphosts
 
137 - 09.03.21 - 17:49
(131) это проблема не меня а нача... которого тоже не могут найти и ОК. Хотя думаю если не будет форс-мажора на пару лет его хватит точно
   rphosts
 
138 - 09.03.21 - 17:49
(136) * в=в+Сред(а,1+дл-и1,1);
   Волшебник
 
139 - 09.03.21 - 17:49
   mikecool
 
140 - 09.03.21 - 17:51
(139) таки питон рулит )
   Krendel
 
141 - 09.03.21 - 17:51
(132) Начни обучать и они появятся ;-)
   fisher
 
142 - 09.03.21 - 17:51
(128) Ну, он-то надеялся что вопросы будут из разряда "На старой работе одинэснег получал NNN денег. Сколько всего денег будет получать одинэснег, если на новой работе ему насыпят еще два раза по столько же?". А ты с глупостями какими-то.
   mikecool
 
143 - 09.03.21 - 17:52
(134) алгоритмы сортировки еще помнить нужно, а банальные вещи в голове должны быть
такие простые задачи даются на проверку соображать
   Волшебник
 
144 - 09.03.21 - 17:52
(140) PHP рулит:

strrev()
   Garikk
 
145 - 09.03.21 - 17:52
(140) зато java нагляднее
   mikecool
 
146 - 09.03.21 - 17:53
(144) снимаю шляпу )
   Garikk
 
147 - 09.03.21 - 17:53
(143) мне тут банальные вещи про перемножение матриц спрашивали на одном собесе..не ну как все программисты это должны знать, разве нет?
   fisher
 
148 - 09.03.21 - 17:53
(134) Сразу становится понятно, на каком расстоянии соискатель находится от программирования. Это же задачки из разряда логических.
   mikecool
 
149 - 09.03.21 - 17:53
+146 не, одеваю обратно, букв больше
   rphosts
 
150 - 09.03.21 - 17:54
(141) и только прекрати процесс как начнут разбегаться
   Начинающий_13
 
151 - 09.03.21 - 17:54
Может у тебя провести собеседования как у П. Чистова. Ты готов? Ршим пару простых задач по быстрому. Ты ни никогда не думал, что хороших програмист это не тот кто быстро говорит и пишит зазубренне, а спокойно сядет подумает, откроет если надо справку и решит проблему.
   mikecool
 
152 - 09.03.21 - 17:54
(147) это знания, считаю почти базовые, любого тех вуза
если вспомнил + в карму ))
   Krendel
 
153 - 09.03.21 - 17:55
(147) Хлеще вопросы- структуры регистров себестоимости УПП при партионном учете ;-)

Я правда попросил сначала ответить на количество отчетов в уПП, но чото проверяющий слился
   Prog111
 
154 - 09.03.21 - 17:56
(143) В 1С на проверку сообразительности надо давать какую-нибудь типовую базу и задачу - вытащить данные о контактной информации или дополнительные реквизиты. Или что-то в этом роде.
   rphosts
 
155 - 09.03.21 - 17:57
(153) кол-во отчётов в УПП? Ты стебаешься?
   rphosts
 
156 - 09.03.21 - 17:57
+ (155) я-бы после такого вопроса встал и ушёл.
   Garikk
 
157 - 09.03.21 - 17:58
(152) у меня был один такой коллега, до хрипоты мог спорить как правильно делать сортировку и такие мозголомные штуки...у нас код на ревью мог неделю висеть потому что в какомто неважном участке типа упрядочивания списка из 5 элементов не оптимальный код... не обращая внимания на то что кругом пожар и через неделю релиз который этот модуль полностью выводит из эксплуатации
   Krendel
 
158 - 09.03.21 - 17:58
(155) В свое время, будучи стажером, на первом своем проекте, выписал в эксель все отчеты УПП, прооткрывал их все, и потом мы согласовывали только нужные ;-)
   mikecool
 
159 - 09.03.21 - 17:59
(157) зато , предполагаю, на выходе был чистый код
   Garykom
 
160 - 09.03.21 - 17:59
(136) В одну строку можно записать же
 
 Рекламное место пустует
   rphosts
 
161 - 09.03.21 - 17:59
(158) вот офигенно полезная фигня - список отчётов УПП... ещё с внешними
   rphosts
 
162 - 09.03.21 - 17:59
(157) это называется перфекционизм
   rphosts
 
163 - 09.03.21 - 18:00
+ (162) сделать задачу идеально... но, никогда!
   Garikk
 
164 - 09.03.21 - 18:00
(159) на выходе был адский код с нулевым уровнем поддержки...да блин он работал идеально

через неделю прилетает задача 'а докиньте еще 3 аттрибута в отчет чтобы они тоже учитывались'...и ппц, месяц перепиливание ВСЕГО потому что 'прошлое решение было оптимально только в данном варианте'
   Начинающий_13
 
165 - 09.03.21 - 18:00
По УПП все собеседования у меня заканчивались сделайте нам выгрузку(отредактируйте) из одной УПП, из загрузить в более новую . Тогда мы вас примем
   Krendel
 
166 - 09.03.21 - 18:00
(161) меня собеседовали, такое же как знание регистров накопления по расчету себеса, или НДСа, если ты когда-нить погружался в специфику- ты знаешь, если нет- не знаешь
   Волшебник
 
167 - 09.03.21 - 18:00
(160) Хватит разврата
   Garikk
 
168 - 09.03.21 - 18:00
(162) это кошмар
   rphosts
 
169 - 09.03.21 - 18:01
(165) обновить релиз что-ли?
   Garykom
 
170 - 09.03.21 - 18:02
(160)+
Стр = "Проверка";
Сообщить(Стр);
Стр2 = "";
Для Сч = 1 По СтрДлина(Стр) Цикл Стр2 = Стр2 + Сред(Стр, СтрДлина(Стр) - Сч + 1, 1) КонецЦикла;
Сообщить(Стр2);

   Garykom
 
171 - 09.03.21 - 18:03
(133) Чего то ты лишнего с рекурсией наворотил, там все сильно проще
   Начинающий_13
 
172 - 09.03.21 - 18:03
(169) Нет написать обработку или ту которую они нашли в нете
   rphosts
 
173 - 09.03.21 - 18:04
(170) как после деабскурации кода... т.е. в 1 строку - надуманно
   O-Planet
 
174 - 09.03.21 - 18:05
(136) Красавчик! Да, это и нужно.

Народ, тут вопрос не в строках, а в умении ориентироваться на местности. Ограничений нет вообще! Гугл, хелп и пол часа времени!!! Как можно не решить эту задачу, объясните мне?! Чисто загуглить алгоритм. Я ж не стою за спиной. Но мне важно, чтобы чел умел найти решение и мыслить, как программист.
   Волшебник
 
175 - 09.03.21 - 18:05
(136) Это скучно.
   rphosts
 
176 - 09.03.21 - 18:07
(172) если учесть, что от релиза к релизу часто данные одного релиза перетаскиваются в другой/другие другой структуры... в общем случае задача не такая тривиальная... если релиз новый - а ты ещё найди.
   rphosts
 
177 - 09.03.21 - 18:07
(174) (175) это как ответ на экзамене на вопрос преподавателя: "Как меня зовут?"? "Какого цвета учебник?"...
   rphosts
 
178 - 09.03.21 - 18:08
(176) *релиза = регистра
   Serg_1960
 
179 - 09.03.21 - 18:09
Функция Зеркало(ИсхСтрока,Знач х = 1)
    Возврат ?(х>СтрДлина(ИсхСтрока), "", Зеркало(ИсхСтрока,х+1) + Сред(ИсхСтрока,х,1));
КонецФункции
   rphosts
 
180 - 09.03.21 - 18:10
(179) рекурсия = злое зло.
И да "любая рекурсия заменяется циклом", хотя рекурсия красивее.
   O-Planet
 
181 - 09.03.21 - 18:11
Если за рекурсию говорить, то вот, на коленке набросал. Наверное, работает)

Функция Рек(Стр)
  Дл=СтрДлина(Стр);
  Возврат ?(Дл<=1,Стр,Прав(Стр,1)+Рек(Лев(Стр,Дл-1)));
КонецФункции
   Волшебник
 
182 - 09.03.21 - 18:14
(179)(180) При длинной строке вылетает с дампом
   Волшебник
 
183 - 09.03.21 - 18:15
(181) Использование рекурсии для этой задачи является грубой ошибкой. Задание на собеседовании с грубой ошибкой — это моветон.
   welwel
 
184 - 09.03.21 - 18:16
Приходилось в своё время проводить собеседование - просил написать на листе бумаги сортировку массива на любом языке (лишь бы не встроенным методом языка). Отсев был заметный, но за тех нескольких кандидатов, выдававших адекватный результат, не было впоследствии стыдно. Сделал сильно удививший меня вывод: всех прошедших этот простой тест можно нанимать кодером.
   O-Planet
 
185 - 09.03.21 - 18:16
(183) Вот хотю, чтобы солдат ломом подсел плац!
   Hans
 
186 - 09.03.21 - 18:16
(182) Мало того этот код не читатается. Другой программист потратит некоторое время что бы понять что этот код из 3х строк делает.
То ли дело с циклом, когда за пару сек становиться ясно что строка будет переворачиваться.
   O-Planet
 
187 - 09.03.21 - 18:18
(183) (186) Ни кто не просит рекурсию на собеседовании.
   Волшебник
 
188 - 09.03.21 - 18:19
(187) в (25) прозвучало
>> Не торопись. Тебе эту задачу нужно решить рекурсивно, не используя циклы
   Волшебник
 
189 - 09.03.21 - 18:21
(185) Ну если Вы сами ведёте себя неадекватно, то чего Вы хотите от кандидатов? Существует закон притяжения и это не про гравитацию.
   Krendel
 
190 - 09.03.21 - 18:21
(188) Это проверка уже на профпригодность программиста 1С, типа дали задачу по правке счет фактуры, а сдать ты должен правила расчета себеса
   Волшебник
 
191 - 09.03.21 - 18:25
(184) так можно?

СЗ = Новый СписокЗначений;
СЗ.ЗагрузитьЗначения(мас);
СЗ.СортироватьПоЗначению();
мас = СЗ.ВыгрузитьЗначения();
   rphosts
 
192 - 09.03.21 - 18:26
(182) на 8.2.13 при глубине рекурсии(тело функции из "Если и>0 Тогда Вызов(и-1); КонецЕсли;") около 4500 вылетало, как сейчас - вряд-ли намного лучше т.к. глубокие рекурсии не оптимально и очень срецифично
   O-Planet
 
193 - 09.03.21 - 18:29
(188) Так это ж я написал, что специально ему! Типа чтобы ещё 100к к з/п сверху добавить. Он же на вокзал побежал.
   Волшебник
 
194 - 09.03.21 - 18:29
(193) Если сделает запросом, накинь ему ещё сотку.
   wt
 
195 - 09.03.21 - 18:30
Я офигеваю от сегодняшних «специалистов» , что в (181). Им не интересны моменты, типа какое образование, какой ВУЗ, или иное, почему уволился с предыдущего места работы, есть ли вредные привычки, и в конце концов своего времени не жалко, чтобы из-за пары строк кода отказать кандидату. В конце концов есть же испытательный срок! Вам просто не нужны работники.
   rphosts
 
196 - 09.03.21 - 18:30
(184) пузырьковый - тоже сортировка непрошибаемая... но медленная... то-ли дело слиянием отсортированных групп, но коду будет прилично больше.
   O-Planet
 
197 - 09.03.21 - 18:31
(194) Да, план именно таков! И ещё 100 - если com-объект забацает на c#, решающий эту задачу, в блокноте прямо.
   rphosts
 
198 - 09.03.21 - 18:31
(195) так нету никаких таких кодеров на рынке... голяк!
   Волшебник
 
199 - 09.03.21 - 18:32
(196) Надо загнать в ТЗ, поместить во временную таблицу и отсортировать запросом на сервере.
   rphosts
 
200 - 09.03.21 - 18:33
(199) это слишком просто.
  1  2  3  4  5  6  7   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.