Вход | Регистрация
 

Пробить чек на ККМ не печатая его.

Пробить чек на ККМ не печатая его.
Я
   mishaPH
 
09.03.21 - 12:19
Собственно а можно ли "пробить" чек на ккм не выводя его на печать? например для онлайн платежа инет магазина, или клиенту не нужна бумажка шлите на емейл из офд и т.п.
   piter3
 
1 - 09.03.21 - 12:21
Да.
   Исновая
 
2 - 09.03.21 - 12:38
В штрихе в таблицах откл, в атоле только через код
   mishaPH
 
Модератор
3 - 09.03.21 - 12:43
(2) атол у нас. т.е. можно передавать чек программно из 1с на ккм, без печати оного?
не посдскажите как?
   mishaPH
 
Модератор
4 - 09.03.21 - 12:43
какая команда
   mishaPH
 
Модератор
5 - 09.03.21 - 12:46
атол 10 только переходим. нет еще ккм почти. либо забить и сделать только для 10го.

но в идеале и для 8го и для 10го как откл печать бумаги
   KoalaJustKoala
 
6 - 09.03.21 - 12:48
(0) мы для таких случаев эмулятором пользуемся, но где его брать я честное слово хз(((
   Исновая
 
7 - 09.03.21 - 12:48
(3) через интеграционную компоненту никак
   mishaPH
 
Модератор
8 - 09.03.21 - 12:49
(7) через драйвер никак?
   mishaPH
 
Модератор
9 - 09.03.21 - 12:52
хотя вот нашел у атола Чтобы чек не печатался (электронный чек), нужно установить параметру LIBFPTR_PARAM_RECEIPT_ELECTRONICALLY значение true.
   Irbis
 
10 - 09.03.21 - 12:55
(0) Да, больше миллиона таких чеков в месяц делаем.
   mishaPH
 
Модератор
11 - 09.03.21 - 12:58
(10) атол? какая версия
   Irbis
 
12 - 09.03.21 - 13:09
Атол-онлайн. Кассы в аренде, расходники (ФН) оплачиваются отдельно, регистрируем в ФНС сами, ОФД не Атол (так сложилось). Реестры грузятся в 1С, и фоновым заданием через  API отправляются на ферму касс в 2 потока (разделение каналов поступления денег). При нормальном интернете пробивали более 200 тыс. чеков в сутки.
Но ставить нужно минимум 2 ККТ, чтобы обеспечить непрерывность приёма ДС, в том числе и при заменен накопителей.
   mishaPH
 
Модератор
13 - 09.03.21 - 13:13
(12) не ну с онлайн кассами тут проще. просто есть касса в магазине и иногда продажа идет из магазина по срочной доставке там курьерами и т.п. чек при оплате идет онлайн итак а бумажка никому не нужна и кассиров путает
   Irbis
 
14 - 09.03.21 - 13:16
(13) Неужели бумаги жалко? Мы сейчас запустили несколько десятков касс, так на одну оплату из одного товара слип+чек аж в 24 см выходит. Хорошо хоть платежей немного. Я бы наеборот чтобы не путать никого сделал бы всё одинаково.
   mishaPH
 
Модератор
15 - 09.03.21 - 13:48
(14) это гемор для тупых продавцов . нет бумаги нет проблем
   HawkEye
 
16 - 09.03.21 - 15:37
(5)
в 8-ом так:
// CheckMode - Режим формирования чека:
//  0 - только в электронном виде без печати на чековой ленте

//  1 - печатать на чековой ленте
driver.CheckMode = 0;

но тогда помомему обязательно заполнить тэг 1008
   mishaPH
 
Модератор
17 - 09.03.21 - 17:38
(16) большое мерси. попробую
   ЦТО-шник
 
18 - 09.03.21 - 20:53
В настройках ккт можно отключить через таблицы, опция специально для инет магазинов
   mishaPH
 
Модератор
19 - 09.03.21 - 21:06
(18) это реальный маг. надо и так и так. и продавца чтобы у прилавка не дергать и манагер выбивает чек удаленно продавая с этого магазина. А курьер пришел забрал
   Исновая
 
20 - 09.03.21 - 21:48
(18) тоьько в штрих м.както так, и она не для инет магазинов
   opus70
 
21 - 10.03.21 - 08:51
(19) все это хорошо только кто недостачю будет покрывать от таких моментов
   mishaPH
 
Модератор
22 - 10.03.21 - 08:58
(21) какая недостача. идет по каналу безнала и отд секции . кассир отвечает только за нал.

сейчас продавец тупо бумажки выкидывает
   serpentt
 
23 - 10.03.21 - 11:25
(17) Есть маленький нюанс, если не хотите печатать чек И ОТСЫЛАТЬ его электронно покупателю

то должна быть определенная последовательность, иначе чек все равно выйдет на печать...

ОбъектECR.NewDocument();
ОбъектECR.CheckType = 1;
ОбъектECR.CheckMode = 0;//     0 - только в электронном виде без печати на чековой ленте


ОбъектECR.OpenCheck();

// 1008 Всегда ПЕРВЫЙ после OpenCheck()

//{ "1008" Запись контакта покупателя для отправки электронного чека
ОбъектECR.AttrNumber = 1008;
ОбъектECR.AttrValue  = МайлТелефон//"+79091235566" или "sergey@milkopt.ru"

ОбъектECR.WriteAttribute();
//}
   serpentt
 
24 - 10.03.21 - 11:26
(23) Атол ДТО-8
   mishaPH
 
Модератор
25 - 10.03.21 - 11:28
(23) да емейл заполняеем.
сделаю первым
   mishaPH
 
Модератор
26 - 11.03.21 - 08:40
(23) гм. а у меня нигде нет NewDocument();

                Объект.CancelCheck(); при завершении 
есть нал безнал, емейл 1008
есть             Объект.Регистрация(); при строках.
   mishaPH
 
Модератор
27 - 11.03.21 - 08:42
так начинается код печати чека. еще остатки штатного fr_com
    Если ПустоеЗначение(Объект) = 1 Тогда
        ОписаниеРезультата = "устройство не подключено";
        Возврат 0;
    ИначеЕсли ПодключитьсяКФР(Объект) = 0 Тогда
        Возврат 0;
    КонецЕсли;
    
    
    Объект.Mode = 1;// режим регистрации чеков

    Объект.Password = Пароль;// пароль на режим регистрации

    
    Объект.SetMode();
    Объект.GetStatus();
    Если Объект.СостояниеЧека <> 0 Тогда        
        Попытка
            Объект.CancelCheck();
        Исключение
        КонецПопытки;
    КонецЕсли;
    
    Если Объект.Результат <> 0 Тогда
        Попытка
            Объект.CancelCheck();
        Исключение
        КонецПопытки;
        ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
        ОтключитьсяОтФР(Объект, 0);
        Возврат 0;
    КонецЕсли;
    
    // регистрация товаров

    РезРегистрация = 1;
    СписокТоваров.ВыбратьСтроки();            
    ДлинаНаименования = Объект.ДлинаСтрокиСимволов;// зависит от модели ФР

    

    Если ЕмейлКлиентаДляОФД <> "" Тогда
        Объект.AttrNumber = 1008;
        Объект.AttrValue = СокрЛп(ЕмейлКлиентаДляОФД);
        Объект.WriteAttribute();
    КонецЕсли;
    
    Если Кассир <> "" Тогда
        Объект.AttrNumber = 1021;
        Объект.AttrValue = СокрЛп(Кассир);
        Объект.AttrPrint = 1;
        Объект.WriteAttribute();
    КонецЕсли;

    Если КассирИНН <> "" Тогда
        Объект.AttrNumber = 1203;
        Объект.AttrValue = СокрЛп(КассирИНН);
        Объект.AttrPrint = 1;
        Объект.WriteAttribute();
    КонецЕсли;
   serpentt
 
28 - 11.03.21 - 13:12
(26) NewDocument ()

Данные метод является сервисным и представляет собой логическое сочетание нескольких
кассовых операций (Запросы
GetStatus (), SetMode (), CancelCheck () и т.д.).
Выполнение этого метода следует производить перед открытием любого документа (открытие
чека, печать отчета и др.), при этом выполняются следующие действия:
если чек открыт, он будет отменен;
 выполняется запрос некоторых параметров ККМ;
 драйвер возвращает ошибки, возникающие в работе ККМ;
 выполняется попытка войти в режим, указанный в свойстве Mode.

http://fs.atol.ru/_layouts/15/atol.templates/Handlers/FileHandler.ashx?guid=48f67bf7-0787-459e-b520-d2f5ac78fe26&webUrl=
   mishaPH
 
Модератор
29 - 11.03.21 - 15:02
(28) да я понимаю. но в моем коде этого нет. хотя все работает


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.