Вход | Регистрация
 

Отбор в динамическом списке

Отбор в динамическом списке
Я
   Varlant1n
 
05.03.21 - 18:15
Здравствуйте! Есть динамический список на форме и есть реквизит с типом булево "ТолькоНеОтгруженные".

При открытии формы отбор срабатывает. Но когда убирается галочка список полностью опустошается.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ТолькоНеОтгруженные = Истина;
    ОтборСписокДокументов(НЕ ТолькоНеОтгруженные);
КонецПроцедуры

&НаСервере
Процедура ОтборСписокДокументов(ИспользоватьОтбор)
    Отбор = СписокДокументов.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    Отбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Отгружено");
    Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
    Отбор.Использование = Истина;
    Отбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
    Отбор.ПравоеЗначение = ИспользоватьОтбор;
КонецПроцедуры

&НаКлиенте
Процедура ТолькоНеОтгруженныеПриИзменении(Элемент)
    ОтборСписокДокументов(ТолькоНеОтгруженные);
КонецПроцедуры

Как думаете в чем проблема? Спасибо заранее!
   PR
 
1 - 05.03.21 - 18:18
(0) Проблема в том, что нужно менять существующий отбор, а не добавлять новый
   Varlant1n
 
2 - 05.03.21 - 18:19
(1) Так я и меняю его, разве нет?
   ДенисЧ
 
3 - 05.03.21 - 18:21
(2) Если ты выражение "Элементы.Добавить" называешь "меняю", тогда я, как говорится... Ля пилоте дель Спанья
   PR
 
4 - 05.03.21 - 18:22
(2) Да, его
Но только первый раз
   Varlant1n
 
5 - 05.03.21 - 18:24
(4) А как это можно грамотно реализовать?
   PR
 
6 - 05.03.21 - 18:27
(5) Эээ... ну я даже не знаю, мне кажется, начинать надо с изучения того, что такое программирование, с чем его там вообще едят, потом понять синтаксис и объекты ЯП, на котором ты собираешься программировать
Ну или специалиста вызвать, это быстрее
   PR
 
7 - 05.03.21 - 18:27
+(6) Дарю лайфхак, вдруг поможет
Ctrl + F1
   Varlant1n
 
8 - 05.03.21 - 18:32
(7) Спасибо огромное за помощь, друг! Я последую Вашему совету. Спасибо еще раз за помощь. Я очень рад, что на данном форуме такие добрые люди, которые помогают начинающим. Удачи Вам в будущем во всех Ваших начинаниях!
   PR
 
9 - 05.03.21 - 18:37
(8) Дружище, на нашем форуме помогают людям, а не делают за них
Открой синтакс-помощник и изучи методы объекта, с которым ты работаешь
Ну то есть сделай (7)
   Andreyyy
 
10 - 05.03.21 - 18:37
(8) Так помогли же, указали на ошибку. Это 99% успеха.
   PR
 
11 - 05.03.21 - 18:38
А друг (0) было от чистого сердца?... Да ну, не может быть
   PR
 
12 - 05.03.21 - 18:39
+(11) В смысле, не (0), а (8)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.