Вход | Регистрация
 

Как работает РольДоступна()

Как работает РольДоступна()
Я
   ArturDoo
 
04.03.21 - 16:25
1С:ERP Управление предприятием 2 (2.4.12.64)
Доброго времени суток. Нужно ограничить Изменения на форме, в зависимости от статуса, но кому-то нужно оставить. Сделал такую проверку:
&НаКлиенте
Процедура ИнтроС_ПриОткрытииПеред(Отказ)
    Если Строка(ЭтаФорма.Состояние) = "Закрыт" Тогда
                Разрешить = ПроверкаПравНаСервере();
                Если НЕ Разрешить Тогда
                    Сообщить("У вас нет прав на изменение Утверждённых спецификаций!", СтатусСообщения.Важное);
                ЭтаФорма.ТолькоПросмотр = Истина;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
&НаСервере
Функция ПроверкаПравНаСервере ()
    ПраваНаИзменение = РольДоступна("1Тест");
    Возврат (ПраваНаИзменение);
КонецФункции;

Создал себе новую группу, профиль, добавил в него роль - "1Тест".
Сиду под полными правами, если это из-за них - плохо
Как сделать правильно?
   Beduin
 
1 - 04.03.21 - 16:28
Пользователи.ЭтоПолноправныйПользователь(,,ЛОЖЬ)
   ArturDoo
 
2 - 04.03.21 - 16:30
(1) Не все пользователи с полнымиПравами должны мочь редактировать
   Андроны едут
 
3 - 04.03.21 - 16:45
(0) В конфигураторе укажи свою роль для нужных пользователей. Профили не контролируют пользователей с полными правами.
   ArturDoo
 
4 - 04.03.21 - 16:48
(3) Помогло, спасибо большое
   Mankubus
 
5 - 04.03.21 - 18:01
(4) это поможет до первого обновления ролей. потом все что добавлено в конфигураторе сотрется
не нужно добавлять роли в конфигураторе
   Mankubus
 
6 - 04.03.21 - 18:01
(2) это противоречит концепции полных прав. придумайте другую настройку, например через доп права пользователей
   FIXXXL
 
7 - 04.03.21 - 18:29
(0) как вариант, сделай ГруппуДоступа под твою проверку и проверяй входит ли пользователь в Группу
но если у вас кто попало имеет ПолныеПрава, может и в группах нашалить...

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.